summaryrefslogtreecommitdiffstats
path: root/libraries/pygame
diff options
context:
space:
mode:
author hollywoodb2010-05-11 14:56:24 +0200
committer Robby Workman2010-05-11 14:56:24 +0200
commit1b1f9cecb048b3f44008a69e0aa6d40dab6573e0 (patch)
treef19e16ab893275995eed9a902a2c7e24432b9c8c /libraries/pygame
parentc4c982bcfd379d1616b3a5f2ec3f839faa438f2e (diff)
downloadslackbuilds-1b1f9cecb048b3f44008a69e0aa6d40dab6573e0.tar.gz
libraries/pygame: Initial import
Diffstat (limited to 'libraries/pygame')
-rw-r--r--libraries/pygame/README6
-rw-r--r--libraries/pygame/pygame.SlackBuild59
-rw-r--r--libraries/pygame/pygame.info8
-rw-r--r--libraries/pygame/slack-desc11
4 files changed, 84 insertions, 0 deletions
diff --git a/libraries/pygame/README b/libraries/pygame/README
new file mode 100644
index 0000000000..3612e2b1ef
--- /dev/null
+++ b/libraries/pygame/README
@@ -0,0 +1,6 @@
+Pygame is a set of Python modules designed for writing games.
+
+It is written on top of the excellent SDL library. This allows you to create
+fully featured games and multimedia programs in the python language. Pygame
+is highly portable and runs on nearly every platform and operating system.
+
diff --git a/libraries/pygame/pygame.SlackBuild b/libraries/pygame/pygame.SlackBuild
new file mode 100644
index 0000000000..1da5a331bc
--- /dev/null
+++ b/libraries/pygame/pygame.SlackBuild
@@ -0,0 +1,59 @@
+#!/bin/sh
+
+## Written by hollywoodb (hollywoodb@fastmail.fm)
+
+# Verify script is being run by root user.
+if [ "$(id -u)" != "0" ]; then
+ echo "This script must be run as root!"
+ exit
+fi
+
+NAME=pygame
+VERSION=1.7.1
+SRCVERSION=${VERSION}release
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$NAME
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+tar -xzvf $CWD/$NAME-$SRCVERSION.tar.gz || exit 1
+cd $NAME-$SRCVERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python config.py || exit 1
+
+# Let's build the installable tarball, but we'll wait just a bit
+# to extract it into $PKG
+python setup.py bdist || exit 1
+
+mkdir -p $PKG/usr/doc/$NAME-$VERSION
+cp -a PKG-INFO WHATSNEW install.html readme.txt docs/* examples \
+ $PKG/usr/doc/$NAME-$VERSION
+cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Let's extract the installable tarball now into $PKG
+# Since we're in the right place, strip everything and build the package
+cd $PKG
+tar -xzf $TMP/$NAME-$SRCVERSION/dist/$NAME-$SRCVERSION.linux-i686.tar.gz || exit 1
+find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+/sbin/makepkg -l y -c n -p $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/pygame/pygame.info b/libraries/pygame/pygame.info
new file mode 100644
index 0000000000..6d2315179e
--- /dev/null
+++ b/libraries/pygame/pygame.info
@@ -0,0 +1,8 @@
+PRGNAM="pygame"
+VERSION="1.7.1"
+HOMEPAGE="http://www.pygame.org/"
+DOWNLOAD="http://www.pygame.org/ftp/pygame-1.7.1release.tar.gz"
+MD5SUM="05d86d1af446f79411359400951053b7"
+MAINTAINER="hollywoodb"
+EMAIL="hollywoodb@fastmail.fm"
+APPROVED="robw810"
diff --git a/libraries/pygame/slack-desc b/libraries/pygame/slack-desc
new file mode 100644
index 0000000000..24f5c3f4a1
--- /dev/null
+++ b/libraries/pygame/slack-desc
@@ -0,0 +1,11 @@
+pygame: pygame (a set of Python modules designed for writing games)
+pygame:
+pygame: pygame is written on top of the excellent SDL library. This allows you
+pygame: to create fully featured games and multimedia programs in the python
+pygame: language. Pygame is highly portable and runs on nearly every platform
+pygame: and operating system.
+pygame:
+pygame: Pygame is free. Released under the LGPL licence, you can create open
+pygame: source, free, freeware, shareware, and commercial games with it.
+pygame:
+pygame: