summaryrefslogtreecommitdiffstats
path: root/libraries/pyechonest
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-20 11:35:05 +0100
committer Erik Hanson2014-01-30 06:20:27 +0100
commit73da4d1c1dbd004da9e1956667c44e4925fdfc05 (patch)
tree9fa913f3cb30d7319832daaf848ecffd92b34535 /libraries/pyechonest
parent17babbcf56b377b2072259e904b303268480b0a0 (diff)
downloadslackbuilds-73da4d1c1dbd004da9e1956667c44e4925fdfc05.tar.gz
libraries/pyechonest: Added (Python interf. for Echo Nest APIs).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/pyechonest')
-rw-r--r--libraries/pyechonest/README18
-rw-r--r--libraries/pyechonest/pyechonest.SlackBuild89
-rw-r--r--libraries/pyechonest/pyechonest.info10
-rw-r--r--libraries/pyechonest/slack-desc19
4 files changed, 136 insertions, 0 deletions
diff --git a/libraries/pyechonest/README b/libraries/pyechonest/README
new file mode 100644
index 0000000000..52976aa5b9
--- /dev/null
+++ b/libraries/pyechonest/README
@@ -0,0 +1,18 @@
+Tap into The Echo Nest's Musical Brain for the best music search,
+information, recommendations and remix tools on the web.
+
+Pyechonest is an open source Python library for the Echo Nest API.
+With Pyechonest you have Python access to the entire set of API
+methods including:
+
+- artist - search for artists by name, description, or attribute,
+ and get back detailed information about any artist including audio,
+ similar artists, blogs, familiarity, hotttnesss, news, reviews,
+ urls and video.
+- song - search songs by artist, title, description, or attribute
+ (tempo, duration, etc) and get detailed information back about each
+ song, such as hotttnesss, audio_summary, or tracks.
+- track - upload a track to the Echo Nest and receive summary
+ information about the track including key, duration, mode, tempo,
+ time signature along with detailed track info including timbre,
+ pitch, rhythm and loudness information.
diff --git a/libraries/pyechonest/pyechonest.SlackBuild b/libraries/pyechonest/pyechonest.SlackBuild
new file mode 100644
index 0000000000..435b97895b
--- /dev/null
+++ b/libraries/pyechonest/pyechonest.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for pyechonest
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyechonest
+VERSION=${VERSION:-8.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+PYTHON=python
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+$PYTHON setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.md PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyechonest/pyechonest.info b/libraries/pyechonest/pyechonest.info
new file mode 100644
index 0000000000..68cb02f363
--- /dev/null
+++ b/libraries/pyechonest/pyechonest.info
@@ -0,0 +1,10 @@
+PRGNAM="pyechonest"
+VERSION="8.0.1"
+HOMEPAGE="https://github.com/echonest/pyechonest"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pyechonest/pyechonest-8.0.1.tar.gz"
+MD5SUM="b097c886dafcf7c5e024818dba5b05d0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/pyechonest/slack-desc b/libraries/pyechonest/slack-desc
new file mode 100644
index 0000000000..244e52f952
--- /dev/null
+++ b/libraries/pyechonest/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyechonest: pyechonest (Python interface to The Echo Nest APIs)
+pyechonest:
+pyechonest: Tap into The Echo Nest's Musical Brain for the best music search,
+pyechonest: information, recommendations and remix tools on the web.
+pyechonest: Pyechonest is an open source Python library for the Echo Nest API.
+pyechonest: With Pyechonest you have Python access to the entire set of API
+pyechonest: methods.
+pyechonest:
+pyechonest: homepage: https://github.com/echonest/pyechonest
+pyechonest:
+pyechonest: