summaryrefslogtreecommitdiffstats
path: root/libraries/pyPEG2/pyPEG2.SlackBuild
diff options
context:
space:
mode:
author Edinaldo P. Silva2017-12-20 23:43:17 +0100
committer Willy Sudiarto Raharjo2017-12-21 02:19:31 +0100
commitff24b0ba7a7ab750ac096c0b29ff775e661787fa (patch)
tree12abec0a0ebdec4401dc825ffdb620b9421e6a43 /libraries/pyPEG2/pyPEG2.SlackBuild
parentb5cde734ad415c3b5b126b0c11e4f0fc13496c2c (diff)
downloadslackbuilds-ff24b0ba7a7ab750ac096c0b29ff775e661787fa.tar.gz
libraries/pyPEG2: Add python3 support.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries/pyPEG2/pyPEG2.SlackBuild')
-rw-r--r--libraries/pyPEG2/pyPEG2.SlackBuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/libraries/pyPEG2/pyPEG2.SlackBuild b/libraries/pyPEG2/pyPEG2.SlackBuild
index 1b9ed36ae6..669bcfbf82 100644
--- a/libraries/pyPEG2/pyPEG2.SlackBuild
+++ b/libraries/pyPEG2/pyPEG2.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pyPEG2
VERSION=${VERSION:-2.15.2}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,8 +69,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+python setup.py build
python setup.py install --root=$PKG
+# Build mutagen with python3. Default is no.
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py build
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true