summaryrefslogtreecommitdiffstats
path: root/libraries/poco/poco_x64.patch
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-03-13 08:34:57 +0100
committer Erik Hanson2014-03-21 19:01:14 +0100
commit07474dacc2d35d41227460a2ad36e39ab8cd802b (patch)
treef3adbca34477094d8e535e94da862afe99016e44 /libraries/poco/poco_x64.patch
parent7c579abbd5df812ce3404284a232c9344e510b54 (diff)
downloadslackbuilds-07474dacc2d35d41227460a2ad36e39ab8cd802b.tar.gz
libraries/poco: Added (C++ class libraries).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/poco/poco_x64.patch')
-rw-r--r--libraries/poco/poco_x64.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/libraries/poco/poco_x64.patch b/libraries/poco/poco_x64.patch
new file mode 100644
index 0000000000..aeac7c1b06
--- /dev/null
+++ b/libraries/poco/poco_x64.patch
@@ -0,0 +1,22 @@
+--- poco-1.4.6p2-all/Makefile.original 2014-03-13 14:12:58.141661715 +0700
++++ poco-1.4.6p2-all/Makefile 2014-03-13 14:14:32.910933057 +0700
+@@ -33,7 +33,7 @@
+
+ install: libexecs
+ mkdir -p $(INSTALLDIR)/include/Poco
+- mkdir -p $(INSTALLDIR)/lib
++ mkdir -p $(INSTALLDIR)/lib64
+ mkdir -p $(INSTALLDIR)/bin
+ for comp in $(COMPONENTS) ; do \
+ if [ -d "$(POCO_BASE)/$$comp/include" ] ; then \
+@@ -43,8 +43,8 @@
+ find $(POCO_BUILD)/$$comp/bin -perm -700 -type f -exec cp -f {} $(INSTALLDIR)/bin \; ; \
+ fi ; \
+ done
+- find $(POCO_BUILD)/lib -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib \;
+- find $(POCO_BUILD)/lib -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib \;
++ find $(POCO_BUILD)/lib -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib64 \;
++ find $(POCO_BUILD)/lib -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib64 \;
+
+ libexecs = Foundation-libexec XML-libexec Util-libexec Net-libexec Crypto-libexec NetSSL_OpenSSL-libexec Data-libexec Data/SQLite-libexec Data/ODBC-libexec Data/MySQL-libexec Zip-libexec PageCompiler-libexec PageCompiler/File2Page-libexec
+ tests = Foundation-tests XML-tests Util-tests Net-tests Crypto-tests NetSSL_OpenSSL-tests Data-tests Data/SQLite-tests Data/ODBC-tests Data/MySQL-tests Zip-tests