summaryrefslogtreecommitdiffstats
path: root/libraries/physfs
diff options
context:
space:
mode:
author ponce2012-02-12 17:29:41 +0100
committer Robby Workman2012-08-21 22:36:50 +0200
commit3c0c9551d37f00b8ab41f104044c433e9ac30de9 (patch)
tree2236382c608d44d50d17880c768e1ebe822687ae /libraries/physfs
parent4fe4fafdaa3dc4346e64738347648c8628bfe75d (diff)
downloadslackbuilds-3c0c9551d37f00b8ab41f104044c433e9ac30de9.tar.gz
libraries/physfs: Fixed build with gcc-4.6 and turned off debug.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/physfs')
-rw-r--r--libraries/physfs/physfs.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/libraries/physfs/physfs.SlackBuild b/libraries/physfs/physfs.SlackBuild
index 5ee10e504f..ed5994a8ef 100644
--- a/libraries/physfs/physfs.SlackBuild
+++ b/libraries/physfs/physfs.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=physfs
VERSION=2.0.2
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -65,6 +65,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
+# while we cut away -Werror to make gcc-4.6 happy, we turn off debug too
+sed -i "s|-g -pipe -Werror|-pipe|" CMakeLists.txt
+
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \