summaryrefslogtreecommitdiffstats
path: root/libraries/libwhisker2/libwhisker2.SlackBuild
diff options
context:
space:
mode:
author Brenton Earl2016-12-15 01:00:52 +0100
committer Willy Sudiarto Raharjo2016-12-15 16:32:07 +0100
commitcad89d33a48cd034acee78a167dc31a6fe3efa9d (patch)
treee6a672edf9f116b296739c3361108aa1753a5334 /libraries/libwhisker2/libwhisker2.SlackBuild
parent1723090bf5df91cc4a91f454365872c1bf017908 (diff)
downloadslackbuilds-cad89d33a48cd034acee78a167dc31a6fe3efa9d.tar.gz
libraries/libwhisker2: Switch to i586.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/libwhisker2/libwhisker2.SlackBuild')
-rw-r--r--libraries/libwhisker2/libwhisker2.SlackBuild29
1 files changed, 12 insertions, 17 deletions
diff --git a/libraries/libwhisker2/libwhisker2.SlackBuild b/libraries/libwhisker2/libwhisker2.SlackBuild
index be2e8c1b8a..cce0b93052 100644
--- a/libraries/libwhisker2/libwhisker2.SlackBuild
+++ b/libraries/libwhisker2/libwhisker2.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=libwhisker2
-VERSION=2.5
+VERSION=${VERSION:-2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +42,8 @@ OUTPUT=${OUTPUT:-/tmp}
DOCS="CHANGES DISTRIBUTION KNOWNBUGS LICENSE README docs scripts"
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -71,28 +71,23 @@ cat $CWD/Makefiles.patch | patch -p1
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
make lib
make DESTDIR=$PKG \
MAN3PATH=/usr/man/man3 \
install
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-( cd $PKG
- find -L . \( -name "perllocal.pod" -o -name ".packlist" -o -name "*.bs" \) \
- -exec rm -f {} \;
-)
+find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION