summaryrefslogtreecommitdiffstats
path: root/libraries/libgnome/libgnome.SlackBuild
diff options
context:
space:
mode:
author Matteo Bernardini2019-08-18 16:29:50 +0200
committer Matteo Bernardini2019-08-18 16:29:50 +0200
commite81a89f1b6ccd3da8cffc51b431e0026126e34b9 (patch)
treed58abd1dad22c526d4bebefe25d34800370d6392 /libraries/libgnome/libgnome.SlackBuild
parentd04189e642ca17186cb9b2b5899fa9c12aceb782 (diff)
downloadslackbuilds-5f2831c3d36a91082430233bca817afd27cec528.tar.gz
20190818.2 global branch merge.current-20190818.2
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/libgnome/libgnome.SlackBuild')
-rw-r--r--libraries/libgnome/libgnome.SlackBuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/libraries/libgnome/libgnome.SlackBuild b/libraries/libgnome/libgnome.SlackBuild
index 15083db758..a05779e965 100644
--- a/libraries/libgnome/libgnome.SlackBuild
+++ b/libraries/libgnome/libgnome.SlackBuild
@@ -69,6 +69,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# https://github.com/voidlinux/void-packages/commit/f16a2d557e84f5d7f5ece8b2022aab4fd17aa0ce
+for f in $(find . -type f -exec file "{}" \; | grep "C source" | cut -d ':' -f1); do
+ echo "${f}"
+ recode ISO-8859-1..UTF-8 "${f}"
+done
+
# Fix for the newer glib
sed -i "/-DG_DISABLE_DEPRECATED/d" libgnome/Makefile.*