summaryrefslogtreecommitdiffstats
path: root/libraries/libevdevplus
diff options
context:
space:
mode:
author B. Watson2022-02-01 20:23:42 +0100
committer Willy Sudiarto Raharjo2022-02-06 05:42:46 +0100
commit2100c16126ec409667490d1ec7927ea99ca951a9 (patch)
tree7b21eff7ed99ce74b6e0df11d0b2759bb7600612 /libraries/libevdevplus
parentaeb45fc7bc76937b0dbba4536ba8fe6b124ca589 (diff)
downloadslackbuilds-2100c16126ec409667490d1ec7927ea99ca951a9.tar.gz
libraries/libevdevplus: Added (C++ event device lib).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/libevdevplus')
-rw-r--r--libraries/libevdevplus/README1
-rw-r--r--libraries/libevdevplus/libevdevplus.SlackBuild99
-rw-r--r--libraries/libevdevplus/libevdevplus.info10
-rw-r--r--libraries/libevdevplus/slack-desc19
4 files changed, 129 insertions, 0 deletions
diff --git a/libraries/libevdevplus/README b/libraries/libevdevplus/README
new file mode 100644
index 0000000000..468d6a05b3
--- /dev/null
+++ b/libraries/libevdevplus/README
@@ -0,0 +1 @@
+libevdevplus (easy-to-use event device library in C++)
diff --git a/libraries/libevdevplus/libevdevplus.SlackBuild b/libraries/libevdevplus/libevdevplus.SlackBuild
new file mode 100644
index 0000000000..e99bf1c6d9
--- /dev/null
+++ b/libraries/libevdevplus/libevdevplus.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/bash
+
+# Slackware build script for libevdevplus
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# Note: this version of libevdevplus is not the latest. It was chosen
+# because it's compatible with ytodool-0.1.9. Later versions of
+# libevdevplus have API changes that break it, plus upstream dropped
+# support for building a shared library, and got rid of "make install"
+# entirely.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=libevdevplus
+VERSION=${VERSION:-0.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+SRCNAM=libevdevPlus
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_CXX_FLAGS_RELEASE="$SLKCFLAGS -DNDEBUG" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make VERBOSE=1
+ make install/strip DESTDIR=$PKG
+cd ..
+
+# No cmake option to disable the static lib. Could patch CMakeLists.txt,
+# or just do this:
+rm -f $PKG/usr/lib*/*.a
+
+# This binary looks useful, but isn't installed by default.
+mkdir -p $PKG/usr/bin
+install -s build/evdevPlus_test $PKG/usr/bin
+
+# README.md is really just a placeholder. Include it to avoid people
+# wondering why there's no README.
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE* README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/libevdevplus/libevdevplus.info b/libraries/libevdevplus/libevdevplus.info
new file mode 100644
index 0000000000..727e30f3e8
--- /dev/null
+++ b/libraries/libevdevplus/libevdevplus.info
@@ -0,0 +1,10 @@
+PRGNAM="libevdevplus"
+VERSION="0.1.1"
+HOMEPAGE="https://github.com/YukiWorkshop/libevdevPlus/"
+DOWNLOAD="https://github.com/YukiWorkshop/libevdevPlus/archive/v0.1.1/libevdevPlus-0.1.1.tar.gz"
+MD5SUM="fda5c9e24ac6db31ee595595ad6305c8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/libraries/libevdevplus/slack-desc b/libraries/libevdevplus/slack-desc
new file mode 100644
index 0000000000..83fd137563
--- /dev/null
+++ b/libraries/libevdevplus/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libevdevplus: libevdevplus (easy-to-use event device library in C++)
+libevdevplus:
+libevdevplus:
+libevdevplus:
+libevdevplus:
+libevdevplus:
+libevdevplus:
+libevdevplus:
+libevdevplus:
+libevdevplus:
+libevdevplus: