summaryrefslogtreecommitdiffstats
path: root/libraries/fpconst
diff options
context:
space:
mode:
author Larry Hajali2010-05-12 23:30:10 +0200
committer David Somero2010-05-12 23:30:10 +0200
commit7f3fa8f9ac1651e2d88fa73f5a716972c85ca067 (patch)
treecb1d50dd98d46dd430a2804c586e994f6be61048 /libraries/fpconst
parentf37db1111955832906878ef5d923870b62d39832 (diff)
downloadslackbuilds-7f3fa8f9ac1651e2d88fa73f5a716972c85ca067.tar.gz
libraries/fpconst: Added to 12.2 repository
Diffstat (limited to 'libraries/fpconst')
-rw-r--r--libraries/fpconst/README5
-rw-r--r--libraries/fpconst/fpconst.SlackBuild50
-rw-r--r--libraries/fpconst/fpconst.info8
-rw-r--r--libraries/fpconst/slack-desc20
4 files changed, 83 insertions, 0 deletions
diff --git a/libraries/fpconst/README b/libraries/fpconst/README
new file mode 100644
index 0000000000..e7ce665eda
--- /dev/null
+++ b/libraries/fpconst/README
@@ -0,0 +1,5 @@
+Utilities for handling IEEE 754 floating point special values.
+This python module implements constants and functions for working with
+IEEE754 double-precision special values. It provides constants for
+Not-a-Number (NaN), Positive Infinity (PosInf), and Negative Infinity
+(NegInf), as well as functions to test for these values. \ No newline at end of file
diff --git a/libraries/fpconst/fpconst.SlackBuild b/libraries/fpconst/fpconst.SlackBuild
new file mode 100644
index 0000000000..b9be16a67a
--- /dev/null
+++ b/libraries/fpconst/fpconst.SlackBuild
@@ -0,0 +1,50 @@
+#!/bin/sh
+
+# Slackware build script for fpconst
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=fpconst
+VERSION=${VERSION:-0.7.3}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG COPYING MANIFEST PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/fpconst/fpconst.info b/libraries/fpconst/fpconst.info
new file mode 100644
index 0000000000..0f303f8ad4
--- /dev/null
+++ b/libraries/fpconst/fpconst.info
@@ -0,0 +1,8 @@
+PRGNAM="fpconst"
+VERSION="0.7.3"
+HOMEPAGE="http://pypi.python.org/pypi/fpconst/"
+DOWNLOAD="http://downloads.sourceforge.net/rsoap/fpconst-0.7.3.tar.gz"
+MD5SUM="13884b81da3335b2ec4b6ea1dc26b6fa"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/libraries/fpconst/slack-desc b/libraries/fpconst/slack-desc
new file mode 100644
index 0000000000..92e8c676ac
--- /dev/null
+++ b/libraries/fpconst/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+fpconst: fpconst (Utilities for IEEE 754 floating point special values)
+fpconst:
+fpconst: Utilities for handling IEEE 754 floating point special values. This
+fpconst: python module implements constants and functions for working with
+fpconst: IEEE754 double-precision special values. It provides constants for
+fpconst: Not-a-Number (NaN), Positive Infinity (PosInf), and Negative Infinity
+fpconst: (NegInf), as well as functions to test for these values.
+fpconst:
+fpconst: Homepage: http://pypi.python.org/pypi/fpconst/
+fpconst:
+fpconst:
+ \ No newline at end of file