summaryrefslogtreecommitdiffstats
path: root/libraries/OpenSceneGraph
diff options
context:
space:
mode:
author Matteo Bernardini2019-08-18 12:30:18 +0200
committer Robby Workman2021-04-18 05:59:37 +0200
commita76ced6dfda5e07f0910fcf02702c39280d45478 (patch)
treec53640f8d80fdb383b3b01d3d8e8dcb7ee7d4d58 /libraries/OpenSceneGraph
parenta7313e3532d7dd899e331dc07e388fa7b88d4d27 (diff)
downloadslackbuilds-a76ced6dfda5e07f0910fcf02702c39280d45478.tar.gz
libraries/OpenSceneGraph: Fix building against wxGTK3.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/OpenSceneGraph')
-rw-r--r--libraries/OpenSceneGraph/0008-Fix_wxWidgets_gl.patch12
-rw-r--r--libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild3
2 files changed, 15 insertions, 0 deletions
diff --git a/libraries/OpenSceneGraph/0008-Fix_wxWidgets_gl.patch b/libraries/OpenSceneGraph/0008-Fix_wxWidgets_gl.patch
new file mode 100644
index 0000000000..70cc792eb8
--- /dev/null
+++ b/libraries/OpenSceneGraph/0008-Fix_wxWidgets_gl.patch
@@ -0,0 +1,12 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -763,8 +763,7 @@ IF (BUILD_OSG_EXAMPLES AND NOT ANDROID
+ FIND_PACKAGE(GLUT)
+ FIND_PACKAGE(FOX)
+
+- SET(wxWidgets_USE_LIBS base core gl net)
+- FIND_PACKAGE(wxWidgets)
++ FIND_PACKAGE(wxWidgets COMPONENTS base core gl net)
+
+ ENDIF(BUILD_OSG_EXAMPLES AND NOT ANDROID)
+
diff --git a/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild b/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
index a158f30565..41183973f1 100644
--- a/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
+++ b/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
@@ -59,6 +59,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Work around for wx_gtk3_gl library not being linked with - thanks fedora
+patch -p1 < $CWD/0008-Fix_wxWidgets_gl.patch
+
mkdir -p build
cd build
cmake .. \