summaryrefslogtreecommitdiffstats
path: root/libraries/OpenSceneGraph
diff options
context:
space:
mode:
author Matteo Bernardini2020-01-01 17:38:37 +0100
committer Matteo Bernardini2020-01-01 17:38:37 +0100
commit6ed778974da2cbb6b73ea66a5447d9512f6fa77b (patch)
tree665223f87657bbf381d630897e66501a4c58e65d /libraries/OpenSceneGraph
parent82bbd880da5d554ddb98a82fcf8c17cc2131d56a (diff)
downloadslackbuilds-6ed778974da2cbb6b73ea66a5447d9512f6fa77b.tar.gz
20200101.2 global branch merge.current-20200101.2
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/OpenSceneGraph')
-rw-r--r--libraries/OpenSceneGraph/0008-Fix_wxWidgets_gl.patch12
-rw-r--r--libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild3
2 files changed, 15 insertions, 0 deletions
diff --git a/libraries/OpenSceneGraph/0008-Fix_wxWidgets_gl.patch b/libraries/OpenSceneGraph/0008-Fix_wxWidgets_gl.patch
new file mode 100644
index 0000000000..70cc792eb8
--- /dev/null
+++ b/libraries/OpenSceneGraph/0008-Fix_wxWidgets_gl.patch
@@ -0,0 +1,12 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -763,8 +763,7 @@ IF (BUILD_OSG_EXAMPLES AND NOT ANDROID
+ FIND_PACKAGE(GLUT)
+ FIND_PACKAGE(FOX)
+
+- SET(wxWidgets_USE_LIBS base core gl net)
+- FIND_PACKAGE(wxWidgets)
++ FIND_PACKAGE(wxWidgets COMPONENTS base core gl net)
+
+ ENDIF(BUILD_OSG_EXAMPLES AND NOT ANDROID)
+
diff --git a/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild b/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
index a158f30565..41183973f1 100644
--- a/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
+++ b/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
@@ -59,6 +59,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Work around for wx_gtk3_gl library not being linked with - thanks fedora
+patch -p1 < $CWD/0008-Fix_wxWidgets_gl.patch
+
mkdir -p build
cd build
cmake .. \