summaryrefslogtreecommitdiffstats
path: root/ham
diff options
context:
space:
mode:
author Howard Pepper2012-12-02 18:38:17 +0100
committer dsomero2012-12-11 22:21:54 +0100
commita46a29f823d605d7bebbc04c25b62eaa992d2423 (patch)
tree51ad5d12ca018fab55ae5beded23b4d5a3117ad4 /ham
parent2ddff304643ba185ae73be02bb97bedf7a802629 (diff)
downloadslackbuilds-a46a29f823d605d7bebbc04c25b62eaa992d2423.tar.gz
ham/hamlib: Updated for version 1.2.15 and moved from libraries
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'ham')
-rw-r--r--ham/hamlib/README5
-rw-r--r--ham/hamlib/hamlib.SlackBuild101
-rw-r--r--ham/hamlib/hamlib.info10
-rw-r--r--ham/hamlib/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/ham/hamlib/README b/ham/hamlib/README
new file mode 100644
index 0000000000..a32e1b757d
--- /dev/null
+++ b/ham/hamlib/README
@@ -0,0 +1,5 @@
+hamlib (the ham radio control libraries)
+
+hamlib is a development effort to provide a consistent interface
+for programmers wanting to incorporate radio controls in their
+programs.
diff --git a/ham/hamlib/hamlib.SlackBuild b/ham/hamlib/hamlib.SlackBuild
new file mode 100644
index 0000000000..b64d44d032
--- /dev/null
+++ b/ham/hamlib/hamlib.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# SlackBuild script for hamlib.
+
+# Copyright 2010 Howard Pepper <h_pepper {at} bellsouth [dot] net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=hamlib
+VERSION=1.2.15
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="AUTHORS COPYING COPYING.LIB ChangeLog INSTALL LICENSE NEWS PLAN
+ README README.betatester README.developer THANKS TODO"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --enable-shared
+
+# Fix linking when --libdir=/usr/lib64
+sed -i \
+ -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
+ src/Makefile || exit
+
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# No manpages are installed
+rm -rf $PKG/usr/man
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/ham/hamlib/hamlib.info b/ham/hamlib/hamlib.info
new file mode 100644
index 0000000000..3891b286dc
--- /dev/null
+++ b/ham/hamlib/hamlib.info
@@ -0,0 +1,10 @@
+PRGNAM="hamlib"
+VERSION="1.2.15"
+HOMEPAGE="http://sourceforge.net/apps/mediawiki/hamlib/index.php?title=Main_Page"
+DOWNLOAD="http://downloads.sourceforge.net/hamlib/hamlib-1.2.15.tar.gz"
+MD5SUM="8c10041b75d41a8b585a78fd14564387"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Howard Pepper"
+EMAIL="h_pepper <at> bellsouth {dot} net"
diff --git a/ham/hamlib/slack-desc b/ham/hamlib/slack-desc
new file mode 100644
index 0000000000..c940a29ab4
--- /dev/null
+++ b/ham/hamlib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+hamlib: hamlib (the ham radio control libraries)
+hamlib:
+hamlib: hamlib is a development effort to provide a consistent interface
+hamlib: for programmers wanting to incorporate radio controls in their
+hamlib: programs.
+hamlib:
+hamlib: Homepage: http://www.hamlib.org
+hamlib:
+hamlib:
+hamlib:
+hamlib: