summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author klaatu2020-01-07 10:10:18 +0100
committer Willy Sudiarto Raharjo2020-01-11 14:58:10 +0100
commitd28f4328ae89564a1220f71cbac64fe97b0a48dd (patch)
tree389216ce63a7bda10aa6a0e4d473992e2ee5fa4f /graphics
parent6057a1d91a85aa7a31cd01946dd4f41b3a825a9b (diff)
downloadslackbuilds-d28f4328ae89564a1220f71cbac64fe97b0a48dd.tar.gz
graphics/fontmatrix: removed. No updates in 10 years, Python2 only.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fontmatrix/README13
-rw-r--r--graphics/fontmatrix/doinst.sh9
-rw-r--r--graphics/fontmatrix/fontmatrix.SlackBuild104
-rw-r--r--graphics/fontmatrix/fontmatrix.info10
-rw-r--r--graphics/fontmatrix/slack-desc19
5 files changed, 0 insertions, 155 deletions
diff --git a/graphics/fontmatrix/README b/graphics/fontmatrix/README
deleted file mode 100644
index d0db4dab95..0000000000
--- a/graphics/fontmatrix/README
+++ /dev/null
@@ -1,13 +0,0 @@
-Fontmatrix is a professional font manager and organiser.
-
-Fontmatrix is a manager built with the kind of features and abilities
-graphic designers, layout professionals along with others have felt
-necessary, but modernized with some new touches.
-
-Fontmatrix provides a font browser, organiser, and manager. It makes it
-easy to tag and group (or sub-group) fonts logically. It has extensive
-GUI support for showing all glyphs in a font, previews of sample text,
-variable sizing, and to reveal advanced Open Type features.
-
-Fontmatrix can also create a PDF catalogue of your fonts for printing or
-reference.
diff --git a/graphics/fontmatrix/doinst.sh b/graphics/fontmatrix/doinst.sh
deleted file mode 100644
index 65c7e2eeb9..0000000000
--- a/graphics/fontmatrix/doinst.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/graphics/fontmatrix/fontmatrix.SlackBuild b/graphics/fontmatrix/fontmatrix.SlackBuild
deleted file mode 100644
index 7a7eb49dfd..0000000000
--- a/graphics/fontmatrix/fontmatrix.SlackBuild
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for fontmatrix
-# Written by Larry Hajali
-# Maintained by Klaatu <klaatu@member.fsf.org>
-
-PRGNAM=fontmatrix
-VERSION=${VERSION:-20161216}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-sed -i 's|share/man|man|' CMakeLists.txt
-
-# Cmake uses the static python lib. Let's use the shared lib instead.
-PYVER=$(python -c 'import sys; print sys.version[:3]')
-PY_LIB_SHARED="/usr/lib${LIBDIRSUFFIX}/libpython${PYVER}.so"
-
-mkdir build && cd build
- cmake \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DWANT_M17N:BOOL=true \
- -DWANT_PODOFO:BOOL=true \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_BUILD_TYPE=Release ..
-
- # Remove -O3 flag.
- for i in $(find . -name "flags.make"); do
- sed -i 's|-O3||g' $i
- done || echo "not needed"
-
- make VERBOSE=1
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-rm -rf $PKG/usr/share/icons
-for i in 16 22 32 48 64 128; do
- mkdir -p $PKG/usr/share/icons/hicolor/${i}x${i}/apps
- install -m 0644 src/icons/application-fontmatrix_${i}.png \
- $PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM.png
-done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING ChangeLog TODO harfbuzz/{COPYING.*,README,AUTHORS} \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat harfbuzz/COPYING > $PKG/usr/doc/$PRGNAM-$VERSION/COPYING.harfbuzz
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-chmod 0644 $PKG/usr/doc/$PRGNAM-$VERSION/*
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/fontmatrix/fontmatrix.info b/graphics/fontmatrix/fontmatrix.info
deleted file mode 100644
index e006a798e1..0000000000
--- a/graphics/fontmatrix/fontmatrix.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="fontmatrix"
-VERSION="20161216"
-HOMEPAGE="https://github.com/fontmatrix/fontmatrix"
-DOWNLOAD="http://slackermedia.info/slackbuilds/fontmatrix/fontmatrix-20161216.zip"
-MD5SUM="3c2b3bab19a121a9e1e8a9a5d1900a57"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="podofo"
-MAINTAINER="Klaatu"
-EMAIL="klaatu@member.fsf.org"
diff --git a/graphics/fontmatrix/slack-desc b/graphics/fontmatrix/slack-desc
deleted file mode 100644
index 293c0c0771..0000000000
--- a/graphics/fontmatrix/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-fontmatrix: fontmatrix (font manager)
-fontmatrix:
-fontmatrix: fontmatrix is a manager built with the kind of features and abilities
-fontmatrix: graphic designers, layout professionals, and others have felt
-fontmatrix: necessary, but modernized with some new touches.
-fontmatrix:
-fontmatrix: Homepage: https://github.com/fontmatrix/fontmatrix
-fontmatrix:
-fontmatrix:
-fontmatrix:
-fontmatrix: