summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author B. Watson2019-12-29 05:13:44 +0100
committer Willy Sudiarto Raharjo2019-12-29 05:13:44 +0100
commitbfcb447214296edd29bc4c148334fa87731bbce9 (patch)
tree981c38a933bdbdc9d2c1a42ee462be16f0287dc5 /graphics
parente51925f6cea571efc9231046e8e3fd77ba263dfb (diff)
downloadslackbuilds-bfcb447214296edd29bc4c148334fa87731bbce9.tar.gz
graphics/webp-pixbuf-loader: Added (WEBP loader for gdk-pixbuf2).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/webp-pixbuf-loader/README4
-rw-r--r--graphics/webp-pixbuf-loader/doinst.sh3
-rw-r--r--graphics/webp-pixbuf-loader/git2tarxz.sh42
-rw-r--r--graphics/webp-pixbuf-loader/slack-desc19
-rw-r--r--graphics/webp-pixbuf-loader/webp-pixbuf-loader.SlackBuild83
-rw-r--r--graphics/webp-pixbuf-loader/webp-pixbuf-loader.info10
6 files changed, 161 insertions, 0 deletions
diff --git a/graphics/webp-pixbuf-loader/README b/graphics/webp-pixbuf-loader/README
new file mode 100644
index 0000000000..b2f4324907
--- /dev/null
+++ b/graphics/webp-pixbuf-loader/README
@@ -0,0 +1,4 @@
+webp-pixbuf-loader (WEBP loader for gdk-pixbuf2)
+
+This allows gdk-pixbuf2 (and software using it) to load WebP images.
+In particular it allows qiv and geeqie to display WebP images.
diff --git a/graphics/webp-pixbuf-loader/doinst.sh b/graphics/webp-pixbuf-loader/doinst.sh
new file mode 100644
index 0000000000..364414cfa1
--- /dev/null
+++ b/graphics/webp-pixbuf-loader/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-gdk-pixbuf-loaders ]; then
+ /usr/bin/update-gdk-pixbuf-loaders >/dev/null 2>&1
+fi
diff --git a/graphics/webp-pixbuf-loader/git2tarxz.sh b/graphics/webp-pixbuf-loader/git2tarxz.sh
new file mode 100644
index 0000000000..eda6a8cec9
--- /dev/null
+++ b/graphics/webp-pixbuf-loader/git2tarxz.sh
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+# Create source tarball from git repo, with generated version
+# number. We don't include the git history in the tarball.
+
+# Note that this script doesn't need to be run as root. It does
+# need to be able to write to the current directory it's run from.
+
+PRGNAM=webp-pixbuf-loader
+CLONE_URL=https://github.com/aruiz/$PRGNAM.git
+
+set -e
+
+GITDIR=$( mktemp -dt $PRGNAM.git.XXXXXX )
+rm -rf $GITDIR
+git clone $CLONE_URL $GITDIR
+
+CWD="$( pwd )"
+cd $GITDIR
+
+VERSION=$( git log --date=format:%Y%m%d --pretty=format:%cd.%h -n1 )
+
+rm -rf .git
+find . -name .gitignore -print0 | xargs -0 rm -f
+
+cd "$CWD"
+rm -rf $PRGNAM-$VERSION $PRGNAM-$VERSION.tar.xz
+mv $GITDIR $PRGNAM-$VERSION
+tar cvfJ $PRGNAM-$VERSION.tar.xz $PRGNAM-$VERSION
+
+cat <<EOF
+
+Archive created: $PRGNAM-$VERSION.tar.xz
+
+Update $PRGNAM.info with:
+
+VERSION="$VERSION"
+DOWNLOAD="http://urchlay.naptime.net/~urchlay/src/$PRGNAM-$VERSION.tar.xz"
+MD5SUM="$( md5sum $PRGNAM-$VERSION.tar.xz | cut -d' ' -f1 )"
+
+Don't forget to upload the new source!
+EOF
diff --git a/graphics/webp-pixbuf-loader/slack-desc b/graphics/webp-pixbuf-loader/slack-desc
new file mode 100644
index 0000000000..0b8cc74f0e
--- /dev/null
+++ b/graphics/webp-pixbuf-loader/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+webp-pixbuf-loader: webp-pixbuf-loader (WEBP loader for gdk-pixbuf2)
+webp-pixbuf-loader:
+webp-pixbuf-loader: This allows gdk-pixbuf2 (and software using it) to load WebP images.
+webp-pixbuf-loader: In particular it allows qiv and geeqie to display WebP images.
+webp-pixbuf-loader:
+webp-pixbuf-loader:
+webp-pixbuf-loader:
+webp-pixbuf-loader:
+webp-pixbuf-loader:
+webp-pixbuf-loader:
+webp-pixbuf-loader:
diff --git a/graphics/webp-pixbuf-loader/webp-pixbuf-loader.SlackBuild b/graphics/webp-pixbuf-loader/webp-pixbuf-loader.SlackBuild
new file mode 100644
index 0000000000..d93e42fb70
--- /dev/null
+++ b/graphics/webp-pixbuf-loader/webp-pixbuf-loader.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/sh
+
+# Slackware build script for webp-pixbuf-loader
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=webp-pixbuf-loader
+VERSION=${VERSION:-20191003.fb04954}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# this stuff is for making meson/ninja update the loaders, we do that
+# in doinst.sh instead.
+sed -i '/gdk_pb_query_loaders/d' meson.build
+
+mkdir build
+cd build
+ CFLAGS="-Wl,-s $SLKCFLAGS" \
+ CXXFLAGS="-Wl,-s $SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ ninja
+ DESTDIR=$PKG ninja install
+cd ..
+
+DOCDIR=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $DOCDIR
+cat $CWD/README > $DOCDIR/README
+cat $CWD/$PRGNAM.SlackBuild > $DOCDIR/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/webp-pixbuf-loader/webp-pixbuf-loader.info b/graphics/webp-pixbuf-loader/webp-pixbuf-loader.info
new file mode 100644
index 0000000000..96baf11a22
--- /dev/null
+++ b/graphics/webp-pixbuf-loader/webp-pixbuf-loader.info
@@ -0,0 +1,10 @@
+PRGNAM="webp-pixbuf-loader"
+VERSION="20191003.fb04954"
+HOMEPAGE="https://github.com/aruiz/webp-pixbuf-loader"
+DOWNLOAD="http://urchlay.naptime.net/~urchlay/src/webp-pixbuf-loader-20191003.fb04954.tar.xz"
+MD5SUM="d3e9041ab56b18020c647dcb9f3176d4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="meson libwebp"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"