summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-07-18 19:00:29 +0200
committer Willy Sudiarto Raharjo2014-07-18 19:00:29 +0200
commit4997062b105ed911c7ba8d40290fbce6b328ffc6 (patch)
tree2da331d5872a8e9574fecd2499c80f20960f4352 /graphics
parent38caaf00887b45348fdedcd8e28936e0690a087e (diff)
downloadslackbuilds-4997062b105ed911c7ba8d40290fbce6b328ffc6.tar.gz
graphics/phatch: Added (GUI photo batch processor).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/phatch/README7
-rw-r--r--graphics/phatch/doinst.sh3
-rw-r--r--graphics/phatch/phatch.SlackBuild94
-rw-r--r--graphics/phatch/phatch.info10
-rw-r--r--graphics/phatch/slack-desc19
5 files changed, 133 insertions, 0 deletions
diff --git a/graphics/phatch/README b/graphics/phatch/README
new file mode 100644
index 0000000000..d22b6f9118
--- /dev/null
+++ b/graphics/phatch/README
@@ -0,0 +1,7 @@
+Phatch is a simple to use cross-platform GUI Photo Batch Processor
+which handles all popular image formats and can duplicate
+(sub)folder hierarchies. Phatch can batch resize, rotate, apply
+perspective, shadows, rounded corners, ... and more in minutes
+instead of hours or days if you do it manually. Phatch allows you to
+use EXIF and IPTC tags for renaming and data stamping. Phatch
+also supports a console version to batch photos on webservers.
diff --git a/graphics/phatch/doinst.sh b/graphics/phatch/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/graphics/phatch/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/graphics/phatch/phatch.SlackBuild b/graphics/phatch/phatch.SlackBuild
new file mode 100644
index 0000000000..f4119d6fb4
--- /dev/null
+++ b/graphics/phatch/phatch.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/sh
+
+# Slackware build script for phatch
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=phatch
+VERSION=${VERSION:-0.2.7.1}
+SRCVER=$(echo $VERSION | cut -c1-5)
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/man
+mv $PKG/usr/share/man/man1 $PKG/usr/man
+rm -rf $PKG/usr/share/man
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/phatch/phatch.info b/graphics/phatch/phatch.info
new file mode 100644
index 0000000000..7b7a68dc44
--- /dev/null
+++ b/graphics/phatch/phatch.info
@@ -0,0 +1,10 @@
+PRGNAM="phatch"
+VERSION="0.2.7.1"
+HOMEPAGE="http://photobatch.stani.be"
+DOWNLOAD="http://photobatch.stani.be/download/package/phatch-0.2.7.1.tar.gz"
+MD5SUM="c0638bcc6510d340c03c40ddfb0a0c2f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="wxPython"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/graphics/phatch/slack-desc b/graphics/phatch/slack-desc
new file mode 100644
index 0000000000..36a23e97c4
--- /dev/null
+++ b/graphics/phatch/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+phatch: phatch (GUI photo batch processor)
+phatch:
+phatch: Phatch is a simple to use cross-platform GUI Photo Batch Processor
+phatch: which handles all popular image formats and can duplicate (sub)folder
+phatch: hierarchies. Phatch can batch resize, rotate, apply perspective,
+phatch: shadows, rounded corners, ... and more in minutes instead of hours
+phatch: or days if you do it manually.
+phatch:
+phatch: Homepage: http://photobatch.stani.be
+phatch:
+phatch: