summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author orbea2020-01-12 03:32:09 +0100
committer Willy Sudiarto Raharjo2020-01-18 06:25:14 +0100
commitf4847aeafbbcfab4f90e8ca7f28ba052d49df6ba (patch)
tree327b7910ba94906c890e4efe4446c3cae8c705ea /graphics
parent428f08b54271c3125b35794981270aa7b4e20f26 (diff)
downloadslackbuilds-f4847aeafbbcfab4f90e8ca7f28ba052d49df6ba.tar.gz
games/antares: Moved from graphics.
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/antares/README4
-rw-r--r--graphics/antares/antares.SlackBuild96
-rw-r--r--graphics/antares/antares.info12
-rw-r--r--graphics/antares/doinst.sh9
-rw-r--r--graphics/antares/procyon.patch32
-rw-r--r--graphics/antares/slack-desc19
-rw-r--r--graphics/antares/text.patch26
7 files changed, 0 insertions, 198 deletions
diff --git a/graphics/antares/README b/graphics/antares/README
deleted file mode 100644
index 2730617966..0000000000
--- a/graphics/antares/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Antares is a port of the original Ares code base that was open sourced
-in 2008. Antares is an extremely faithful reproduction of the original
-Ares experience, making changes only as necessary to support running on
-modern computers.
diff --git a/graphics/antares/antares.SlackBuild b/graphics/antares/antares.SlackBuild
deleted file mode 100644
index c5bf1b2b24..0000000000
--- a/graphics/antares/antares.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for antares
-
-# Copyright 2018, 2020 Hunter Sezen California, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=antares
-VERSION=${VERSION:-0.9.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Prevent downloading the source during install
-mkdir -p $PKG/usr/share/games/$PRGNAM/downloads
-cp $CWD/Ares-1.2.0.zip $PKG/usr/share/games/$PRGNAM/downloads
-
-# Don't connect accessibility bus.
-# https://github.com/arescentral/antares/issues/276
-export NO_AT_BRIDGE=1
-
-# Use a system version of gn.
-sed -i 's|build/lib/bin/gn|gn|' build/lib/scripts/cfg.py
-
-# gn: Fix build with newer gn versions.
-# https://github.com/arescentral/procyon/pull/15
-( cd ext/procyon; patch -p1 < $CWD/procyon.patch )
-
-# Makefile: Install the text directory.
-# https://github.com/arescentral/antares/pull/307
-patch -p1 < $CWD/text.patch
-
-# configure is a python script
-./configure \
- --prefix=/usr
-
-make NINJA="${NINJA:-ninja} -C out/cur" install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CONTRIBUTING COPYING COPYING.LESSER README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/antares/antares.info b/graphics/antares/antares.info
deleted file mode 100644
index cd46acce08..0000000000
--- a/graphics/antares/antares.info
+++ /dev/null
@@ -1,12 +0,0 @@
-PRGNAM="antares"
-VERSION="0.9.0"
-HOMEPAGE="https://arescentral.org/antares"
-DOWNLOAD="UNSUPPORTED"
-MD5SUM=""
-DOWNLOAD_x86_64="http://downloads.arescentral.org/Antares/antares-0.9.0.zip \
- http://downloads.arescentral.org/Ares/Ares-1.2.0.zip"
-MD5SUM_x86_64="351ae6d76673564b4fe17b56b583a0dc \
- b41f52c74f7cad3ff183dabe81bd1cf2"
-REQUIRES="OpenAL glfw3 gn libc++ libmodplug"
-MAINTAINER="Hunter Sezen"
-EMAIL="orbea@riseup.net"
diff --git a/graphics/antares/doinst.sh b/graphics/antares/doinst.sh
deleted file mode 100644
index 65c7e2eeb9..0000000000
--- a/graphics/antares/doinst.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/graphics/antares/procyon.patch b/graphics/antares/procyon.patch
deleted file mode 100644
index 1805b5aa82..0000000000
--- a/graphics/antares/procyon.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 42aeba19dbe79c6ebd3e860bff977595577ad90f Mon Sep 17 00:00:00 2001
-From: orbea <orbea@riseup.net>
-Date: Wed, 8 Jan 2020 12:12:34 -0800
-Subject: [PATCH] gn: Fix build with newer gn versions.
-
----
- src/cpp/BUILD.gn | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/src/cpp/BUILD.gn b/src/cpp/BUILD.gn
-index 58da775..b76d236 100644
---- a/src/cpp/BUILD.gn
-+++ b/src/cpp/BUILD.gn
-@@ -13,7 +13,7 @@
- # limitations under the License.
-
- static_library("procyon-cpp") {
-- sources = [
-+ public = [
- "include/pn/arg",
- "include/pn/array",
- "include/pn/data",
-@@ -23,6 +23,9 @@ static_library("procyon-cpp") {
- "include/pn/output",
- "include/pn/string",
- "include/pn/value",
-+ ]
-+
-+ sources = [
- "src/array.cpp",
- "src/common.hpp",
- "src/data.cpp",
diff --git a/graphics/antares/slack-desc b/graphics/antares/slack-desc
deleted file mode 100644
index 7937124a8b..0000000000
--- a/graphics/antares/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-antares: antares (A tactical space combat game)
-antares:
-antares: Antares is based on Ares, a game developed by Nathan Lamont, and
-antares: released for the classic Mac OS in 1996.
-antares:
-antares: Homepage: https://arescentral.org/antares
-antares:
-antares:
-antares:
-antares:
-antares:
diff --git a/graphics/antares/text.patch b/graphics/antares/text.patch
deleted file mode 100644
index 62b7e61ba2..0000000000
--- a/graphics/antares/text.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 914ad7b2cd53b8396a6e407c91b63adfc3b18443 Mon Sep 17 00:00:00 2001
-From: orbea <orbea@riseup.net>
-Date: Wed, 8 Jan 2020 07:42:21 -0800
-Subject: [PATCH] Makefile: Install the text directory.
-
-This fixes a crash at the end of the tutorial level.
-
-antares-glfw: text/6000.txt: couldn't find resource "text/6000.txt"
-
-Signed-off-by: orbea <orbea@riseup.net>
----
- Makefile | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/Makefile b/Makefile
-index 7146731e..7404fb34 100644
---- a/Makefile
-+++ b/Makefile
-@@ -105,6 +105,7 @@ install-data: build
- cp -r data/sounds $(DESTDIR)$(DATADIR)/app
- cp -r data/sprites $(DESTDIR)$(DATADIR)/app
- cp -r data/strings $(DESTDIR)$(DATADIR)/app
-+ cp -r data/text $(DESTDIR)$(DATADIR)/app
-
- .PHONY: install-scenario
- install-scenario: build