summaryrefslogtreecommitdiffstats
path: root/graphics/yagf/yagf.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2015-03-27 09:43:18 +0100
committer Willy Sudiarto Raharjo2015-03-27 09:43:18 +0100
commit8df6a9412eb30c58072451a17f3482885222657d (patch)
tree85ff4c66ca6bd84c3e303f8df49ba2b067542b96 /graphics/yagf/yagf.SlackBuild
parentd27cd40a4b04a0d55164385c3d2164a3f0aabcfe (diff)
downloadslackbuilds-8df6a9412eb30c58072451a17f3482885222657d.tar.gz
graphics/yagf: Updated for version 0.9.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/yagf/yagf.SlackBuild')
-rw-r--r--graphics/yagf/yagf.SlackBuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/graphics/yagf/yagf.SlackBuild b/graphics/yagf/yagf.SlackBuild
index 41249e673f..ebc458a9c9 100644
--- a/graphics/yagf/yagf.SlackBuild
+++ b/graphics/yagf/yagf.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for yagf
-# Copyright 2009-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=yagf
-VERSION=${VERSION:-0.9.3.2}
+VERSION=${VERSION:-0.9.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -67,12 +67,10 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix desktop menu item.
-sed -i -e '/\[lt\]/,/\[pl\]/d' -e 's|OCR;|OCR;Graphics;Scanning;|' YAGF.desktop
-# Turn on tiff support.
-sed -i 's|MPTIFF_SUPPORT false|MPTIFF_SUPPORT true|' CMakeLists.txt
+sed -i 's|OCR;|OCR;Graphics;Scanning;|' YAGF.desktop
mkdir -p build
cd build
@@ -87,13 +85,14 @@ cd build
make install DESTDIR=$PKG
cd ..
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS ChangeLog COPYING DESCRIPTION README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 '{}' \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc