summaryrefslogtreecommitdiffstats
path: root/graphics/shotwell/shotwell.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2013-11-20 02:07:10 +0100
committer Robby Workman2013-11-24 06:59:03 +0100
commit609e01ddac036f54b2cc6ec182259eb488d6fba5 (patch)
tree14526151d285b58a1243f4c0c78a2682a0142f41 /graphics/shotwell/shotwell.SlackBuild
parentebe1c15116d422bb0d06f971d189e3b510895d77 (diff)
downloadslackbuilds-609e01ddac036f54b2cc6ec182259eb488d6fba5.tar.gz
graphics/shotwell: Removed (build failure)
This package is not compatible with the boost version in Slackware 14.1. As an additional hurdle, it needs an older version of LibRaw than we currently have in our repo, while some of the other stuff requires the newer version. Given the circumstances, shotwell goes. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'graphics/shotwell/shotwell.SlackBuild')
-rw-r--r--graphics/shotwell/shotwell.SlackBuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/graphics/shotwell/shotwell.SlackBuild b/graphics/shotwell/shotwell.SlackBuild
deleted file mode 100644
index 00fc9fad66..0000000000
--- a/graphics/shotwell/shotwell.SlackBuild
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/bin/sh
-
-# Brad Hermanson <apeitheo@gmail.com>
-
-PRGNAM=shotwell
-VERSION=0.11.6
-BUILD=${BUILD:-4}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# Fix building with LibRaw 0.14
-patch -p0 -i $CWD/patch-src-photos-GRaw.vala
-patch -p0 -i $CWD/patch-vapi-libraw.vapi
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --lib=lib${LIBDIRSUFFIX} \
- --disable-schemas-compile \
- --disable-desktop-update \
- --disable-icon-update \
- --enable-build-for-glade \
- --install-headers \
- --release
-
-# Allow shotwell to find our tweaked vala-12 package.
-sed -e 's/valac/valac-0.12/' -i plugins/Makefile.plugin.mk
-sed -e 's/valac/valac-0.12/' -i Makefile
-
-make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS COPYING INSTALL MAINTAINERS NEWS README THANKS \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}