summaryrefslogtreecommitdiffstats
path: root/graphics/python3-gds3xtrude
diff options
context:
space:
mode:
author Lockywolf2023-07-08 05:41:41 +0200
committer Willy Sudiarto Raharjo2023-07-08 11:41:52 +0200
commit46e47204afc785a46f267be4304420f6a89137da (patch)
treedf75ead8121f4fb0c4a029e4e0e2f6d2ca6345d5 /graphics/python3-gds3xtrude
parenta607515b3c810c969e7661d7785e0b3091ee479b (diff)
downloadslackbuilds-46e47204afc785a46f267be4304420f6a89137da.tar.gz
graphics/python3-gds3xtrude: Added (3D layout viewer).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/python3-gds3xtrude')
-rw-r--r--graphics/python3-gds3xtrude/README7
-rw-r--r--graphics/python3-gds3xtrude/python3-gds3xtrude.SlackBuild81
-rw-r--r--graphics/python3-gds3xtrude/python3-gds3xtrude.info10
-rw-r--r--graphics/python3-gds3xtrude/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/graphics/python3-gds3xtrude/README b/graphics/python3-gds3xtrude/README
new file mode 100644
index 0000000000..bcad782613
--- /dev/null
+++ b/graphics/python3-gds3xtrude/README
@@ -0,0 +1,7 @@
+gds3xtrude takes the layers of your layout and converts them into 3D
+volumes by extrusion. gds3xtrude is intended to be used in two
+different ways:
+
+1. as KLayout extension: Show 3D model of the active view.
+2. as standalone tool: Convert GDS to OpenSCAD/Blender from the
+ command line.
diff --git a/graphics/python3-gds3xtrude/python3-gds3xtrude.SlackBuild b/graphics/python3-gds3xtrude/python3-gds3xtrude.SlackBuild
new file mode 100644
index 0000000000..4aabafe781
--- /dev/null
+++ b/graphics/python3-gds3xtrude/python3-gds3xtrude.SlackBuild
@@ -0,0 +1,81 @@
+#!/bin/bash
+
+# Slackware build script for python3-gds3xtrude
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-gds3xtrude
+TARNAM=gds3xtrude
+VERSION=${VERSION:-0.0.13}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TARNAM-$VERSION
+tar xvf $CWD/$TARNAM-$VERSION.tar.gz
+cd $TARNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE PKG-INFO README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/python3-gds3xtrude/python3-gds3xtrude.info b/graphics/python3-gds3xtrude/python3-gds3xtrude.info
new file mode 100644
index 0000000000..6a2517718f
--- /dev/null
+++ b/graphics/python3-gds3xtrude/python3-gds3xtrude.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-gds3xtrude"
+VERSION="0.0.13"
+HOMEPAGE="https://github.com/fsitok/gds3xtrude"
+DOWNLOAD="https://files.pythonhosted.org/packages/e9/11/683cee1ad6e7927005400477b8c5ceeee3dab004f51349467cb3f9280ad0/gds3xtrude-0.0.13.tar.gz"
+MD5SUM="8755ad97da2a6d080aff10c35380c270"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-solidpython klayout openscad"
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-gds3xtrude_2023-07-03@lockywolf.net"
diff --git a/graphics/python3-gds3xtrude/slack-desc b/graphics/python3-gds3xtrude/slack-desc
new file mode 100644
index 0000000000..c34808602c
--- /dev/null
+++ b/graphics/python3-gds3xtrude/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-gds3xtrude: python3-gds3xtrude (A simple layout to 3D converter)
+python3-gds3xtrude:
+python3-gds3xtrude: gds3xtrude takes the layers of your layout and converts them into 3D
+python3-gds3xtrude: volumes by extrusion. gds3xtrude is intended to be used in two
+python3-gds3xtrude: different ways: as KLayout extension: Show 3D model of the active
+python3-gds3xtrude: view. as standalone tool: Convert GDS to OpenSCAD/Blender from the
+python3-gds3xtrude: command line.
+python3-gds3xtrude:
+python3-gds3xtrude:
+python3-gds3xtrude:
+python3-gds3xtrude: