summaryrefslogtreecommitdiffstats
path: root/graphics/fbida
diff options
context:
space:
mode:
author B. Watson2016-10-16 05:58:41 +0200
committer Willy Sudiarto Raharjo2016-10-22 03:47:29 +0200
commit5df91c4112f14c5b73bce718801110820e623502 (patch)
tree6bb5f3bb02041a0ad5471db4e2cbdddea22ce57e /graphics/fbida
parent4d20c711815570648428d580cfa30dc77d5a92d7 (diff)
downloadslackbuilds-5df91c4112f14c5b73bce718801110820e623502.tar.gz
graphics/fbida: Updated for version 2.12.
Diffstat (limited to 'graphics/fbida')
-rw-r--r--graphics/fbida/README13
-rw-r--r--graphics/fbida/doinst.sh3
-rw-r--r--graphics/fbida/fbida.SlackBuild61
-rw-r--r--graphics/fbida/fbida.info6
-rw-r--r--graphics/fbida/ida.desktop9
-rw-r--r--graphics/fbida/ida.pngbin0 -> 1722 bytes
6 files changed, 73 insertions, 19 deletions
diff --git a/graphics/fbida/README b/graphics/fbida/README
index 085ab24270..da171cf3f3 100644
--- a/graphics/fbida/README
+++ b/graphics/fbida/README
@@ -3,9 +3,10 @@ fbida (image viewer for framebuffer console)
The fbida project contains a few applications for viewing and
editing images, with the main focus being photos:
-fbi – This is an image viewer for the Linux framebuffer console.
-fbgs – Script for viewing ps/pdf files on framebuffer console using fbi.
-exiftran – command line tool to do lossless transformations of JPEG images.
-
-ida (a Motif based image viewer for X11) is not included on purpose,
-as it needs Open Motif.
+ fbi - This is an image viewer for the Linux framebuffer console.
+ fbgs - Script for viewing PS/PDF files on framebuffer console using fbi.
+ fbipdf - Framebuffer PDF viewer, faster and better than fbgs, but without
+ support for PS.
+exiftran - Command line tool to do lossless transformations of JPEG images.
+ ida - Motif based image viewer for X11. Can be disabled by setting
+ MOTIF=no in the script's environment.
diff --git a/graphics/fbida/doinst.sh b/graphics/fbida/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/graphics/fbida/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/graphics/fbida/fbida.SlackBuild b/graphics/fbida/fbida.SlackBuild
index 718c5e936a..94b7795ff6 100644
--- a/graphics/fbida/fbida.SlackBuild
+++ b/graphics/fbida/fbida.SlackBuild
@@ -1,12 +1,6 @@
#!/bin/sh
# Slackware build script for fbida
-# Modified by Luis Henrique <lmello.009@gmail.com>
-
-# Modified again on 20140915 by B. Watson <yalhcru@gmail.com>
-# - Took over maintenance, minor script cleanup
-
-# 20150508 bkw: update for v2.10
# (C) 2007 Michael Wagner <lapinours@web.de>
# All rights reserved.
@@ -28,8 +22,24 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Modified by Luis Henrique <lmello.009@gmail.com>
+
+# Modified again on 20140915 by B. Watson <yalhcru@gmail.com>
+# - Took over maintenance, minor script cleanup
+
+# 20150508 bkw: update for v2.10
+
+# 20161015 bkw:
+# - update for v2.12
+# - add optional motif support, since Slack 14.2 has real Motif. Also
+# add .desktop and icon, if motif was included.
+# - actually apply SLKCFLAGS
+# - 2.12 has a new fbpdf command, which I've renamed to
+# fbipdf to avoid conflicting with the fbpdf package
+# - include French man pages, which aren't installed by default
+
PRGNAM=fbida
-VERSION=${VERSION:-2.10}
+VERSION=${VERSION:-2.12}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,7 +56,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="COPYING Changes INSTALL README TODO"
+DOCS="COPYING Changes README TODO"
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
@@ -77,10 +87,41 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" make HAVE_MOTIF=no
-prefix=/usr make install DESTDIR=$PKG mandir=$PKG/usr/man HAVE_MOTIF=no
+MOTIF_OPT="HAVE_MOTIF=${MOTIF:-yes}"
+sed -i "/^CFLAGS/s,-g *-O2,$SLKCFLAGS," mk/Variables.mk
+make $MOTIF_OPT prefix=/usr
+strip fbpdf # not stripped for some reason
+make install prefix=/usr DESTDIR=$PKG mandir=$PKG/usr/man $MOTIF_OPT
gzip -9 $PKG/usr/man/man1/*
+FR_MAN="exiftran fbgs fbi"
+
+# upstream's .desktop file doesn't validate, we ship a corrected one,
+# but only include it if motif support was built in. PNG icon was
+# converted from mallard_48.xpm in the src.
+if [ "${MOTIF:-yes}" = "yes" ]; then
+ mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
+ cat $CWD/ida.desktop > $PKG/usr/share/applications/ida.desktop
+ cat $CWD/ida.png > $PKG/usr/share/pixmaps/ida.png
+ FR_MAN="$FR_MAN ida"
+fi
+
+# /usr/bin/fbpdf conflicts with office/fbpdf, so rename it
+mv $PKG/usr/bin/fbpdf $PKG/usr/bin/fbipdf
+
+# French man pages. I don't see a way to get make to install these. Hope
+# they're useful, I can't actually read French. They're UTF-8, and display
+# poorly with Slackware's old man command... so I convert them to 8859-1
+# and hope for the best. They look OK with LANG set to either fr_FR
+# or fr_FR.UTF-8. They also look OK with the man command from man-db.
+# iconv chokes on the unicode ellipsis character (U+2026), the sed stuff
+# converts it back to three periods as Bemer intended!
+mkdir -p $PKG/usr/man/fr/man1
+for i in $FR_MAN; do
+ LANG=C sed 's,\xe2\x80\xa6,...,g' < $i.man.fr | \
+ iconv -c -f UTF-8 -t ISO-8859-1 | \
+ gzip -9c > $PKG/usr/man/fr/man1/$i.1.gz
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/graphics/fbida/fbida.info b/graphics/fbida/fbida.info
index a7155af7e1..001aa45b55 100644
--- a/graphics/fbida/fbida.info
+++ b/graphics/fbida/fbida.info
@@ -1,8 +1,8 @@
PRGNAM="fbida"
-VERSION="2.10"
+VERSION="2.12"
HOMEPAGE="http://linux.bytesex.org/fbida/"
-DOWNLOAD="https://www.kraxel.org/releases/fbida/fbida-2.10.tar.gz"
-MD5SUM="09460b964b58c2e39b665498eca29018"
+DOWNLOAD="https://www.kraxel.org/releases/fbida/fbida-2.12.tar.gz"
+MD5SUM="f5f3fdaca387f267ddc8a05365113448"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/graphics/fbida/ida.desktop b/graphics/fbida/ida.desktop
new file mode 100644
index 0000000000..11aa5356d5
--- /dev/null
+++ b/graphics/fbida/ida.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=ida
+GenericName=Image Viewer
+Exec=ida %F
+Terminal=false
+Icon=ida
+Categories=Motif;Graphics;Viewer
+MimeType=image/jpeg;image/tiff;image/png
diff --git a/graphics/fbida/ida.png b/graphics/fbida/ida.png
new file mode 100644
index 0000000000..ef5cc1e825
--- /dev/null
+++ b/graphics/fbida/ida.png
Binary files differ