summaryrefslogtreecommitdiffstats
path: root/graphics/apitrace
diff options
context:
space:
mode:
author B. Watson2022-04-08 23:16:06 +0200
committer Willy Sudiarto Raharjo2022-04-09 10:45:12 +0200
commit71f8aa23cf7b9f12fd17ab2075b72d2d5aae200a (patch)
tree9c803cfb2ef57998d5d4fdface6f10e70cab6a39 /graphics/apitrace
parent2b6f63a427c5894a5e6dede99b829ff7ec560238 (diff)
downloadslackbuilds-71f8aa23cf7b9f12fd17ab2075b72d2d5aae200a.tar.gz
graphics/apitrace: Fix conflict with dpkg.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/apitrace')
-rw-r--r--graphics/apitrace/apitrace.SlackBuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/graphics/apitrace/apitrace.SlackBuild b/graphics/apitrace/apitrace.SlackBuild
index 82d70befc1..f44b48fc46 100644
--- a/graphics/apitrace/apitrace.SlackBuild
+++ b/graphics/apitrace/apitrace.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220301 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix conflict with dpkg.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=apitrace
VERSION=${VERSION:-9.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +75,14 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# 20220408 bkw: fix Debian brokenness: we have a dpkg build... if it
+# happens to be installed, we get shared libs installed to the wrong
+# directory (because we don't really support debian-style multiarch).
+sed -i 's,dpkg-architecture,true,' CMakeLists.txt
mkdir -p build
cd build
@@ -90,12 +95,9 @@ cd build
-DENABLE_STATIC_SNAPPY=OFF \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild