summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author M.Dinslage2019-09-06 17:30:23 +0200
committer Willy Sudiarto Raharjo2019-09-06 17:30:23 +0200
commiteacad03cfb413b3b03677f4bf9ad2b4571a62659 (patch)
treebc95ad8613db0b0a549c88132ae58b30043751f3 /gis
parent2674968f7a770df610d9808e35331dc3dc6ea299 (diff)
downloadslackbuilds-eacad03cfb413b3b03677f4bf9ad2b4571a62659.tar.gz
gis/opencpn-plugin-oesenc: Updated for version 3.2.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/opencpn-plugin-oesenc/multilib-strict.patch14
-rw-r--r--gis/opencpn-plugin-oesenc/opencpn-plugin-oesenc.SlackBuild7
-rw-r--r--gis/opencpn-plugin-oesenc/opencpn-plugin-oesenc.info6
-rw-r--r--gis/opencpn-plugin-oesenc/slackware-detection-logic.patch27
4 files changed, 34 insertions, 20 deletions
diff --git a/gis/opencpn-plugin-oesenc/multilib-strict.patch b/gis/opencpn-plugin-oesenc/multilib-strict.patch
deleted file mode 100644
index d1a80d8fc1..0000000000
--- a/gis/opencpn-plugin-oesenc/multilib-strict.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -up oesenc_pi-2.9.1601/CMakeLists.txt.orig1 oesenc_pi-2.9.1601/CMakeLists.txt
---- oesenc_pi-2.9.1601/CMakeLists.txt.orig1 2019-04-03 20:56:51.982839060 -0500
-+++ oesenc_pi-2.9.1601/CMakeLists.txt 2019-04-03 20:58:02.487835992 -0500
-@@ -99,6 +99,10 @@ IF (NOT WIN32)
- ENDIF (CMAKE_SYSTEM_PROCESSOR MATCHES "arm*")
- ENDIF (EXISTS /etc/debian_version)
-
-+ IF (EXISTS /etc/slackware-version)
-+ SET (LIB_INSTALL_DIR "lib${LIB_SUFFIX}")
-+ ENDIF (EXISTS /etc/slackware-version)
-+
- IF (EXISTS /etc/redhat-release)
- SET (PACKAGE_FORMAT "RPM")
- SET (PACKAGE_DEPS "opencpn")
diff --git a/gis/opencpn-plugin-oesenc/opencpn-plugin-oesenc.SlackBuild b/gis/opencpn-plugin-oesenc/opencpn-plugin-oesenc.SlackBuild
index b30a6f3f61..3ec0ec0280 100644
--- a/gis/opencpn-plugin-oesenc/opencpn-plugin-oesenc.SlackBuild
+++ b/gis/opencpn-plugin-oesenc/opencpn-plugin-oesenc.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=opencpn-plugin-oesenc
-VERSION=${VERSION:-3.0.0}
+VERSION=${VERSION:-3.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,11 +71,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Don't hardcode the LIB directory
sed -i -e 's/^ SET (LIB_INSTALL_DIR "lib")/ SET (LIB_INSTALL_DIR "lib${LIB_SUFFIX}")/' \
cmake/PluginInstall.cmake
-# fix shared object installing to wrong directory
-patch -p1 < $CWD/multilib-strict.patch
+# add detection logic for Slackware so libraries get installed to proper location.
+patch -p1 < $CWD/slackware-detection-logic.patch
mkdir -p build
cd build
diff --git a/gis/opencpn-plugin-oesenc/opencpn-plugin-oesenc.info b/gis/opencpn-plugin-oesenc/opencpn-plugin-oesenc.info
index 6e5bfa95a8..ba62f28e15 100644
--- a/gis/opencpn-plugin-oesenc/opencpn-plugin-oesenc.info
+++ b/gis/opencpn-plugin-oesenc/opencpn-plugin-oesenc.info
@@ -1,8 +1,8 @@
PRGNAM="opencpn-plugin-oesenc"
-VERSION="3.0.0"
+VERSION="3.2.0"
HOMEPAGE="https://opencpn.org/OpenCPN/plugins/oesenc.html"
-DOWNLOAD="https://github.com/bdbcat/oesenc_pi/archive/v3.0.0/oesenc_pi-3.0.0.tar.gz"
-MD5SUM="700e5853cd2269ef5f1a3fc3e6ab98ec"
+DOWNLOAD="https://github.com/bdbcat/oesenc_pi/archive/v3.2.0/oesenc_pi-3.2.0.tar.gz"
+MD5SUM="8847c01066737b7ae073bf0fd0cfbd7f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="opencpn"
diff --git a/gis/opencpn-plugin-oesenc/slackware-detection-logic.patch b/gis/opencpn-plugin-oesenc/slackware-detection-logic.patch
new file mode 100644
index 0000000000..5075353f71
--- /dev/null
+++ b/gis/opencpn-plugin-oesenc/slackware-detection-logic.patch
@@ -0,0 +1,27 @@
+diff -up oesenc_pi-3.2.0/CMakeLists.txt.orig1 oesenc_pi-3.2.0/CMakeLists.txt
+--- oesenc_pi-3.2.0/CMakeLists.txt.orig1 2019-09-01 23:51:42.965365609 -0500
++++ oesenc_pi-3.2.0/CMakeLists.txt 2019-09-02 00:10:07.037326117 -0500
+@@ -116,18 +116,17 @@ IF (NOT WIN32)
+ ENDIF(NOT DEFINED PACKAGE_FORMAT)
+
+ IF(NOT DEFINED PACKAGE_FORMAT)
+- IF (EXISTS /etc/os-release OR EXISTS /etc/sysconfig/SuSEfirewall2.d OR EXISTS /etc/suse-release OR EXISTS /etc/SuSE-release)
+- MESSAGE (STATUS "*** OpenSUSE detected ***")
+- SET (PACKAGE_FORMAT "RPM")
+- SET (PACKAGE_DEPS "opencpn")
++ IF (EXISTS /etc/slackware-version)
++ MESSAGE (STATUS "*** Slackware detected ***")
++ SET (PACKAGE_FORMAT "TXZ")
+ IF (CMAKE_SIZEOF_VOID_P MATCHES "8")
+ SET (ARCH "x86_64")
+- SET (LIB_INSTALL_DIR "lib")
++ SET (LIB_INSTALL_DIR "lib64")
+ ELSE (CMAKE_SIZEOF_VOID_P MATCHES "8")
+ SET (ARCH "i386")
+ SET (LIB_INSTALL_DIR "lib")
+ ENDIF (CMAKE_SIZEOF_VOID_P MATCHES "8")
+- ENDIF (EXISTS /etc/os-release OR EXISTS /etc/sysconfig/SuSEfirewall2.d OR EXISTS /etc/suse-release OR EXISTS /etc/SuSE-release)
++ ENDIF (EXISTS /etc/slackware-version)
+ ENDIF(NOT DEFINED PACKAGE_FORMAT)
+
+ ENDIF (UNIX AND NOT APPLE)