summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-11-17 00:16:08 +0100
committer Willy Sudiarto Raharjo2019-11-23 10:01:58 +0100
commit373c8de22d0e061cfc06b54c299a8901fa72154a (patch)
tree068523d29aff78b11366dc68e1a106e2d7296a89 /gis
parent335bc843aeefc17b7d50905748201113ad5ba772 (diff)
downloadslackbuilds-373c8de22d0e061cfc06b54c299a8901fa72154a.tar.gz
gis/python-mapnik: Python 3 won't work on 14.2.
Diffstat (limited to 'gis')
-rw-r--r--gis/python-mapnik/python-mapnik.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/gis/python-mapnik/python-mapnik.SlackBuild b/gis/python-mapnik/python-mapnik.SlackBuild
index 5a54a13d52..8191c5a01e 100644
--- a/gis/python-mapnik/python-mapnik.SlackBuild
+++ b/gis/python-mapnik/python-mapnik.SlackBuild
@@ -2,7 +2,7 @@
#
# SlackBuild for python-mapnik
#
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -59,7 +59,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xzf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xzvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -68,10 +68,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+#python3 setup.py install --root=$PKG # only works on -current, where boost has libboost_python3x.so
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true