summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-11-11 06:52:40 +0100
committer Willy Sudiarto Raharjo2019-11-23 10:01:57 +0100
commit076ebd81c2d190f30100844a0b819d38f3edbbad (patch)
treea7646d32dcc784898829f1ff2e3450da5bd44ee3 /gis
parenta660aed736e63b2f1c68c29b008e23ede25a0bd9 (diff)
downloadslackbuilds-076ebd81c2d190f30100844a0b819d38f3edbbad.tar.gz
gis/cartopy: Add support for proj6.
Diffstat (limited to 'gis')
-rw-r--r--gis/cartopy/cartopy.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/gis/cartopy/cartopy.SlackBuild b/gis/cartopy/cartopy.SlackBuild
index ce376aa696..aa7effe818 100644
--- a/gis/cartopy/cartopy.SlackBuild
+++ b/gis/cartopy/cartopy.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for cartopy
-# Copyright 2014-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2014-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=cartopy
VERSION=${VERSION:-0.17.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+CFLAGS="$SLKCFLAGS -DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1" \
+ python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true