summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Kyle Guinn2014-09-27 20:20:19 +0200
committer Willy Sudiarto Raharjo2014-09-27 20:20:19 +0200
commit3acc06b5abfe66203cc388742efb4879b95fa781 (patch)
treedea43f47b0f1009a38a24b67685fc8ffc8901d93 /gis
parentabbd371347da226f12d5b303f0354cec5bb88a71 (diff)
downloadslackbuilds-3acc06b5abfe66203cc388742efb4879b95fa781.tar.gz
gis/pytrainer: Added (activity viewer).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/pytrainer/README6
-rw-r--r--gis/pytrainer/doinst.sh3
-rw-r--r--gis/pytrainer/pytrainer.SlackBuild85
-rw-r--r--gis/pytrainer/pytrainer.info10
-rw-r--r--gis/pytrainer/slack-desc19
5 files changed, 123 insertions, 0 deletions
diff --git a/gis/pytrainer/README b/gis/pytrainer/README
new file mode 100644
index 0000000000..d697ab97ff
--- /dev/null
+++ b/gis/pytrainer/README
@@ -0,0 +1,6 @@
+Pytrainer is a tool to log all your sport excursion coming from GPS
+devices (with a focus on ForeRunner) or GPX files. Pytrainer supports
+GPS track files and displays it in graphs, maps...
+
+The plugins and extensions may have additional dependencies.
+See /usr/doc/pytrainer-$VERSION/INSTALL for details.
diff --git a/gis/pytrainer/doinst.sh b/gis/pytrainer/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/gis/pytrainer/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/gis/pytrainer/pytrainer.SlackBuild b/gis/pytrainer/pytrainer.SlackBuild
new file mode 100644
index 0000000000..0c6b2c5e3e
--- /dev/null
+++ b/gis/pytrainer/pytrainer.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for Pytrainer
+
+# Copyright 2014 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pytrainer
+VERSION=${VERSION:-1.10.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$(uname -m) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="CHANGES COPYING INSTALL PLUGINS.README README.md"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/v$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/pytrainer/pytrainer.info b/gis/pytrainer/pytrainer.info
new file mode 100644
index 0000000000..d0788d8b3a
--- /dev/null
+++ b/gis/pytrainer/pytrainer.info
@@ -0,0 +1,10 @@
+PRGNAM="pytrainer"
+VERSION="1.10.0"
+HOMEPAGE="https://github.com/pytrainer/pytrainer"
+DOWNLOAD="https://github.com/pytrainer/pytrainer/archive/v1.10.0.tar.gz"
+MD5SUM="66d2c18fccca2f862914f99c4110ccc4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lxml sqlalchemy-migrate python-dateutil matplotlib pywebkitgtk zenity"
+MAINTAINER="Kyle Guinn"
+EMAIL="elyk03@gmail.com"
diff --git a/gis/pytrainer/slack-desc b/gis/pytrainer/slack-desc
new file mode 100644
index 0000000000..7cee953cff
--- /dev/null
+++ b/gis/pytrainer/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pytrainer: Pytrainer (activity viewer)
+pytrainer:
+pytrainer: Pytrainer is a tool to log all your sport excursion coming from GPS
+pytrainer: devices (with a focus on ForeRunner) or GPX files. Pytrainer supports
+pytrainer: GPS track files and displays it in graphs, maps...
+pytrainer:
+pytrainer:
+pytrainer:
+pytrainer:
+pytrainer:
+pytrainer: