summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Edward W. Koenig2021-07-16 05:57:19 +0200
committer Willy Sudiarto Raharjo2021-07-17 04:50:22 +0200
commit91068fd6544b02f6dd29fac026c38190d6bed56a (patch)
tree7bc7dff275b054c317a68b8ecdfd27bcddbb501f /games
parented4e3a1749d9c867010c3ed7774deda4c4f20215 (diff)
downloadslackbuilds-91068fd6544b02f6dd29fac026c38190d6bed56a.tar.gz
games/sauerbraten: Updated for version 2020_12_27
Signed-off-by: Edward W. Koenig <kingbeowulf@linuxgalaxy.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/sauerbraten/sauerbraten.SlackBuild38
-rw-r--r--games/sauerbraten/sauerbraten.info6
2 files changed, 32 insertions, 12 deletions
diff --git a/games/sauerbraten/sauerbraten.SlackBuild b/games/sauerbraten/sauerbraten.SlackBuild
index cc40fff214..61e6b4cc43 100644
--- a/games/sauerbraten/sauerbraten.SlackBuild
+++ b/games/sauerbraten/sauerbraten.SlackBuild
@@ -1,25 +1,45 @@
-#!/bin/bash
+#!/bin/sh
# Slackware build script for sauerbraten
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
# New SBo maintainer: Edward Koenig <kingbeowulf[at]linuxgalaxy[dot]org>
#
+# Copyright 2021 Edward W. Koenig, Vancouver, WA, USA
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
# Changelog
#---------------------------------------------------------------------------------------
-# 1.0 26-DEC-2011 New SBo maintainer: Edward Koenig <kingbeowulf[at]gmail[dot]com>
-# 2.0 23-JUN-2013 new version, script clean up.
-#
+# 1.0 26-DEC-2011 New SBo maintainer: Edward Koenig <kingbeowulf[at]gmail[dot]com>
+# 2.0 23-JUN-2013 new version, script clean up.
+# 3.0 18-APR-2021 new version, added copyright notice
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sauerbraten
-VERSION=${VERSION:-2013_02_03}
+VERSION=${VERSION:-2020_12_27}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-EDITION=${EDITION:-collect_edition}
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
@@ -28,6 +48,7 @@ if [ -z "$ARCH" ]; then
esac
fi
+CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -48,7 +69,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
-tar xvf $CWD/${PRGNAM}_${VERSION}_${EDITION}_linux.tar.bz2
+tar xvf $CWD/${PRGNAM}_${VERSION}_linux.tar.bz2
cd $PRGNAM
chown -R root:root .
find -L . \
@@ -63,7 +84,6 @@ rm -f bin_unix/*
sed -i \
-e "s|-O3|$SLKCFLAGS|" \
-e '/\$(STRIP) \.\./d' \
- -e "s|\./configure|CFLAGS=\"$SLKCFLAGS\" \./configure|" \
src/Makefile
make -C src
diff --git a/games/sauerbraten/sauerbraten.info b/games/sauerbraten/sauerbraten.info
index f352f3669f..8b5e61047b 100644
--- a/games/sauerbraten/sauerbraten.info
+++ b/games/sauerbraten/sauerbraten.info
@@ -1,8 +1,8 @@
PRGNAM="sauerbraten"
-VERSION="2013_02_03"
+VERSION="2020_12_27"
HOMEPAGE="http://www.sauerbraten.org/"
-DOWNLOAD="http://downloads.sourceforge.net/sauerbraten/sauerbraten_2013_02_03_collect_edition_linux.tar.bz2"
-MD5SUM="2cfbd619981402898f97b93be08d58ac"
+DOWNLOAD="http://downloads.sourceforge.net/sauerbraten/sauerbraten_2020_12_27_linux.tar.bz2"
+MD5SUM="7935ee9ac241a255056f595ca203b4ed"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""