summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author M.Dinslage2021-07-26 04:38:29 +0200
committer Robby Workman2021-07-26 04:38:29 +0200
commit65f5fd0ab0479920c068fca4253452d82f2f1905 (patch)
tree82a3a0551068524038a564658649a3a22cacd466 /games
parentf5226a274864d9d8193291809c1db20cc68fdfcb (diff)
downloadslackbuilds-65f5fd0ab0479920c068fca4253452d82f2f1905.tar.gz
games/fceux: Updated for version 2.4.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/fceux/fceux.SlackBuild63
-rw-r--r--games/fceux/fceux.desktop9
-rw-r--r--games/fceux/fceux.info8
-rw-r--r--games/fceux/fceux.pngbin7066 -> 0 bytes
-rw-r--r--games/fceux/scons-python3.patch109
5 files changed, 35 insertions, 154 deletions
diff --git a/games/fceux/fceux.SlackBuild b/games/fceux/fceux.SlackBuild
index 0147dcfb81..d8ab3875be 100644
--- a/games/fceux/fceux.SlackBuild
+++ b/games/fceux/fceux.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for fceux
-# Copyright 2016 Matt Dinslage (daedra1980@gmail.com), Springfield, MO, USA
+# Copyright 2021 Matt Dinslage (daedra1980@gmail.com), Springfield, MO, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,18 +22,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=fceux
-VERSION=${VERSION:-2.2.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.4.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -51,17 +50,17 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="'-O2', '-march=i486', '-mtune=i686'"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="'-O2', '-march=i686', '-mtune=i686'"
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="'-O2', '-fPIC'"
+ SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
- SLKCFLAGS="'-O2'"
+ SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
@@ -71,7 +70,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.src.tar.?z*
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -80,23 +79,24 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix building with python3
-patch -p1 < $CWD/scons-python3.patch
-
-# Set our CFLAGS, move man pages, disable debub symbols
-sed -i \
- -e "s|'-Wall'|${SLKCFLAGS}, '-Wall'|" \
- -e "s|/share/man/man6/|/man/man6/|" \
- -e "s|/share/man/man6/|/man/man6/|" \
- -e "s|symbols', 1|symbols', 0|" \
- -e "s|release', 0|release', 1|" \
- SConstruct
-
-scons install -i --prefix=$PKG/usr
-
-# Delete low res icon and replace below, also delete unneeded .dll files
-rm -f $PKG/usr/share/pixmaps/fceux.png
-rm -f $PKG/usr/share/$PRGNAM/*.dll
+# Fix man pages
+sed -i 's,share/man/man6,man/man6,g' src/CMakeLists.txt
+
+# Fix incorrect version name
+sed -i 's/-interim git//g' src/version.h
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -105,12 +105,11 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a documentation/* COPYING *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-#Add icon
-cat $CWD/fceux.png > $PKG/usr/share/pixmaps/fceux.png
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
diff --git a/games/fceux/fceux.desktop b/games/fceux/fceux.desktop
deleted file mode 100644
index c21ccf8a6a..0000000000
--- a/games/fceux/fceux.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Fceux
-GenericName=Nintendo/Famicon Emulator
-Exec=fceux
-Terminal=false
-Type=Application
-Categories=Game;Emulator;
-Icon=/usr/share/pixmaps/Nintendo.png
-StartupNotify=false
diff --git a/games/fceux/fceux.info b/games/fceux/fceux.info
index faa83b3399..305157ce7c 100644
--- a/games/fceux/fceux.info
+++ b/games/fceux/fceux.info
@@ -1,10 +1,10 @@
PRGNAM="fceux"
-VERSION="2.2.3"
+VERSION="2.4.0"
HOMEPAGE="http://fceux.com/web/home.html"
-DOWNLOAD="http://downloads.sourceforge.net/fceultra/fceux-2.2.3.src.tar.gz"
-MD5SUM="8002b161ea3342decce1abcca76db84a"
+DOWNLOAD="http://downloads.sourceforge.net/fceultra/fceux-2.4.0.tar.gz"
+MD5SUM="373ddc61b8e9557f1e8ba27a8ff10697"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="libminizip"
MAINTAINER="M.Dinslage"
EMAIL="daedra1980@gmail.com"
diff --git a/games/fceux/fceux.png b/games/fceux/fceux.png
deleted file mode 100644
index a9e7823333..0000000000
--- a/games/fceux/fceux.png
+++ /dev/null
Binary files differ
diff --git a/games/fceux/scons-python3.patch b/games/fceux/scons-python3.patch
deleted file mode 100644
index c5a1080f60..0000000000
--- a/games/fceux/scons-python3.patch
+++ /dev/null
@@ -1,109 +0,0 @@
---- fceux-2.2.3/SConstruct.orig 2019-07-26 18:04:29.368573309 +0000
-+++ fceux-2.2.3/SConstruct 2019-07-26 18:04:31.975265342 +0000
-@@ -46,30 +46,30 @@
- # Default compiler flags:
- env.Append(CCFLAGS = ['-Wall', '-Wno-write-strings', '-Wno-sign-compare'])
-
--if os.environ.has_key('PLATFORM'):
-+if os.environ.get('PLATFORM'):
- env.Replace(PLATFORM = os.environ['PLATFORM'])
--if os.environ.has_key('CC'):
-+if os.environ.get('CC'):
- env.Replace(CC = os.environ['CC'])
--if os.environ.has_key('CXX'):
-+if os.environ.get('CXX'):
- env.Replace(CXX = os.environ['CXX'])
--if os.environ.has_key('WINDRES'):
-+if os.environ.get('WINDRES'):
- env.Replace(WINDRES = os.environ['WINDRES'])
--if os.environ.has_key('CFLAGS'):
-+if os.environ.get('CFLAGS'):
- env.Append(CCFLAGS = os.environ['CFLAGS'].split())
--if os.environ.has_key('CXXFLAGS'):
-+if os.environ.get('CXXFLAGS'):
- env.Append(CXXFLAGS = os.environ['CXXFLAGS'].split())
--if os.environ.has_key('CPPFLAGS'):
-+if os.environ.get('CPPFLAGS'):
- env.Append(CPPFLAGS = os.environ['CPPFLAGS'].split())
--if os.environ.has_key('LDFLAGS'):
-+if os.environ.get('LDFLAGS'):
- env.Append(LINKFLAGS = os.environ['LDFLAGS'].split())
--if os.environ.has_key('PKG_CONFIG_PATH'):
-+if os.environ.get('PKG_CONFIG_PATH'):
- env['ENV']['PKG_CONFIG_PATH'] = os.environ['PKG_CONFIG_PATH']
--if not os.environ.has_key('PKG_CONFIG_PATH') and env['PLATFORM'] == 'darwin':
-+if not os.environ.get('PKG_CONFIG_PATH') and env['PLATFORM'] == 'darwin':
- env['ENV']['PKG_CONFIG_PATH'] = "/usr/local/lib/pkgconfig:/opt/X11/lib/pkgconfig"
--if os.environ.has_key('PKG_CONFIG_LIBDIR'):
-+if os.environ.get('PKG_CONFIG_LIBDIR'):
- env['ENV']['PKG_CONFIG_LIBDIR'] = os.environ['PKG_CONFIG_LIBDIR']
-
--print "platform: ", env['PLATFORM']
-+print ("platform: ", env['PLATFORM'])
-
- # compile with clang
- if env['CLANG']:
-@@ -103,18 +103,18 @@
- assert conf.CheckLibWithHeader('z', 'zlib.h', 'c', 'inflate;', 1), "please install: zlib"
- if env['SDL2']:
- if not conf.CheckLib('SDL2'):
-- print 'Did not find libSDL2 or SDL2.lib, exiting!'
-+ print ('Did not find libSDL2 or SDL2.lib, exiting!')
- Exit(1)
- env.Append(CPPDEFINES=["_SDL2"])
- env.ParseConfig('pkg-config sdl2 --cflags --libs')
- else:
- if not conf.CheckLib('SDL'):
-- print 'Did not find libSDL or SDL.lib, exiting!'
-+ print ('Did not find libSDL or SDL.lib, exiting!')
- Exit(1)
- env.ParseConfig('sdl-config --cflags --libs')
- if env['GTK']:
- if not conf.CheckLib('gtk-x11-2.0'):
-- print 'Could not find libgtk-2.0, exiting!'
-+ print ('Could not find libgtk-2.0, exiting!')
- Exit(1)
- # Add compiler and linker flags from pkg-config
- config_string = 'pkg-config --cflags --libs gtk+-2.0'
-@@ -153,7 +153,7 @@
- env.Append(CCFLAGS = ["-I/usr/include/lua"])
- lua_available = True
- if lua_available == False:
-- print 'Could not find liblua, exiting!'
-+ print ('Could not find liblua, exiting!')
- Exit(1)
- else:
- env.Append(CCFLAGS = ["-Isrc/lua/src"])
-@@ -167,7 +167,7 @@
- gd = conf.CheckLib('gd', autoadd=1)
- if gd == 0:
- env['LOGO'] = 0
-- print 'Did not find libgd, you won\'t be able to create a logo screen for your avis.'
-+ print ('Did not find libgd, you won\'t be able to create a logo screen for your avis.')
-
- if env['OPENGL'] and conf.CheckLibWithHeader('GL', 'GL/gl.h', 'c', autoadd=1):
- conf.env.Append(CCFLAGS = "-DOPENGL")
-@@ -181,8 +181,8 @@
- if env['FRAMESKIP']:
- env.Append(CPPDEFINES = ['FRAMESKIP'])
-
--print "base CPPDEFINES:",env['CPPDEFINES']
--print "base CCFLAGS:",env['CCFLAGS']
-+print ("base CPPDEFINES:",env['CPPDEFINES'])
-+print ("base CCFLAGS:",env['CCFLAGS'])
-
- if env['DEBUG']:
- env.Append(CPPDEFINES=["_DEBUG"], CCFLAGS = ['-g', '-O0'])
---- fceux-2.2.3/src/SConscript.orig 2019-07-26 18:08:11.297535443 +0000
-+++ fceux-2.2.3/src/SConscript 2019-07-26 18:08:33.857781956 +0000
-@@ -33,7 +33,7 @@
- platform_files = SConscript('drivers/sdl/SConscript')
- file_list.append(platform_files)
-
--print env['LINKFLAGS']
-+print (env['LINKFLAGS'])
-
- if env['PLATFORM'] == 'win32':
- fceux = env.Program('fceux.exe', file_list)
-
-