summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson2020-12-19 07:02:42 +0100
committer Willy Sudiarto Raharjo2020-12-26 10:40:36 +0100
commit8d27c871171d871ce66d72cc108133a6a24a86a8 (patch)
tree6dc34017d458640b29f7903e69129caf984b5aa9 /games
parent2d25130a97c90345053ff5d32b59e43ffabd0637 (diff)
downloadslackbuilds-8d27c871171d871ce66d72cc108133a6a24a86a8.tar.gz
games/hatari: Updated for version 2.3.0.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/hatari/hatari.SlackBuild26
-rw-r--r--games/hatari/hatari.info8
-rw-r--r--games/hatari/manpage.diff290
-rw-r--r--games/hatari/slack-desc2
4 files changed, 283 insertions, 43 deletions
diff --git a/games/hatari/hatari.SlackBuild b/games/hatari/hatari.SlackBuild
index 35adec40d0..aad63b65a6 100644
--- a/games/hatari/hatari.SlackBuild
+++ b/games/hatari/hatari.SlackBuild
@@ -6,6 +6,11 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20201218 bkw:
+# - update for v2.3.0. Can't build older versions, sorry.
+# - add new dep, python3.
+# - really fix the man pages.
+
# 20200426 bkw:
# - BUILD=2
# - Include support for IPF and CTR images (copy-protected images),
@@ -58,8 +63,8 @@
# - add mime type and auto-associate ST disk images and executables.
PRGNAM=hatari
-VERSION=${VERSION:-2.2.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.3.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -75,6 +80,8 @@ TMP=${TMP-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+# Note: the -O2 here gets overridden by a -O3 that comes later on the
+# command line. Upstream tests with -O3 so it should be fine.
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
@@ -105,9 +112,8 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
# so let's have hatariui use that instead of failing.
patch -p1 < $CWD/hatariui-create-cfg-if-missing.diff
-# man page hadn't been updated since 2014, it says the config file lives
-# in the old ~/.hatari/ location. also fix a few typos and formatting
-# issues.
+# Man pages go in section 6, fix .TH and see-also refs. Also fix a few
+# typos and formatting issues.
patch -p1 < $CWD/manpage.diff
# cmake doesn't support anything like --bindir, --mandir, --docdir. cheat
@@ -118,9 +124,6 @@ sed -i \
-e "s,share/doc/$PRGNAM,doc/$PRGNAM-$VERSION," \
CMakeLists.txt
-# man pages should be in section 6
-sed -i '/\.TH/s,"1","6",' doc/*.1 doc/fr/*.1 tools/*.1 python-ui/*.1
-
# Hard-code the doc path in the UI (we don't use /usr/share/doc/hatari)
sed -i \
-e "/path *= *path *+/s,=.*,= \"/usr/doc/$PRGNAM-$VERSION/\"," \
@@ -140,16 +143,23 @@ sed -i 's/ncurses\.h/&;readline.h/' cmake/FindReadline.cmake
# and libcapsimage 5.1 doesn't support a couple of typedefs that
# existed in 4.2.
+# 20201218 bkw: the source says '#include <caps/CapsLibAll.h>' but
+# we need <caps5/CapsLibAll.h>.
sed -i \
-e '1i#include <stdint.h>' \
-e 's,CapsLong,int32_t,g' \
-e 's,CapsULong,uint32_t,g' \
+ -e '/#include/s,caps/,caps5/,' \
src/floppy_ipf.c
# 20200427 bkw: upstream actually runs cmake directly in the source
# dir rather than the "mkdir build; cd build; cmake .." stuff from
# our template. I'm going to do it their way.
+# 20201218 bkw: I really should not have to tell cmake to look in
+# /usr/include for the libcapsimage headers, that is *the systemwide
+# default location* for includes, and has been since the 1970s. Grr.
cmake \
+ -DCAPSIMAGE_INCLUDE_DIR=/usr/include \
-DCMAKE_VERBOSE_MAKEFILE=TRUE \
$SDL2OPT \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
diff --git a/games/hatari/hatari.info b/games/hatari/hatari.info
index 8b8bfb1610..0b25abe8c2 100644
--- a/games/hatari/hatari.info
+++ b/games/hatari/hatari.info
@@ -1,10 +1,10 @@
PRGNAM="hatari"
-VERSION="2.2.1"
+VERSION="2.3.0"
HOMEPAGE="http://hatari.tuxfamily.org/"
-DOWNLOAD="http://download.tuxfamily.org/hatari/2.2.1/hatari-2.2.1.tar.bz2"
-MD5SUM="fc8d3a14b38714ea0b0800fda6b5cab7"
+DOWNLOAD="http://download.tuxfamily.org/hatari/2.3.0/hatari-2.3.0.tar.bz2"
+MD5SUM="eefd32d63ad0d264f51406f2e7009e23"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3"
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"
diff --git a/games/hatari/manpage.diff b/games/hatari/manpage.diff
index 82f9ed921a..0269253476 100644
--- a/games/hatari/manpage.diff
+++ b/games/hatari/manpage.diff
@@ -1,25 +1,28 @@
-diff -Naur hatari-2.2.1/doc/hatari.1 hatari-2.2.1.patched/doc/hatari.1
---- hatari-2.2.1/doc/hatari.1 2019-02-08 03:30:10.000000000 -0500
-+++ hatari-2.2.1.patched/doc/hatari.1 2020-04-26 23:41:11.738132546 -0400
+diff -Naur hatari-2.3.0/doc/fr/hatari.1 hatari-2.3.0.patched/doc/fr/hatari.1
+--- hatari-2.3.0/doc/fr/hatari.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/doc/fr/hatari.1 2020-12-19 00:50:09.455505119 -0500
@@ -2,7 +2,7 @@
.\" First parameter, NAME, should be all caps
.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
.\" other parameters are allowed: see man(7), man(1)
--.TH "HATARI" "1" "2014-05-08" "Hatari" ""
-+.TH "HATARI" "1" "2020-04-26" "Hatari" ""
+-.TH "HATARI" "1" "2008-03-14" "Hatari" ""
++.TH "HATARI" "6" "2008-03-14" "Hatari" ""
.\" Please adjust this date whenever revising the manpage.
.SH "NAME"
-@@ -557,7 +557,7 @@
- .TP
- .B \-\-benchmark
- Start in benchmark mode (use with --run-vbls).
--This allows to measure the speed of the emulation in frames per second
-+This allows measuring the speed of the emulation in frames per second
- by running at maximum speed (don't wait for VBL). Disable audio/video
- output to have as little OS overhead as possible
+diff -Naur hatari-2.3.0/doc/hatari.1 hatari-2.3.0.patched/doc/hatari.1
+--- hatari-2.3.0/doc/hatari.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/doc/hatari.1 2020-12-19 00:49:56.399506306 -0500
+@@ -2,7 +2,7 @@
+ .\" First parameter, NAME, should be all caps
+ .\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+ .\" other parameters are allowed: see man(7), man(1)
+-.TH "HATARI" "1" "2020-11-27" "Hatari" ""
++.TH "HATARI" "6" "2020-12-18" "Hatari" ""
+ .\" Please adjust this date whenever revising the manpage.
-@@ -599,7 +599,9 @@
+ .SH "NAME"
+@@ -668,7 +668,9 @@
will act as
.B Alternate
as well as long as you do not press it together with a Hatari hotkey
@@ -30,7 +33,26 @@ diff -Naur hatari-2.2.1/doc/hatari.1 hatari-2.2.1.patched/doc/hatari.1
.PP
The
.B right Ctrl
-@@ -730,33 +732,45 @@
+@@ -788,40 +790,49 @@
+ .PP
+ Other Hatari programs and utilities:
+ .br
+-.IR hmsa (1),
+-.IR zip2st (1),
+-.IR atari\-convert\-dir (1),
+-.IR atari\-hd\-image (1),
+-.IR hatariui (1),
+-.IR hconsole (1),
+-.IR gst2ascii (1),
+-.IR hatari_profile (1)
++.IR hmsa (6),
++.IR zip2st (6),
++.IR atari\-convert\-dir (6),
++.IR atari\-hd\-image (6),
++.IR hatariui (6),
++.IR hconsole (6),
++.IR gst2ascii (6),
++.IR hatari_profile (6)
.SH "FILES AND DIRECTORIES"
.TP
@@ -38,8 +60,7 @@ diff -Naur hatari-2.2.1/doc/hatari.1 hatari-2.2.1.patched/doc/hatari.1
+/etc/hatari.cfg
The global configuration file of Hatari.
.TP
--~/.hatari/
-+~/.config/hatari/
+ ~/.config/hatari/
The (default) directory for user's personal Hatari files;
-.B hatari.cfg
+.RS 2
@@ -59,14 +80,6 @@ diff -Naur hatari-2.2.1/doc/hatari.1 hatari-2.2.1.patched/doc/hatari.1
+.TP
+hatari.prn
(printer output file),
--.B hatari.wav
-+.TP
-+hatari.wav
- (recorded sound output in WAV format),
--.B hatari.ym
-+.TP
-+hatari.ym
- (recorded sound output in YM format).
+.RE
.TP
-/usr/share/hatari/ (or /usr/local/share/hatari/)
@@ -81,9 +94,226 @@ diff -Naur hatari-2.2.1/doc/hatari.1 hatari-2.2.1.patched/doc/hatari.1
.SH "AUTHOR"
This manual page was written by Marco Herrn <marco@mherrn.de> for the
--Debian project and later modified by Thomas Huth and Eero Tamminen to
+ Debian project and later modified by Thomas Huth and Eero Tamminen to
-suit the latest version of Hatari.
-+Debian project and later modified by Thomas Huth and Eero Tamminen to suit
-+the (then) latest version of Hatari. Later it was modified by B. Watson
-+<yalhcru@gmail.com> for the SlackBuilds.org project to suit the latest
-+(2.2.1) version of Hatari, and to fix some of the formatting.
++suit the latest version of Hatari. Later it was modified by B. Watson
++<yalhcru@gmail.com> for the SlackBuilds.org project to fix some formatting.
+diff -Naur hatari-2.3.0/python-ui/hatariui.1 hatari-2.3.0.patched/python-ui/hatariui.1
+--- hatari-2.3.0/python-ui/hatariui.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/python-ui/hatariui.1 2020-12-19 00:50:20.615504105 -0500
+@@ -2,7 +2,7 @@
+ .\" First parameter, NAME, should be all caps
+ .\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+ .\" other parameters are allowed: see man(7), man(1)
+-.TH "hatariui" "1" "2019-02-24" "Hatari" "Hatari UI"
++.TH "hatariui" "6" "2019-02-24" "Hatari" "Hatari UI"
+ .SH "NAME"
+ hatariui \- Python/Gtk UI for Hatari
+ .SH "SYNOPSIS"
+@@ -211,9 +211,9 @@
+ For more examples on Hatari UI options usage, see the hatariui shell
+ script.
+ .SH "SEE ALSO"
+-.IR hmsa (1),
+-.IR hatariui (1),
+-.IR hconsole (1)
++.IR hmsa (6),
++.IR hatariui (6),
++.IR hconsole (6)
+ .SH "COPYRIGHT"
+ Hatari UI is written by Eero Tamminen <oak at helsinkinet fi>.
+ .PP
+diff -Naur hatari-2.3.0/tools/atari-convert-dir.1 hatari-2.3.0.patched/tools/atari-convert-dir.1
+--- hatari-2.3.0/tools/atari-convert-dir.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/tools/atari-convert-dir.1 2020-12-19 00:47:26.732519911 -0500
+@@ -1,4 +1,4 @@
+-.TH "atari-convert-dir" "1" "2015-04-26" "Hatari" "Hatari utilities"
++.TH "atari-convert-dir" "6" "2015-04-26" "Hatari" "Hatari utilities"
+ .SH NAME
+ atari\-convert\-dir \- helper for creating Atari compatible disk images
+ .SH SYNOPSIS
+@@ -16,9 +16,9 @@
+ use is also recommended with \fIzip2st\fP tool content (because Mtools
+ \fImcopy\fP doesn't convert long file names correctly for Atari).
+ .SH SEE ALSO
+-.IR atari\-hd\-image (1),
+-.IR zip2st (1),
+-.IR hatari (1),
++.IR atari\-hd\-image (6),
++.IR zip2st (6),
++.IR hatari (6),
+ .IR mcopy (1)
+ .SH "AUTHOR"
+ Written by Eero Tamminen <oak at helsinkinet fi>.
+diff -Naur hatari-2.3.0/tools/atari-hd-image.1 hatari-2.3.0.patched/tools/atari-hd-image.1
+--- hatari-2.3.0/tools/atari-hd-image.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/tools/atari-hd-image.1 2020-12-19 00:47:08.660521554 -0500
+@@ -1,4 +1,4 @@
+-.TH "atari-hd-image" "1" "2015-04-26" "Hatari" "Hatari utilities"
++.TH "atari-hd-image" "6" "2015-04-26" "Hatari" "Hatari utilities"
+ .SH NAME
+ atari\-hd\-image \- tool for creating a harddisk image for use with Hatari
+ .SH SYNOPSIS
+@@ -37,12 +37,12 @@
+ 8MB image with partition named 'TEST', and files from content/:
+ .B atari\-hd\-image 8 8mb-disk.img TEST content/
+ .SH SEE ALSO
+-.IR atari\-convert\-dir (1),
+-.IR hmsa (1),
+-.IR zip2st (1),
+-.IR hatari (1),
+-.IR mkdosfs (1),
+-.IR sfdisk (1),
++.IR atari\-convert\-dir (6),
++.IR hmsa (6),
++.IR zip2st (6),
++.IR hatari (6),
++.IR mkdosfs (8),
++.IR sfdisk (8),
+ .IR dd (1)
+ .SH "AUTHOR"
+ Written by Eero Tamminen <oak at helsinkinet fi>.
+diff -Naur hatari-2.3.0/tools/debugger/gst2ascii.1 hatari-2.3.0.patched/tools/debugger/gst2ascii.1
+--- hatari-2.3.0/tools/debugger/gst2ascii.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/tools/debugger/gst2ascii.1 2020-12-19 00:48:17.759515273 -0500
+@@ -2,7 +2,7 @@
+ .\" First parameter, NAME, should be all caps
+ .\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+ .\" other parameters are allowed: see man(7), man(1)
+-.TH "GST2ASCII" "1" "2017-11-11" "Hatari" "Hatari utilities"
++.TH "GST2ASCII" "6" "2017-11-11" "Hatari" "Hatari utilities"
+ .SH "NAME"
+ gst2ascii \- Filter and output Atari program symbol table as ASCII
+ .SH "SYNOPSIS"
+@@ -60,8 +60,8 @@
+ .br
+ symbols program.sym TEXT DATA BSS
+ .SH "SEE ALSO"
+-.IR hatari (1),
+-.IR hatari_profile (1)
++.IR hatari (6),
++.IR hatari_profile (6)
+ .SH "AUTHOR"
+ Written by Eero Tamminen <oak at helsinkinet fi>.
+ .SH "LICENSE"
+diff -Naur hatari-2.3.0/tools/debugger/hatari_profile.1 hatari-2.3.0.patched/tools/debugger/hatari_profile.1
+--- hatari-2.3.0/tools/debugger/hatari_profile.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/tools/debugger/hatari_profile.1 2020-12-19 00:55:04.273478319 -0500
+@@ -2,7 +2,7 @@
+ .\" First parameter, NAME, should be all caps
+ .\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+ .\" other parameters are allowed: see man(7), man(1)
+-.TH "HATARI_PROFILE" "1" "2013-04-15" "Hatari" "Hatari utilities"
++.TH "HATARI_PROFILE" "6" "2013-04-15" "Hatari" "Hatari utilities"
+ .SH "NAME"
+ hatari_profile \- Post-processor for Hatari profiler data
+ .SH "SYNOPSIS"
+@@ -135,10 +135,10 @@
+ -------------------------------------------------------------
+ .fi
+ .SH "SEE ALSO"
+-.IR hatari (1),
+-.IR gst2ascii (1),
+-.IR hconsole (1)
+-.IR hatariui (1)
++.IR hatari (6),
++.IR gst2ascii (6),
++.IR hconsole (6),
++.IR hatariui (6)
+ .SH "AUTHOR"
+ Written by Eero Tamminen <oak at helsinkinet fi>.
+ .SH "LICENSE"
+diff -Naur hatari-2.3.0/tools/hatari-prg-args.1 hatari-2.3.0.patched/tools/hatari-prg-args.1
+--- hatari-2.3.0/tools/hatari-prg-args.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/tools/hatari-prg-args.1 2020-12-19 00:49:08.415510668 -0500
+@@ -1,4 +1,4 @@
+-.TH "hatari-prg-args" "1" "2018-05-01" "Hatari" "Hatari utilities"
++.TH "hatari-prg-args" "6" "2018-05-01" "Hatari" "Hatari utilities"
+ .SH NAME
+ hatari\-prg\-args \- autorun Atari programs with arguments
+ .SH SYNOPSIS
+@@ -37,8 +37,8 @@
+ Run it from disk image instead of host directory:
+ .B hatari\-prg\-args -m -- 'A:\\\\SIDPLAY.TTP' 'SIDS\\\\TEST.SID'
+ .SH SEE ALSO
+-.IR hatari (1),
+-.IR hconsole (1)
++.IR hatari (6),
++.IR hconsole (6)
+ .SH "AUTHOR"
+ Written by Eero Tamminen <oak at helsinkinet fi>.
+ .SH "LICENSE"
+diff -Naur hatari-2.3.0/tools/hconsole/hconsole.1 hatari-2.3.0.patched/tools/hconsole/hconsole.1
+--- hatari-2.3.0/tools/hconsole/hconsole.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/tools/hconsole/hconsole.1 2020-12-19 00:49:34.615508286 -0500
+@@ -2,7 +2,7 @@
+ .\" First parameter, NAME, should be all caps
+ .\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+ .\" other parameters are allowed: see man(7), man(1)
+-.TH "HCONSOLE" "1" "2010-10-10" "Hatari" "Hatari utilities"
++.TH "HCONSOLE" "6" "2010-10-10" "Hatari" "Hatari utilities"
+ .SH "NAME"
+ hconsole \- Interactive Python console for using Hatari's remote API
+ .SH "SYNOPSIS"
+@@ -52,8 +52,8 @@
+ By default hconsole and its examples are installed under
+ the /usr/share/hatari/hconsole/ directory.
+ .SH "SEE ALSO"
+-.IR hatari (1),
+-.IR hatariui (1)
++.IR hatari (6),
++.IR hatariui (6)
+ .SH "AUTHOR"
+ Written by Eero Tamminen <oak at helsinkinet fi>.
+ .SH "LICENSE"
+diff -Naur hatari-2.3.0/tools/hmsa/hmsa.1 hatari-2.3.0.patched/tools/hmsa/hmsa.1
+--- hatari-2.3.0/tools/hmsa/hmsa.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/tools/hmsa/hmsa.1 2020-12-19 00:47:44.567518290 -0500
+@@ -2,7 +2,7 @@
+ .\" First parameter, NAME, should be all caps
+ .\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+ .\" other parameters are allowed: see man(7), man(1)
+-.TH "HMSA" "1" "2010-05-30" "Hatari" "Hatari utilities"
++.TH "HMSA" "6" "2010-05-30" "Hatari" "Hatari utilities"
+ .SH "NAME"
+ hmsa \- Atari MSA / ST disk image creator and converter
+ .SH "SYNOPSIS"
+@@ -48,9 +48,9 @@
+ .br
+ hmsa disk.msa
+ .SH "SEE ALSO"
+-.IR hatari (1),
+-.IR zip2st (1),
+-.IR atari\-hd\-image (1)
++.IR hatari (6),
++.IR zip2st (6),
++.IR atari\-hd\-image (6)
+ .SH "AUTHOR"
+ Written by Thomas Huth <huth at tuxfamily.org>. This manual page
+ added by Eero Tamminen <oak at helsinkinet fi>.
+diff -Naur hatari-2.3.0/tools/zip2st.1 hatari-2.3.0.patched/tools/zip2st.1
+--- hatari-2.3.0/tools/zip2st.1 2020-11-28 08:37:58.000000000 -0500
++++ hatari-2.3.0.patched/tools/zip2st.1 2020-12-19 00:49:25.742509093 -0500
+@@ -1,4 +1,4 @@
+-.TH "ZIP2ST" "1" "2016-02-26" "Hatari" "Hatari utilities"
++.TH "ZIP2ST" "6" "2016-02-26" "Hatari" "Hatari utilities"
+ .SH NAME
+ zip2st \- convert directory or .zip archive to .st disk image
+ .SH SYNOPSIS
+@@ -29,11 +29,11 @@
+ within a .zip archive, you need to extract them before conversion.
+ .PP
+ .SH SEE ALSO
+-.IR hmsa (1),
+-.IR atari\-convert\-dir (1),
+-.IR atari\-hd\-image (1),
+-.IR hatari (1),
+-.IR unzip (1),
++.IR hmsa (6),
++.IR atari\-convert\-dir (6),
++.IR atari\-hd\-image (6),
++.IR hatari (6),
++.IR unzip (6),
+ .IR mtools (1),
+ .IR basename (1),
+ .IR dd (1).
diff --git a/games/hatari/slack-desc b/games/hatari/slack-desc
index fa776a63b7..7c55291048 100644
--- a/games/hatari/slack-desc
+++ b/games/hatari/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-hatari: hatari (Atari ST/STE/Falcon)
+hatari: hatari (Atari ST/STE/Falcon emulator)
hatari:
hatari: Hatari is an Atari ST/STE/Falcon emulator for Linux and other systems
hatari: that are supported by the SDL library. The Atari ST was a 16/32 bit