summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Daniel Prosser2019-02-08 18:28:08 +0100
committer Willy Sudiarto Raharjo2019-02-08 18:28:08 +0100
commit2833874bf82b454ed2344e30bce4c281a3fd424d (patch)
tree436188ab7e4964d3faf22fdcd01249f7f64a13f9 /games
parent8edf9d0f958df503b64d95f21f8dd2f2f9990d96 (diff)
downloadslackbuilds-2833874bf82b454ed2344e30bce4c281a3fd424d.tar.gz
games/crrcsim: Added (model airplane flight simulator).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/crrcsim/CRRCsim.desktop11
-rw-r--r--games/crrcsim/README5
-rw-r--r--games/crrcsim/crrcsim.SlackBuild108
-rw-r--r--games/crrcsim/crrcsim.info10
-rw-r--r--games/crrcsim/doinst.sh3
-rw-r--r--games/crrcsim/slack-desc19
6 files changed, 156 insertions, 0 deletions
diff --git a/games/crrcsim/CRRCsim.desktop b/games/crrcsim/CRRCsim.desktop
new file mode 100644
index 0000000000..8875885c63
--- /dev/null
+++ b/games/crrcsim/CRRCsim.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Comment=A Model-Airplane Flight Simulation Program
+TryExec=/usr/bin/crrcsim
+Exec=/usr/bin/crrcsim
+Icon=/usr/share/crrcsim/icons/crrcsim.png
+Name=CRRCsim
+Categories=Game;
+Terminal=false
+StartupNotify=true
diff --git a/games/crrcsim/README b/games/crrcsim/README
new file mode 100644
index 0000000000..5249fe894e
--- /dev/null
+++ b/games/crrcsim/README
@@ -0,0 +1,5 @@
+CRRCSim is a model airplane flight simulation program for Linux with ports to
+other platforms. Using CRRCSim you can learn how to fly model aircraft, test
+new aircraft designs, and improve your skills by practicing in the relative
+safety of your PC. CRRCSim specializes in thermal and slope soaring simulation,
+though powered models are also included.
diff --git a/games/crrcsim/crrcsim.SlackBuild b/games/crrcsim/crrcsim.SlackBuild
new file mode 100644
index 0000000000..ab12c3bab1
--- /dev/null
+++ b/games/crrcsim/crrcsim.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/sh
+
+# Slackware build script for crrcsim
+
+# Copyright 2019 Daniel Prosser, Lexington Park, MD
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=crrcsim
+VERSION=${VERSION:-0.9.13}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Boost libraries are now threadsafe; -mt has been dropped
+sed -i 's/boost_thread-mt/boost_thread/g' configure.ac
+./autogen.sh
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/share/applications
+cp -a $CWD/CRRCsim.desktop $PKG/usr/share/applications
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING HISTORY $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/crrcsim/crrcsim.info b/games/crrcsim/crrcsim.info
new file mode 100644
index 0000000000..6464479612
--- /dev/null
+++ b/games/crrcsim/crrcsim.info
@@ -0,0 +1,10 @@
+PRGNAM="crrcsim"
+VERSION="0.9.13"
+HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
+DOWNLOAD="https://downloads.sourceforge.net/project/crrcsim/crrcsim/crrcsim-0.9.13/crrcsim-0.9.13.tar.gz"
+MD5SUM="fbb66c148389e998afe149a34a88abeb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="plib CGAL portaudio"
+MAINTAINER="Daniel Prosser"
+EMAIL="dpross1100@msn.com"
diff --git a/games/crrcsim/doinst.sh b/games/crrcsim/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/games/crrcsim/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/games/crrcsim/slack-desc b/games/crrcsim/slack-desc
new file mode 100644
index 0000000000..5eb0f82614
--- /dev/null
+++ b/games/crrcsim/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+crrcsim: crrcsim (model airplane flight simulator)
+crrcsim:
+crrcsim: CRRCSim is a model airplane flight simulation program for Linux with
+crrcsim: ports to other platforms. Using CRRCSim you can learn how to fly model
+crrcsim: aircraft, test new aircraft designs, and improve your skills by
+crrcsim: practicing in the relative safety of your PC.
+crrcsim:
+crrcsim: homepage: https://sourceforge.net/projects/crrcsim/
+crrcsim:
+crrcsim:
+crrcsim: