summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Dimitris Zlatanidis2015-03-27 14:40:20 +0100
committer Willy Sudiarto Raharjo2015-03-27 20:22:16 +0100
commit6aec4bac397d14219364da35f2cfdca8365568d4 (patch)
treec166e0d4644b342fdc086259f55229ca8b69aa0b /games
parent042b3ca1fcfa3a9aacc86842f3e3b307fa1af395 (diff)
downloadslackbuilds-6aec4bac397d14219364da35f2cfdca8365568d4.tar.gz
games/goonies: Added (A remake of the MSX Goonies game).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/goonies/README4
-rw-r--r--games/goonies/doinst.sh3
-rw-r--r--games/goonies/goonies.SlackBuild90
-rw-r--r--games/goonies/goonies.info10
-rw-r--r--games/goonies/makefile.patch27
-rw-r--r--games/goonies/slack-desc19
6 files changed, 153 insertions, 0 deletions
diff --git a/games/goonies/README b/games/goonies/README
new file mode 100644
index 0000000000..749d4deca0
--- /dev/null
+++ b/games/goonies/README
@@ -0,0 +1,4 @@
+Welcome to the Brain Games remake of the 8 bit classic game 'The
+Goonies'. This game was made by Konami in 1986. There were both a NES
+version and an MSX version of the game; this remake is based on the
+MSX version.
diff --git a/games/goonies/doinst.sh b/games/goonies/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/games/goonies/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/games/goonies/goonies.SlackBuild b/games/goonies/goonies.SlackBuild
new file mode 100644
index 0000000000..259d6ef8c1
--- /dev/null
+++ b/games/goonies/goonies.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for goonies
+
+# Copyright 2014 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=goonies.src
+PRGNAM=$(echo $SRCNAM | cut -c1-7)
+VERSION=${VERSION:-1.4.1528}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM\_$VERSION.tgz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# fix linker and installation paths
+patch -p1 < $CWD/makefile.patch
+
+make
+make install PREFIX=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/goonies/goonies.info b/games/goonies/goonies.info
new file mode 100644
index 0000000000..9f6568b6b7
--- /dev/null
+++ b/games/goonies/goonies.info
@@ -0,0 +1,10 @@
+PRGNAM="goonies"
+VERSION="1.4.1528"
+HOMEPAGE="http://www.braingames.getput.com/goonies/"
+DOWNLOAD="http://braingames.jorito.net/goonies/downloads/goonies.src_1.4.1528.tgz"
+MD5SUM="7c220958a0766fb716d2d0081c81e8bd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/games/goonies/makefile.patch b/games/goonies/makefile.patch
new file mode 100644
index 0000000000..a2454a0592
--- /dev/null
+++ b/games/goonies/makefile.patch
@@ -0,0 +1,27 @@
+--- goonies-1.4.1528/build/linux/Makefile.orig 2015-03-26 04:24:44.994794899 +0200
++++ goonies-1.4.1528/build/linux/Makefile 2015-03-26 05:08:09.457234638 +0200
+@@ -3,11 +3,11 @@
+ PREFIX = /usr
+ EXTRADIR = ./build/linux
+
+-GAMEDIR = $(PREFIX)/games
++GAMEDIR = $(PREFIX)/usr/bin
+ STARTUP = $(GAMEDIR)/$(EXE)
+-BINDIR = $(PREFIX)/share/games/$(EXE)
+-ICNDIR = $(PREFIX)/share/pixmaps
+-APPDIR = $(PREFIX)/share/applications
++BINDIR = $(PREFIX)/usr/share/games/$(EXE)
++ICNDIR = $(PREFIX)/usr/share/pixmaps
++APPDIR = $(PREFIX)/usr/share/applications
+
+ DATA = graphics maps sound
+ ICON = goonies.png
+@@ -58,7 +58,7 @@
+
+ CC = gcc
+ CFLAGS = -g3 -O3 -Wno-write-strings `sdl-config --cflags` -I/usr/X11R6/include
+-LDFLAGS = `sdl-config --libs` -L/usr/X11R6/lib/ -lSDL_image -lSDL_mixer -lGL -lGLU
++LDFLAGS = `sdl-config --libs` -L/usr/X11R6/lib/ -lSDL_image -lSDL_mixer -lGL -lGLU -lm -lstdc++
+ RM = rm -f
+ CP = cp -r
+ MD = mkdir -p
diff --git a/games/goonies/slack-desc b/games/goonies/slack-desc
new file mode 100644
index 0000000000..cbdec230da
--- /dev/null
+++ b/games/goonies/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+goonies: goonies (A remake of the MSX Goonies game)
+goonies:
+goonies: Welcome to the Brain Games remake of the 8 bit classic game 'The
+goonies: Goonies'. This game was made by Konami in 1986. There were both a NES
+goonies: version and an MSX version of the game; this remake is based on the
+goonies: MSX version.
+goonies:
+goonies: Homepage: http://www.braingames.getput.com/goonies/
+goonies:
+goonies:
+goonies: