summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Larry Hajali2013-04-10 20:48:58 +0200
committer Robby Workman2013-04-16 00:21:02 +0200
commite7ea0f4d71fa13e8afaa66fca7abcef9a68c5df7 (patch)
treeef945281e6aa945882ab657166e19503d36e039c /games
parent28d02811e7ab6705e55bfe0e72ca651f29c15028 (diff)
downloadslackbuilds-e7ea0f4d71fa13e8afaa66fca7abcef9a68c5df7.tar.gz
games/opensonic: Added (game based on Sonic the Hedgehog)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/opensonic/README7
-rw-r--r--games/opensonic/doinst.sh3
-rw-r--r--games/opensonic/opensonic.SlackBuild105
-rw-r--r--games/opensonic/opensonic.desktop10
-rw-r--r--games/opensonic/opensonic.info10
-rw-r--r--games/opensonic/slack-desc19
6 files changed, 154 insertions, 0 deletions
diff --git a/games/opensonic/README b/games/opensonic/README
new file mode 100644
index 0000000000..aadf1c8cb2
--- /dev/null
+++ b/games/opensonic/README
@@ -0,0 +1,7 @@
+Open Sonic is an open-source game based on the "Sonic the Hedgehog"
+universe. It introduces a different style of gameplay called
+cooperative play, in which it's possible to control 3 characters
+simultaneously. Unlike most similar games, Open Sonic provides a greater
+level of interaction between the player and the levels. It's more than
+just a jump'n'run; the user must come up with some strategy in order to
+get through the levels.
diff --git a/games/opensonic/doinst.sh b/games/opensonic/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/games/opensonic/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/games/opensonic/opensonic.SlackBuild b/games/opensonic/opensonic.SlackBuild
new file mode 100644
index 0000000000..ac60163b59
--- /dev/null
+++ b/games/opensonic/opensonic.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+
+# Slackware build script for opensonic
+
+# Copyright 2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=opensonic
+SRCNAM=opensnc
+VERSION=${VERSION:-0.1.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-src-$VERSION
+tar xvf $CWD/$SRCNAM-src-$VERSION.tar.gz
+cd $SRCNAM-src-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i 's|/usr/bin|/usr/games|' CMakeLists.txt src/core/global.h
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure
+
+make VERBOSE=1
+make install DESTDIR=$PKG
+
+mkdir -p $PKG/usr/games
+install -m 0755 $PRGNAM $PKG/usr/games
+rm -f $PKG/usr/share/$PRGNAM/$PRGNAM
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
+install -m 0644 icon.png $PKG/usr/share/pixmaps/$PRGNAM.png
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ license.txt readme*.html \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chomd 0644 '{}' \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/opensonic/opensonic.desktop b/games/opensonic/opensonic.desktop
new file mode 100644
index 0000000000..3469c9937b
--- /dev/null
+++ b/games/opensonic/opensonic.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=Opensonic
+GenericName=Opensonic
+Comment=Game based on the "Sonic the Hedgehog" universe.
+Exec=opensonic
+Categories=Game;ArcadeGame;
+Icon=opensonic
+Terminal=false
+StartupNotify=false
diff --git a/games/opensonic/opensonic.info b/games/opensonic/opensonic.info
new file mode 100644
index 0000000000..7d0c3d5e05
--- /dev/null
+++ b/games/opensonic/opensonic.info
@@ -0,0 +1,10 @@
+PRGNAM="opensonic"
+VERSION="0.1.4"
+HOMEPAGE="http://opensnc.sourceforge.net/home/index.php"
+DOWNLOAD="http://downloads.sourceforge.net/opensnc/opensnc-src-0.1.4.tar.gz"
+MD5SUM="069fa14f43251b218b4fd81378d1cd78"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="allegro"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/games/opensonic/slack-desc b/games/opensonic/slack-desc
new file mode 100644
index 0000000000..9dc9cc6152
--- /dev/null
+++ b/games/opensonic/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+opensonic: opensonic (open-source game based on Sonic the Hedgehog)
+opensonic:
+opensonic: Open Sonic is an open-source game based on the "Sonic the Hedgehog"
+opensonic: universe. It introduces a different style of gameplay called
+opensonic: cooperative play, in which it's possible to control 3 characters
+opensonic: simultaneously. Unlike most similar games, Open Sonic provides a
+opensonic: greater level of interaction between the player and the levels. It's
+opensonic: more than just a jump'n'run; the user must come up with some strategy
+opensonic: in order to get through the levels.
+opensonic:
+opensonic: Homepage: http://opensnc.sourceforge.net/home/index.php