summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Dugan Chen2013-01-03 16:55:03 +0100
committer dsomero2013-01-10 00:52:19 +0100
commit53f15c610eb5d2ad4e4164371c9e8a234fdafbef (patch)
tree92b989f4b3acfd645b149ffba5f8762658563307 /games
parent7b158aff13a52ad057a5eec70b721b5a544edc26 (diff)
downloadslackbuilds-53f15c610eb5d2ad4e4164371c9e8a234fdafbef.tar.gz
games/nestopia: Updated for version 1.4.3.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/nestopia/Makefile.patch54
-rw-r--r--games/nestopia/README11
-rw-r--r--games/nestopia/nestopia.SlackBuild19
-rw-r--r--games/nestopia/nestopia.info8
4 files changed, 70 insertions, 22 deletions
diff --git a/games/nestopia/Makefile.patch b/games/nestopia/Makefile.patch
new file mode 100644
index 0000000000..95626c3772
--- /dev/null
+++ b/games/nestopia/Makefile.patch
@@ -0,0 +1,54 @@
+--- Makefile.old 2013-01-02 12:58:22.586959169 -0800
++++ Makefile 2013-01-02 14:56:29.603157717 -0800
+@@ -26,7 +26,7 @@
+ LDFLAGS += -Wl,--as-needed
+
+ EXE = nestopia
+-LIBS = -lstdc++ -lm -lz -lasound $(shell sdl-config --libs) $(shell pkg-config --libs gtk+-3.0)
++LIBS = -lX11 -lstdc++ -lm -lz -lasound $(shell sdl-config --libs) $(shell pkg-config --libs gtk+-3.0)
+
+ PREFIX = /usr/local
+ BINDIR = $(PREFIX)/bin
+@@ -41,12 +41,12 @@
+ CXXFLAGS += -DDATADIR=\"$(DATADIR)\"
+
+ # Linux objs
+-OBJS = objs/linux/main.o objs/linux/oss.o objs/linux/interface.o objs/linux/settings.o
++OBJS = objs/linux/main.o objs/linux/oss.o objs/linux/interface.o objs/linux/settings.o
+ OBJS += objs/linux/auxio.o objs/linux/input.o objs/linux/kentry.o objs/linux/controlconfig.o objs/linux/cheats.o
+ OBJS += objs/linux/seffect.o objs/linux/uihelp.o
+
+ # 7-zip decoder (from LZMA SDK 4.58 beta)
+-OBJS += objs/linux/7zip/7zAlloc.o objs/linux/7zip/7zBuf.o objs/linux/7zip/7zCrc.o objs/linux/7zip/7zDecode.o objs/linux/7zip/7zExtract.o
++OBJS += objs/linux/7zip/7zAlloc.o objs/linux/7zip/7zBuf.o objs/linux/7zip/7zCrc.o objs/linux/7zip/7zDecode.o objs/linux/7zip/7zExtract.o
+ OBJS += objs/linux/7zip/7zHeader.o objs/linux/7zip/7zIn.o objs/linux/7zip/7zItem.o objs/linux/7zip/LzmaDec.o
+ OBJS += objs/linux/7zip/Alloc.o objs/linux/7zip/Bcj2.o objs/linux/7zip/Bra.o objs/linux/7zip/Bra86.o objs/linux/7zip/BraIA64.o
+
+@@ -157,7 +157,7 @@
+ OBJS += objs/core/vssystem/NstVsRbiBaseball.o objs/core/vssystem/NstVsSuperXevious.o objs/core/vssystem/NstVsSystem.o objs/core/vssystem/NstVsTkoBoxing.o
+
+ # object dirs
+-OBJDIRS = objs objs/core objs/core/api objs/core/board objs/core/input objs/core/vssystem objs/nes_ntsc
++OBJDIRS = objs objs/core objs/core/api objs/core/board objs/core/input objs/core/vssystem objs/nes_ntsc
+ OBJDIRS += objs/linux objs/linux/7zip objs/linux/unzip
+
+ # build rules
+@@ -184,13 +184,13 @@
+
+ install:
+ mkdir -p $(DATADIR)/icons
+- install -m 0755 $(EXE) $(BINDIR)
+- install -m 0644 source/linux/icons/nestopia.desktop $(DATADIR)
+- install -m 0644 NstDatabase.xml $(DATADIR)
++ install -Dm 0755 $(EXE) $(BINDIR)/$(EXE)
++ install -Dm 0644 source/linux/icons/nestopia.desktop $(DATADIR)/nestopia.desktop
++ install -Dm 0644 NstDatabase.xml $(DATADIR)/NstDatabase.xml
+ install -m 0644 source/linux/icons/*.png $(DATADIR)/icons
+ install -m 0644 source/linux/icons/*.svg $(DATADIR)/icons
+- install -m 0644 source/linux/icons/nestopia.svg /usr/share/pixmaps
+- xdg-desktop-menu install --novendor $(DATADIR)/nestopia.desktop
++ install -Dm 0644 source/linux/icons/nestopia.svg $(PREFIX)/share/pixmaps/nestopia.svg
++ install -Dm 0644 $(DATADIR)/nestopia.desktop $(PREFIX)/share/applications/nestopia.desktop
+
+ uninstall:
+ xdg-desktop-menu uninstall $(DATADIR)/nestopia.desktop
diff --git a/games/nestopia/README b/games/nestopia/README
index e0dbf55ba0..f82e5e9794 100644
--- a/games/nestopia/README
+++ b/games/nestopia/README
@@ -4,12 +4,7 @@ level. It was also one of the inspirations for bsnes.
A 1Ghz CPU and 128MB RAM are required to get the best performance.
-Before starting it up, copy the following files from /usr/share/nestopiah/ to
-~/.nestopia/:
-
- * NstDatabase.xml
- * The default input file (nstcontrols)
- * The Disk System BIOS (disksys.rom)
-
A Disk System BIOS (disksys.rom) is optional and, of course, not included. If
-you have one, put it in ~/.nestopia/ too.
+you have one, put it in ~/.nestopia
+
+Note: parallel building is supported with a max of 2 jobs.
diff --git a/games/nestopia/nestopia.SlackBuild b/games/nestopia/nestopia.SlackBuild
index c993882c79..d10c25ab45 100644
--- a/games/nestopia/nestopia.SlackBuild
+++ b/games/nestopia/nestopia.SlackBuild
@@ -5,7 +5,7 @@
# Written by Dugan Chen (thedoogster@gmail.com)
PRGNAM=nestopia
-VERSION=${VERSION:-20120918_334cc05}
+VERSION=${VERSION:-1.43}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -36,14 +36,14 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+tar xvf $CWD/$PRGNAM-$VERSION.t?z*
cd $PRGNAM-$VERSION
chown -R root:root .
@@ -53,20 +53,19 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-sed -i -e "s|/local||" -e "s|-O3 -g3|${SLKCFLAGS}|" Makefile
-
-make -j1
-
-install -m0755 -D $PRGNAM $PKG/usr/bin/$PRGNAM
-install -m0644 -D NstDatabase.xml $PKG/usr/share/$PRGNAM/NstDatabase.xml
+patch < $CWD/Makefile.patch
+sed -i "s/-O3 -g3/-g3 ${SLKCFLAGS}/g" Makefile
+make PREFIX=/usr
+make install PREFIX=$PKG/usr
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- COPYING README changelog.* readme.html doc/* \
+ COPYING README README.linux readme.html \
$PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar doc/ $PKG/usr/doc/$PRGNAM-$VERSION/api/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/games/nestopia/nestopia.info b/games/nestopia/nestopia.info
index 7fb9c4d6b2..9d13523283 100644
--- a/games/nestopia/nestopia.info
+++ b/games/nestopia/nestopia.info
@@ -1,10 +1,10 @@
PRGNAM="nestopia"
-VERSION="20120918_334cc05"
+VERSION="1.4.3"
HOMEPAGE="http://0ldsk00l.ca/nestopia.html"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/nestopia-20120918_334cc05.tar.xz"
-MD5SUM="dadba73e2cc3d52bd7da53d62ee9f026"
+DOWNLOAD="https://github.com/downloads/rdanbrook/nestopia/nestopia-1.43.tgz"
+MD5SUM="959ca606bc2f43b3a56eadce5492902f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Dugan Chen"
-EMAIL="thedoogster@gmail.com"
+EMAIL="thedoogster [t] gmail [dot] com"