summaryrefslogtreecommitdiffstats
path: root/games/vbam/vbam.SlackBuild
diff options
context:
space:
mode:
author B. Watson2017-12-20 00:08:09 +0100
committer Willy Sudiarto Raharjo2017-12-21 02:19:33 +0100
commit5c03647093c54c114513d778e1d00ae78edc870a (patch)
tree23391aee1b342f07c4b2206964f3a08877eed6f7 /games/vbam/vbam.SlackBuild
parentac37e357b1cdec2b699cdff8c9f3a001f383d7b7 (diff)
downloadslackbuilds-5c03647093c54c114513d778e1d00ae78edc870a.tar.gz
games/vbam: Updated for version 2.0.1.
Signed-off-by: B. Watson <yalhcru@gmail.com>.
Diffstat (limited to 'games/vbam/vbam.SlackBuild')
-rw-r--r--games/vbam/vbam.SlackBuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/games/vbam/vbam.SlackBuild b/games/vbam/vbam.SlackBuild
index 44c0fa3d50..d7249c4475 100644
--- a/games/vbam/vbam.SlackBuild
+++ b/games/vbam/vbam.SlackBuild
@@ -23,6 +23,8 @@
# Modified by the SlackBuilds.org project.
+# 20171219 bkw: updated for 2.0.1.
+
# 20170302 bkw: use long-format github URL
# 20170126 bkw:
@@ -41,11 +43,11 @@
# - Correct README, plus cosmetic reformatting.
PRGNAM=vbam
-VERSION=${VERSION:-2.0.0beta3}
+VERSION=${VERSION:-2.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-SRCVER="Beta-3"
+SRCVER="$VERSION"
SRCNAM="visualboyadvance-m"
# Set to ON to enable FFMPEG A/V recording.
@@ -102,11 +104,11 @@ find -L . \
# confusion, force the correct version.
WXCONF=${WXCONF:-/usr/lib$LIBDIRSUFFIX/wx/config/gtk2-unicode-3.0}
-# install binary to /usr/games, since it's got a section 6 man page.
-sed -i '/DESTINATION bin/s,bin,games,' CMakeLists.txt
-
-# man pages go in Slack standard location.
-sed -i 's,share/man,man,g' CMakeLists.txt
+# Upstream says: "Note to distro packagers: If you build from a tarball
+# rather than from git, please include 30b6ecf and 4648638 as patches. These
+# didn't make it into the tag."
+patch -p1 < $CWD/30b6ecf.diff
+patch -p1 < $CWD/4648638.diff
mkdir -p build
cd build
@@ -120,6 +122,10 @@ cd build
-DENABLE_FFMPEG=${FFMPEG} \
-DCMAKE_BUILD_TYPE=Release ..
make
+ sed -i \
+ -e 's,/usr/share/man,/usr/man,g' \
+ -e 's,/usr/bin,/usr/games,g' \
+ cmake_install.cmake
make install DESTDIR=$PKG
cd ..