summaryrefslogtreecommitdiffstats
path: root/games/unvanquished/cmakelists.patch
diff options
context:
space:
mode:
author Dimitris Zlatanidis2016-06-09 00:46:55 +0200
committer Willy Sudiarto Raharjo2016-06-09 02:44:03 +0200
commitcc53209e5c2b48c25735c74d2ff492938e90d738 (patch)
tree36d65c61515cb7633beed74ad264e13ff98a86ed /games/unvanquished/cmakelists.patch
parentd25207a8b488d0b7a604ab2b395b91c508089c8c (diff)
downloadslackbuilds-cc53209e5c2b48c25735c74d2ff492938e90d738.tar.gz
games/unvanquished: Updated for version 0.50.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'games/unvanquished/cmakelists.patch')
-rw-r--r--games/unvanquished/cmakelists.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/games/unvanquished/cmakelists.patch b/games/unvanquished/cmakelists.patch
new file mode 100644
index 0000000000..325e6664fc
--- /dev/null
+++ b/games/unvanquished/cmakelists.patch
@@ -0,0 +1,59 @@
+--- Unvanquished-0.50.0/daemon/CMakeLists.txt.orig 2016-06-08 14:53:22.525135294 +0300
++++ Unvanquished-0.50.0/daemon/CMakeLists.txt 2016-06-08 17:10:11.316629219 +0300
+@@ -343,32 +343,32 @@
+ if (NOT EXISTS ${DEPS_DIR})
+ get_filename_component(BASENAME ${DEPS_DIR} NAME)
+ set(REMOTE "http://dl.unvanquished.net/deps/${BASENAME}${DEPS_EXT}")
+- message(STATUS "Downloading dependencies from '${REMOTE}'")
+- file(DOWNLOAD ${REMOTE} ${OBJ_DIR}/${BASENAME}${DEPS_EXT}
+- SHOW_PROGRESS
+- STATUS DOWNLOAD_RESULT
+- LOG DOWNLOAD_LOG
+- )
+- list(GET DOWNLOAD_RESULT 0 DOWNLOAD_STATUS)
+- list(GET DOWNLOAD_RESULT 1 DOWNLOAD_STRING)
+- if (NOT DOWNLOAD_STATUS EQUAL 0)
+- message(FATAL_ERROR "Error downloading '${REMOTE}':
+- Status code: ${DOWNLOAD_STATUS}
+- Error string: ${DOWNLOAD_STRING}
+- Download log: ${DOWNLOAD_LOG}"
+- )
+- endif()
+- message(STATUS "Download completed successfully")
++ #message(STATUS "Downloading dependencies from '${REMOTE}'")
++ #file(DOWNLOAD ${REMOTE} ${OBJ_DIR}/${BASENAME}${DEPS_EXT}
++ # SHOW_PROGRESS
++ # STATUS DOWNLOAD_RESULT
++ # LOG DOWNLOAD_LOG
++ #)
++ #list(GET DOWNLOAD_RESULT 0 DOWNLOAD_STATUS)
++ #list(GET DOWNLOAD_RESULT 1 DOWNLOAD_STRING)
++ #if (NOT DOWNLOAD_STATUS EQUAL 0)
++ # message(FATAL_ERROR "Error downloading '${REMOTE}':
++ # Status code: ${DOWNLOAD_STATUS}
++ # Error string: ${DOWNLOAD_STRING}
++ # Download log: ${DOWNLOAD_LOG}"
++ # )
++ #endif()
++ #message(STATUS "Download completed successfully")
+
+ # Extract the downloaded archive
+- execute_process(
+- COMMAND ${CMAKE_COMMAND} -E tar xzf ${OBJ_DIR}/${BASENAME}${DEPS_EXT}
+- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/external_deps
+- RESULT_VARIABLE EXTRACT_RESULT
+- )
+- if (NOT EXTRACT_RESULT EQUAL 0)
+- message(FATAL_ERROR "Could not extract ${BASENAME}${DEPS_EXT}")
+- endif()
++ #execute_process(
++ # COMMAND ${CMAKE_COMMAND} -E tar xzf ${OBJ_DIR}/${BASENAME}${DEPS_EXT}
++ # WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/external_deps
++ # RESULT_VARIABLE EXTRACT_RESULT
++ #)
++ #if (NOT EXTRACT_RESULT EQUAL 0)
++ # message(FATAL_ERROR "Could not extract ${BASENAME}${DEPS_EXT}")
++ #endif()
+ endif()
+
+ # Add to paths