summaryrefslogtreecommitdiffstats
path: root/games/quarry
diff options
context:
space:
mode:
author Roman Kodinets2020-05-12 18:05:59 +0200
committer Willy Sudiarto Raharjo2020-05-16 03:44:10 +0200
commitda6c1bf7604c83ce8c2cff037fbc4aef3b2342c7 (patch)
treebc8933bdc566eda1b94295f8ec8a548bfc013b8f /games/quarry
parent66ea329e5f9222a31a85f4f22509f6ec9ef9c46a (diff)
downloadslackbuilds-da6c1bf7604c83ce8c2cff037fbc4aef3b2342c7.tar.gz
games/quarry: Added (a universal board game interface program)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/quarry')
-rw-r--r--games/quarry/README7
-rw-r--r--games/quarry/doinst.sh6
-rw-r--r--games/quarry/quarry.SlackBuild106
-rw-r--r--games/quarry/quarry.info10
-rw-r--r--games/quarry/slack-desc19
5 files changed, 148 insertions, 0 deletions
diff --git a/games/quarry/README b/games/quarry/README
new file mode 100644
index 0000000000..a0b2fad9dc
--- /dev/null
+++ b/games/quarry/README
@@ -0,0 +1,7 @@
+Quarry is a universal board game interface program. At present it
+supports three games: Go, Amazons and Reversi. It is intended to be
+useful for both users and developers of game engines (i.e. programs
+that play board games).
+
+Quarry uses are currently limited to playing against a computer
+program (e.g. GNU Go) and browsing and editing SGF game records.
diff --git a/games/quarry/doinst.sh b/games/quarry/doinst.sh
new file mode 100644
index 0000000000..8211abc687
--- /dev/null
+++ b/games/quarry/doinst.sh
@@ -0,0 +1,6 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q /usr/share/applications >/dev/null 2>&1
+fi
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database /usr/share/mime >/dev/null 2>&1
+fi
diff --git a/games/quarry/quarry.SlackBuild b/games/quarry/quarry.SlackBuild
new file mode 100644
index 0000000000..484221ba98
--- /dev/null
+++ b/games/quarry/quarry.SlackBuild
@@ -0,0 +1,106 @@
+#!/bin/sh
+
+# Slackware build script for Quarry.
+
+# Copyright 2020 Roman Kodinets <rkodinets@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=quarry
+VERSION=${VERSION:-0.3.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix linking errors
+find './src/' -type f -name '*.h' -exec sed -i 's/^inline //g' {} \;
+# Do not try to build German help files (fixes install error)
+sed -i 's/^\(SUBDIRS = C\) de/\1/' './help/Makefile.in'
+# Do not try to update mime/desktop database from Makefile (do it from doinst.sh instead)
+sed -i '/\$(MAKE).*hook/d' './data/Makefile.in'
+# Fix desktop file contents
+sed -i 's/^\(Icon=.*\)\.png$/\1/;\/^Version/d;s/^\(Categories=\)Application;/\1/' './data/quarry.desktop.in'
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING* ChangeLog INSTALL NEWS README* THANKS TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/quarry/quarry.info b/games/quarry/quarry.info
new file mode 100644
index 0000000000..72aa79ec67
--- /dev/null
+++ b/games/quarry/quarry.info
@@ -0,0 +1,10 @@
+PRGNAM="quarry"
+VERSION="0.3.0.1"
+HOMEPAGE="http://home.gna.org/quarry/"
+DOWNLOAD="https://github.com/ejona86/quarry/archive/0.3.0.1/quarry-0.3.0.1.tar.gz"
+MD5SUM="3c05c4b51d77114d0be2400647340737"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Roman Kodinets"
+EMAIL="rkodinets@gmail.com"
diff --git a/games/quarry/slack-desc b/games/quarry/slack-desc
new file mode 100644
index 0000000000..1fd51f406e
--- /dev/null
+++ b/games/quarry/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+quarry: Quarry (a universal board game interface program)
+quarry:
+quarry: Quarry is a universal board game interface program. At present it
+quarry: supports three games: Go, Amazons and Reversi. It is intended to be
+quarry: useful for both users and developers of game engines (i.e. programs
+quarry: that play board games).
+quarry:
+quarry: Quarry uses are currently limited to playing against a computer
+quarry: program (e.g. GNU Go) and browsing and editing SGF game records.
+quarry:
+quarry: