summaryrefslogtreecommitdiffstats
path: root/games/dolphin-emu
diff options
context:
space:
mode:
author Larry Hajali2017-04-12 07:33:02 +0200
committer Willy Sudiarto Raharjo2017-04-13 02:28:02 +0200
commitc56fe065e9096456b731ab9ea39bbb16a79b689c (patch)
tree0cf371a045a205e936a718e22adbd76786367d35 /games/dolphin-emu
parentd5e4d27dc51acbccafccfd789f12d1031006b8fd (diff)
downloadslackbuilds-c56fe065e9096456b731ab9ea39bbb16a79b689c.tar.gz
games/dolphin-emu: fix dependencies
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'games/dolphin-emu')
-rw-r--r--games/dolphin-emu/README8
-rw-r--r--games/dolphin-emu/dolphin-emu.SlackBuild28
-rw-r--r--games/dolphin-emu/dolphin-emu.info4
3 files changed, 20 insertions, 20 deletions
diff --git a/games/dolphin-emu/README b/games/dolphin-emu/README
index bac270aa0f..d8612742c3 100644
--- a/games/dolphin-emu/README
+++ b/games/dolphin-emu/README
@@ -7,9 +7,11 @@ currently limited to a couple of games - others require more of the
Triforce-specific peripheral devices to be emulated.
Optional dependencies: SFML, OpenAL, portaudio, soil, miniupnpc,
-soundtouch, ffmpeg and wxGTK3
+soundtouch, ffmpeg, wxGTK3, gtest, embedtls and SDL2
-Optional dependencies (not used): wayland and polarssl (version < 1.3)
+Optional dependencies (not used): wayland
+
+Optional dependencies (not on SBo): xxhash
Note: Wayland support is not enabled even if it is installed. Dolphin
requires mesa to be rebuilt with Wayland support using the following
@@ -19,5 +21,3 @@ configure parameters.
In addition to adding Wayland support to mesa, libxkbcommon needs to
be installed (version >= 0.4.0) that also requires xcb >= 1.10.
-
-Note: polarssl is not use as the version at SBo is too new.
diff --git a/games/dolphin-emu/dolphin-emu.SlackBuild b/games/dolphin-emu/dolphin-emu.SlackBuild
index 27e7a42ad2..a254bf93aa 100644
--- a/games/dolphin-emu/dolphin-emu.SlackBuild
+++ b/games/dolphin-emu/dolphin-emu.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for dolphin-emu
-# Copyright 2013-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2013-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,12 +24,12 @@
PRGNAM=dolphin-emu
VERSION=${VERSION:-5.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -60,7 +60,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf ${PRGNAM/-*/}-$VERSION
-tar xvf $CWD/${PRGNAM/-*/}-$VERSION.tar.?z || tar xvf $CWD/$VERSION.tar.gz
+tar xvf $CWD/${PRGNAM/-*/}-$VERSION.tar.?z
cd ${PRGNAM/-*/}-$VERSION
chown -R root:root .
find -L . \
@@ -69,17 +69,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i "s|share/man|man|" CMakeLists.txt
-
mkdir build
cd build
cmake -G "Unix Makefiles" \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-Dbindir=/usr/games \
+ -Dmandir=/usr/man \
-DLIB_INSTALL_DIR=lib${LIBDIRSUFFIX} \
+ -DENABLE_LTO:BOOL=ON \
+ -DUSE_SHARED_GTEST:BOOL=ON \
+ -DUSE_SHARED_ENET:BOOL=ON \
+ -DENABLE_SDL:BOOL=ON \
-DINSTALL_LIB_DIR=/usr/lib${LIBDIRSUFFIX} \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DDISTRIBUTOR="Slackware" \
-DCMAKE_BUILD_TYPE=Release ..
make VERBOSE=1
@@ -92,18 +96,14 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-for i in 16 32 48 64 128; do
+for i in 16 32 64 128; do
convert Installer/Dolphin.ico -resize ${i}x${i}! $PRGNAM-${i}.png
install -D -m 0644 $PRGNAM-${i}-3.png \
$PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM.png
done
-# Remove unnecessary files/directories.
-rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/libpolarssl.a
-find $PKG -type d -empty -delete
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a license.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a license.txt *.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/games/dolphin-emu/dolphin-emu.info b/games/dolphin-emu/dolphin-emu.info
index 32b34ab3ef..2cb79b3b33 100644
--- a/games/dolphin-emu/dolphin-emu.info
+++ b/games/dolphin-emu/dolphin-emu.info
@@ -3,8 +3,8 @@ VERSION="5.0"
HOMEPAGE="http://dolphin-emu.org/"
DOWNLOAD="UNSUPPORTED"
MD5SUM=""
-DOWNLOAD_x86_64="https://github.com/dolphin-emu/dolphin/archive/5.0.tar.gz"
+DOWNLOAD_x86_64="https://github.com/dolphin-emu/dolphin/archive/5.0/dolphin-5.0.tar.gz"
MD5SUM_x86_64="ed94272956adbec690808f6e4d8ff065"
-REQUIRES="nvidia-cg-toolkit"
+REQUIRES=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"