summaryrefslogtreecommitdiffstats
path: root/games/dolphin-emu/dolphin-emu.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2014-05-18 18:36:40 +0200
committer Willy Sudiarto Raharjo2014-05-18 18:36:40 +0200
commit93ef5a231b5699f1866779050e28dd26c5ce570f (patch)
tree48797e49f86fbdcadef9e556101c42c21ba3e5d1 /games/dolphin-emu/dolphin-emu.SlackBuild
parent329f10a6ec1acc0e6fb96c0a16b55b75f800e14e (diff)
downloadslackbuilds-93ef5a231b5699f1866779050e28dd26c5ce570f.tar.gz
games/dolphin-emu: Updated for version 4.0.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/dolphin-emu/dolphin-emu.SlackBuild')
-rw-r--r--games/dolphin-emu/dolphin-emu.SlackBuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/games/dolphin-emu/dolphin-emu.SlackBuild b/games/dolphin-emu/dolphin-emu.SlackBuild
index 8adfd02898..ec37ed1a0d 100644
--- a/games/dolphin-emu/dolphin-emu.SlackBuild
+++ b/games/dolphin-emu/dolphin-emu.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=dolphin-emu
-VERSION=${VERSION:-4.0}
+VERSION=${VERSION:-4.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,9 +59,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
-unzip $CWD/${PRGNAM/-*/}-$VERSION-src.zip
-cd $PRGNAM
+rm -rf ${PRGNAM/-*/}-$VERSION
+tar xvf $CWD/${PRGNAM/-*/}-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+cd ${PRGNAM/-*/}-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -69,10 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Force dolphin-emu to use internal polarssl. Dolphin-emu fails to build
-# when polarssl >= 1.3.x is installed.
-sed -i 's|include(FindPolarSSL)|#&|' CMakeLists.txt
-
mkdir build
cd build
cmake -G "Unix Makefiles" \
@@ -98,7 +94,8 @@ for i in 16 32 48 64 128; do
done
# Remove unnecessary files/directories.
-rm -rf $PKG/usr/share/pixmaps $PKG/usr/lib${LIBDIRSUFFIX}/libpolarssl.a
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/libpolarssl.a
+find $PKG -type d -empty -delete
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a license.txt Readme.txt $PKG/usr/doc/$PRGNAM-$VERSION