summaryrefslogtreecommitdiffstats
path: root/games/dolphin-emu/dolphin-emu.SlackBuild
diff options
context:
space:
mode:
author Matteo Bernardini2016-06-27 23:27:39 +0200
committer Robby Workman2016-06-28 03:38:29 +0200
commit7b751948abda3ba4c03d148719e88b5b4af66a50 (patch)
treea68eb5427757576318f7d46c595951e51914c563 /games/dolphin-emu/dolphin-emu.SlackBuild
parentdff1fb294577300dbcffb20a18d22f98a6ba219e (diff)
downloadslackbuilds-7b751948abda3ba4c03d148719e88b5b4af66a50.tar.gz
games/dolphin-emu: Updated for version 5.0.
...to use a release and not a snapshot. Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games/dolphin-emu/dolphin-emu.SlackBuild')
-rw-r--r--games/dolphin-emu/dolphin-emu.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/games/dolphin-emu/dolphin-emu.SlackBuild b/games/dolphin-emu/dolphin-emu.SlackBuild
index b67c59a03f..27e7a42ad2 100644
--- a/games/dolphin-emu/dolphin-emu.SlackBuild
+++ b/games/dolphin-emu/dolphin-emu.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=dolphin-emu
-VERSION=${VERSION:-20160206_76d614e}
+VERSION=${VERSION:-5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,6 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s|share/man|man|" CMakeLists.txt
+
mkdir build
cd build
cmake -G "Unix Makefiles" \
@@ -87,6 +89,9 @@ cd -
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
for i in 16 32 48 64 128; do
convert Installer/Dolphin.ico -resize ${i}x${i}! $PRGNAM-${i}.png
install -D -m 0644 $PRGNAM-${i}-3.png \