summaryrefslogtreecommitdiffstats
path: root/games/dfarc
diff options
context:
space:
mode:
author B. Watson2022-02-23 03:24:06 +0100
committer Willy Sudiarto Raharjo2022-02-23 14:10:26 +0100
commit5c93709c4ac0404dfd53aa2507aff3fb942be755 (patch)
tree73cb8e34f7a4a29813e3e155fd9c5c49124d38b4 /games/dfarc
parent8555bf62fd742f834d8460ea4a84dffe1c9286d4 (diff)
downloadslackbuilds-5c93709c4ac0404dfd53aa2507aff3fb942be755.tar.gz
games/dfarc: Fix wxPython/wxGTK3 conflict.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/dfarc')
-rw-r--r--games/dfarc/dfarc.SlackBuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/games/dfarc/dfarc.SlackBuild b/games/dfarc/dfarc.SlackBuild
index c7efc1dcf9..714b7a9b42 100644
--- a/games/dfarc/dfarc.SlackBuild
+++ b/games/dfarc/dfarc.SlackBuild
@@ -22,11 +22,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220222 bkw: Modified by SlackBuilds.org:
+# - always use wxGTK3, regardless of wx-config symlink.
+# - fix .desktop.
+# - binary in /usr/games.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dfarc
VERSION=${VERSION:-3.14}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -84,13 +86,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# ignore woeres.rc; do not install menu items
sed -i '/AC_CHECK_TOOL(WINDRES, windres)/d;/^[[:blank:]]*ac_desktopfiles=yes/s/.*/ac_desktopfiles=no/' configure.ac
+sed -i -e '/^Exec/s,=,=/usr/games/,' \
+ -e '/^Icon/s,=.*,=/usr/share/pixmaps/dfarc.png,' \
+ share/*.desktop.in
+
autoreconf --install --symlink --warnings=all && intltoolize --force
CFLAGS="$SLKCFLAGS" \
@@ -103,19 +109,17 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-static=no \
+ --bindir=/usr/games \
+ --with-wx-config=/usr/lib$LIBDIRSUFFIX/wx/config/gtk3-unicode-3.0 \
--build=$ARCH-slackware-linux
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+make V=1
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+make install-strip DESTDIR=$PKG
+gzip -9 $PKG/usr/man/man*/*.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp ABOUT-NLS AUTHORS BUILD COPYING COPYING.DFArc COPYING.DFArc-2.0 ChangeLog NEWS README* \
+cp AUTHORS COPYING COPYING.DFArc COPYING.DFArc-2.0 ChangeLog NEWS README* \
TRANSLATIONS.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild