summaryrefslogtreecommitdiffstats
path: root/games/brainparty/patches/gcc-6.patch
diff options
context:
space:
mode:
author Matteo Bernardini2018-10-27 10:23:34 +0200
committer Matteo Bernardini2018-10-27 10:23:34 +0200
commit0b34ee30d4ec43cc46afb19bf05377d042e60e3a (patch)
tree70091680471ce3c12de6a06265b99f7c23d8bd56 /games/brainparty/patches/gcc-6.patch
parenta402c4e59f0b3c337c89964dc95412f3fddf455d (diff)
downloadslackbuilds-1f7f9caad14f24b6b8780c90f2dc30d8aa96e14b.tar.gz
20181027.1 global branch merge.current-20181027.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games/brainparty/patches/gcc-6.patch')
-rw-r--r--games/brainparty/patches/gcc-6.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/games/brainparty/patches/gcc-6.patch b/games/brainparty/patches/gcc-6.patch
new file mode 100644
index 0000000000..67dfadd540
--- /dev/null
+++ b/games/brainparty/patches/gcc-6.patch
@@ -0,0 +1,47 @@
+Description: Fix FTBFS on GCC 6 by removing use of hash_set class
+Author: James Cowgill <jcowgill@debian.org>
+Bug-Debian: https://bugs.debian.org/811885
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/WordList.h
++++ b/WordList.h
+@@ -18,24 +18,11 @@
+ #ifndef __WORDLIST_H__
+ #define __WORDLIST_H__
+
++#include <string>
+ #include <vector>
+-#include <ext/hash_set>
++#include <unordered_set>
+
+-using namespace std;
+-using namespace __gnu_cxx;
+-
+-namespace __gnu_cxx
+-{
+- template<> struct hash< std::string >
+- {
+- size_t operator()( const std::string& x ) const
+- {
+- return hash< const char* >()( x.c_str() );
+- }
+- };
+-}
+-
+-typedef hash_set<string, hash<string> > string_hash_set;
++typedef std::unordered_set<std::string> string_hash_set;
+
+ class WordList {
+ private:
+--- a/Makefile
++++ b/Makefile
+@@ -17,6 +17,9 @@ else
+ OSXCOMPAT =
+ endif
+
++# enable c++11
++CXXFLAGS += -std=c++11
++
+ # object files have corresponding source files
+ CXX = g++
+