summaryrefslogtreecommitdiffstats
path: root/games/assaultcube/assaultcube.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2010-08-26 02:35:14 +0200
committer Erik Hanson2010-08-29 22:32:12 +0200
commit5875a1eacd7c5d2fa6c835a554bf6a52195cde72 (patch)
treeca39aad581ec08a834c7a4b9ebd3b97db5dff624 /games/assaultcube/assaultcube.SlackBuild
parent79131597cb797f0f254bfe7cf0ad4544b8a9d91b (diff)
downloadslackbuilds-5875a1eacd7c5d2fa6c835a554bf6a52195cde72.tar.gz
games/assaultcube: Updated for version 1.1.0.1.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'games/assaultcube/assaultcube.SlackBuild')
-rw-r--r--games/assaultcube/assaultcube.SlackBuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/games/assaultcube/assaultcube.SlackBuild b/games/assaultcube/assaultcube.SlackBuild
index 9444fd2ff4..919cc83679 100644
--- a/games/assaultcube/assaultcube.SlackBuild
+++ b/games/assaultcube/assaultcube.SlackBuild
@@ -6,8 +6,8 @@
SRCNAM=AssaultCube
PRGNAM=assaultcube
-VERSION=1.0.4
-BUILD=${BUILD:-2}
+VERSION=1.1.0.1
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -38,9 +38,10 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf ${SRCNAM}_v${VERSION}
+rm -rf $VERSION
tar xvf $CWD/${SRCNAM}_v${VERSION}.tar.bz2
-cd ${SRCNAM}_v${VERSION}
+tar xvf $CWD/${SRCNAM}_v${VERSION}.source.tar.bz2
+cd $VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -48,25 +49,22 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# We need to change the order of the enet libs and includes. Enet libs and include
-# directories need to be declared first as compile will fail if enet is already
-# installed on the system and the Makefile uses system files instead. Also, use
-# custom SLKCFLAGS and remove precompiled binaries.
+# Use custom SLKCFLAGS and remove precompiled binaries.
patch -p1 < $CWD/Makefile.patch
sed -i "s|-O2|$SLKCFLAGS|" source/enet/configure
rm -f bin_unix/*
-CXXOPTFLAGS="$SLKCFLAGS -fomit-frame-pointer" \
+EXTRA_CXXFLAGS="$SLKCFLAGS" \
make -C source/src
-CXXOPTFLAGS="$SLKCFLAGS -fomit-frame-pointer" \
-make -C source/src install
+EXTRA_CXXFLAGS="$SLKCFLAGS" \
+make -C source/src client_install
mkdir -p $PKG/usr/games $PKG/usr/share/$PRGNAM
sed -i "/^CUBE_DIR/s|=.*|=\"/usr/share/${PRGNAM}\"|" $PRGNAM.sh
install -m 0755 $PRGNAM.sh $PKG/usr/games/$PRGNAM
chmod 0755 bin_unix/*
cp -ar \
- bin_unix config bot demos mods packages screenshots \
+ bin_unix config demos mods packages screenshots \
$PKG/usr/share/$PRGNAM
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
@@ -75,7 +73,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
mkdir -p $PKG/usr/share/applications
install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
for i in 16 32 64 96 128; do
- convert icon.ico -resize ${i}x${i}! $PRGNAM-$i.png
+ convert source/vcpp/buildEnv/icon.ico -resize ${i}x${i}! $PRGNAM-$i.png
install -D -m 0644 $PRGNAM-$i-0.png \
$PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM.png
done