summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Matteo Bernardini2022-02-16 19:19:47 +0100
committer Willy Sudiarto Raharjo2022-02-17 06:59:50 +0100
commit3000a9bfe8ba9e23daecc6d456569ba25ff2f281 (patch)
tree880b3e6ea8d7e6f69c3f185be2ab493e2849bacc /development
parent21d04fbf746ca0226d08863c8c8bdbbc0a122b8d (diff)
downloadslackbuilds-3000a9bfe8ba9e23daecc6d456569ba25ff2f281.tar.gz
development/jupyter-nbconvert: Removed (abandoned).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/jupyter-nbconvert/README10
-rw-r--r--development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild99
-rw-r--r--development/jupyter-nbconvert/jupyter-nbconvert.info10
-rw-r--r--development/jupyter-nbconvert/slack-desc19
4 files changed, 0 insertions, 138 deletions
diff --git a/development/jupyter-nbconvert/README b/development/jupyter-nbconvert/README
deleted file mode 100644
index 4170c385ad..0000000000
--- a/development/jupyter-nbconvert/README
+++ /dev/null
@@ -1,10 +0,0 @@
-The nbconvert tool, jupyter nbconvert, converts notebooks to various
-other formats via Jinja templates. The nbconvert tool allows you to
-convert an .ipynb notebook file into various static formats including:
- * HTML
- * LaTeX
- * PDF
- * Reveal JS
- * Markdown (md)
- * ReStructured Text (rst)
- * executable script
diff --git a/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild b/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild
deleted file mode 100644
index 3055d4c3fd..0000000000
--- a/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for jupyter-nbconvert
-
-# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=jupyter-nbconvert
-VERSION=${VERSION:-6.0.7}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=nbconvert
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CONTRIBUTING.md README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/jupyter-nbconvert/jupyter-nbconvert.info b/development/jupyter-nbconvert/jupyter-nbconvert.info
deleted file mode 100644
index 408207f91c..0000000000
--- a/development/jupyter-nbconvert/jupyter-nbconvert.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="jupyter-nbconvert"
-VERSION="6.0.7"
-HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/n/nbconvert/nbconvert-6.0.7.tar.gz"
-MD5SUM="70f69644c21093260ce79ff3ddb8a140"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="bleach decorator python3-defusedxml entrypoints jupyter_core jupyter-nbclient jupyterlab_pygments mistune pandocfilters testpath"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/development/jupyter-nbconvert/slack-desc b/development/jupyter-nbconvert/slack-desc
deleted file mode 100644
index e9f6b97680..0000000000
--- a/development/jupyter-nbconvert/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-jupyter-nbconvert: jupyter-nbconvert (Jupyter notebook conversion)
-jupyter-nbconvert:
-jupyter-nbconvert: jupyter-nbconvert tool converts notebooks to various other formats
-jupyter-nbconvert: via Jinja templates.
-jupyter-nbconvert:
-jupyter-nbconvert:
-jupyter-nbconvert:
-jupyter-nbconvert:
-jupyter-nbconvert:
-jupyter-nbconvert:
-jupyter-nbconvert: