summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Isaac Yu2022-06-17 01:17:38 +0200
committer Willy Sudiarto Raharjo2022-06-18 04:10:06 +0200
commit29a0e7500192019e2b1f5a6ebbd2b5d459f1e172 (patch)
tree3453871c0dc9a843ad161d85dc38fbd02d068bfa /development
parentb8b1d7b310b13f8e3196368434882231ccfd697f (diff)
downloadslackbuilds-29a0e7500192019e2b1f5a6ebbd2b5d459f1e172.tar.gz
development/jupyter_client: Updated for version 7.3.4.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/jupyter_client/jupyter_client.SlackBuild30
-rw-r--r--development/jupyter_client/jupyter_client.info6
2 files changed, 28 insertions, 8 deletions
diff --git a/development/jupyter_client/jupyter_client.SlackBuild b/development/jupyter_client/jupyter_client.SlackBuild
index 7743517445..d998ac775a 100644
--- a/development/jupyter_client/jupyter_client.SlackBuild
+++ b/development/jupyter_client/jupyter_client.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter_client
-VERSION=${VERSION:-7.3.1}
+VERSION=${VERSION:-7.3.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,15 +80,35 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Use this setup.py shim:
+cat << EOF > setup.py
+from setuptools import setup, find_packages
+setup(name='${PRGNAM}',
+ version='${VERSION}',
+ packages=find_packages(exclude=["docs", "docs.*", "tests", "tests.*"]),
+ package_data={'': ['*']},
+ entry_points={
+ 'console_scripts': [
+ 'jupyter-kernelspec = jupyter_client.kernelspecapp:KernelSpecApp.launch_instance',
+ 'jupyter-run = jupyter_client.runapp:RunApp.launch_instance',
+ 'jupyter-kernel = jupyter_client.kernelapp:main',
+ ],
+ 'jupyter_client.kernel_provisioners': [
+ 'local-provisioner = jupyter_client.provisioning:LocalProvisioner',
+ ],
+ },
+)
+EOF
+
+# With the shim, it's a good idea to use "unshare -n" to prevent downloading
+# anything extra:
+unshare -n python3 setup.py install --root=$PKG || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- *.md *.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/jupyter_client/jupyter_client.info b/development/jupyter_client/jupyter_client.info
index feeb82e1b3..fd777f7d58 100644
--- a/development/jupyter_client/jupyter_client.info
+++ b/development/jupyter_client/jupyter_client.info
@@ -1,8 +1,8 @@
PRGNAM="jupyter_client"
-VERSION="7.3.1"
+VERSION="7.3.4"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://github.com/jupyter/jupyter_client/archive/v7.3.1/jupyter_client-7.3.1.tar.gz"
-MD5SUM="f92ea77969392cf0ab8371fc08ad6157"
+DOWNLOAD="https://github.com/jupyter/jupyter_client/archive/v7.3.4/jupyter_client-7.3.4.tar.gz"
+MD5SUM="91419105c5d981dda6379fed7e0bc7f2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="entrypoints jupyter_core nest_asyncio python3-dateutil python3-pyzmq python3-tornado"