summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Chris Walker2018-09-23 00:51:29 +0200
committer Willy Sudiarto Raharjo2018-09-23 01:08:37 +0200
commit994191bcff5b6dd9c8b7aa2e2ee747f58b91a396 (patch)
tree81969fc117136abd85dbcc5e4bbe66f2d7e020f1 /development
parent5025fc3beb99288b24f7f3693b248544cdc66d32 (diff)
downloadslackbuilds-994191bcff5b6dd9c8b7aa2e2ee747f58b91a396.tar.gz
development/gnustep-make: Update script.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/gnustep-make/fhs-slackware91
-rw-r--r--development/gnustep-make/gnustep-make.SlackBuild12
2 files changed, 98 insertions, 5 deletions
diff --git a/development/gnustep-make/fhs-slackware b/development/gnustep-make/fhs-slackware
new file mode 100644
index 0000000000..632a8f6f30
--- /dev/null
+++ b/development/gnustep-make/fhs-slackware
@@ -0,0 +1,91 @@
+#
+# FHS (Filesystem Hierarchy Standard) filesystem layout for system installations
+#
+# This is the standard FHS Unix filesystem layout to use when
+# installing into /usr. Use this if you want GNUstep to blend into
+# your GNU/Linux filesystem (or any other Unix with a similar
+# filesystem) and you are compiling gnustep-make so that it can be
+# shipped as part of a distribution/basic system installation.
+#
+# We put SYSTEM into /usr, and LOCAL into /usr/local. This allows you
+# to make a distinction between stuff that you ship as part of your
+# system/distribution, and the local stuff installed by the local
+# sysadmin. Make sure you compile/install all packages that you want
+# to go into /usr (ie, be part of the system/distribution) using
+# 'make install GNUSTEP_INSTALLATION_DOMAIN=SYSTEM'
+#
+# To get system packages to work in this layout, you need /usr/bin in
+# your PATH, and /usr/lib in your /etc/ld.so.conf (or equivalent for
+# your Unix). Don't forget to run ldconfig after installing a
+# library!
+#
+# Your users will need to also add /usr/local/bin to PATH and
+# /usr/local/lib to /etc/ld.so.conf (or equivalent for your Unix) if
+# they want to use the LOCAL domain. To use gnustep-make in this
+# environment, use 'export
+# GNUSTEP_MAKEFILES=/usr/share/GNUstep/Makefiles'
+
+# By default, we install into /usr, but this can be overridden
+# by using ./configure --prefix=xxx when configuring.
+GNUSTEP_DEFAULT_PREFIX=/usr
+
+# These are only used by gnustep-base to implement the NSUserDirectory
+# API. We never install anything in them. They will be used as they
+# are without $prefix.
+GNUSTEP_SYSTEM_USERS_DIR=/home
+GNUSTEP_NETWORK_USERS_DIR=/home
+GNUSTEP_LOCAL_USERS_DIR=/home
+
+# NB: $prefix will be added to all the MAKEFILES/SYSTEM/NETWORK/LOCAL
+# paths.
+GNUSTEP_MAKEFILES=/share/GNUstep/Makefiles
+
+GNUSTEP_SYSTEM_APPS=/_lib_/GNUstep/Applications
+GNUSTEP_SYSTEM_ADMIN_APPS=/_lib_/GNUstep/Applications
+GNUSTEP_SYSTEM_WEB_APPS=/_lib_/GNUstep/WebApplications
+GNUSTEP_SYSTEM_TOOLS=/bin
+GNUSTEP_SYSTEM_ADMIN_TOOLS=/sbin
+GNUSTEP_SYSTEM_LIBRARY=/_lib_/GNUstep
+GNUSTEP_SYSTEM_HEADERS=/include
+GNUSTEP_SYSTEM_LIBRARIES=/_lib_
+GNUSTEP_SYSTEM_DOC=/share/GNUstep/Documentation
+GNUSTEP_SYSTEM_DOC_MAN=/share/man
+GNUSTEP_SYSTEM_DOC_INFO=/share/info
+
+GNUSTEP_NETWORK_APPS=/local/_lib_/GNUstep/Applications
+GNUSTEP_NETWORK_ADMIN_APPS=/local/_lib_/GNUstep/Applications
+GNUSTEP_NETWORK_WEB_APPS=/_lib_/GNUstep/WebApplications
+GNUSTEP_NETWORK_TOOLS=/local/bin
+GNUSTEP_NETWORK_ADMIN_TOOLS=/local/sbin
+GNUSTEP_NETWORK_LIBRARY=/local/_lib_/GNUstep
+GNUSTEP_NETWORK_HEADERS=/local/include
+GNUSTEP_NETWORK_LIBRARIES=/local/_lib_
+GNUSTEP_NETWORK_DOC=/local/share/GNUstep/Documentation
+GNUSTEP_NETWORK_DOC_MAN=/local/share/man
+GNUSTEP_NETWORK_DOC_INFO=/local/share/info
+
+GNUSTEP_LOCAL_APPS=/local/_lib_/GNUstep/Applications
+GNUSTEP_LOCAL_ADMIN_APPS=/local/_lib_/GNUstep/Applications
+GNUSTEP_LOCAL_WEB_APPS=/local/_lib_/GNUstep/WebApplications
+GNUSTEP_LOCAL_TOOLS=/local/bin
+GNUSTEP_LOCAL_ADMIN_TOOLS=/local/sbin
+GNUSTEP_LOCAL_LIBRARY=/local/_lib_/GNUstep
+GNUSTEP_LOCAL_HEADERS=/local/include
+GNUSTEP_LOCAL_LIBRARIES=/local/_lib_
+GNUSTEP_LOCAL_DOC=/local/share/GNUstep/Documentation
+GNUSTEP_LOCAL_DOC_MAN=/local/share/man
+GNUSTEP_LOCAL_DOC_INFO=/local/share/info
+
+GNUSTEP_USER_DIR_APPS=GNUstep/Applications
+GNUSTEP_USER_DIR_ADMIN_APPS=GNUstep/Applications/Admin
+GNUSTEP_USER_DIR_WEB_APPS=GNUstep/WebApplications
+GNUSTEP_USER_DIR_TOOLS=GNUstep/Tools
+GNUSTEP_USER_DIR_ADMIN_TOOLS=GNUstep/Tools/Admin
+GNUSTEP_USER_DIR_LIBRARY=GNUstep/Library
+GNUSTEP_USER_DIR_HEADERS=GNUstep/Library/Headers
+GNUSTEP_USER_DIR_LIBRARIES=GNUstep/Library/Libraries
+GNUSTEP_USER_DIR_DOC=GNUstep/Library/Documentation
+GNUSTEP_USER_DIR_DOC_MAN=GNUstep/Library/Documentation/man
+GNUSTEP_USER_DIR_DOC_INFO=GNUstep/Library/Documentation/info
+GNUSTEP_USER_CONFIG_FILE=.GNUstep.conf
+GNUSTEP_USER_DEFAULTS_DIR=GNUstep/Defaults
diff --git a/development/gnustep-make/gnustep-make.SlackBuild b/development/gnustep-make/gnustep-make.SlackBuild
index 63ceec3029..480187bc01 100644
--- a/development/gnustep-make/gnustep-make.SlackBuild
+++ b/development/gnustep-make/gnustep-make.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=gnustep-make
VERSION=${VERSION:-2.7.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,6 +69,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Put a Slackware specific FilesystemLayout in place
+sed -e "s/_lib_/lib${LIBDIRSUFFIX}/g" \
+ $CWD/fhs-slackware > FilesystemLayouts/slackware
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -76,19 +80,17 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--infodir=/usr/info \
--libdir=/usr/lib${LIBDIRSUFFIX} \
- --with-layout=fhs-system \
+ --with-layout=slackware \
--with-config-file=/etc/GNUstep/GNUstep.conf \
--with-library-combo=gnu-gnu-gnu \
--build=$ARCH-slackware-linux
-
make
make install DESTDIR=$PKG
mv $PKG/etc/GNUstep/GNUstep.conf $PKG/etc/GNUstep/GNUstep.conf.new
-sed -e "s,/usr/lib$,/usr/lib${LIBDIRSUFFIX},g" \
- -e "s,/usr/local/lib$,/usr/local/lib${LIBDIRSUFFIX},g" \
+sed -e "s,/lib/,/lib${LIBDIRSUFFIX}/,g" \
-e "s,/usr/local/share/info,/usr/local/info,g" \
-e "s,/usr/local/share/man,/usr/local/man,g" \
-e "s,/usr/share/info,/usr/info,g" \