summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Leo C2019-06-29 01:02:15 +0200
committer Willy Sudiarto Raharjo2019-06-29 01:18:06 +0200
commitbac887ac20252f5f0a7c9e20f8e38100752526a4 (patch)
tree0c55932d783ab83bdf14f7a3b83dadfe9f3bc2e4 /development
parenta95a4d4b02c54cb55469d7cb21de614c3730ff0a (diff)
downloadslackbuilds-bac887ac20252f5f0a7c9e20f8e38100752526a4.tar.gz
development/pyqt-distutils: Added (distutils extension).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/pyqt-distutils/README3
-rw-r--r--development/pyqt-distutils/pyqt-distutils.SlackBuild87
-rw-r--r--development/pyqt-distutils/pyqt-distutils.info10
-rw-r--r--development/pyqt-distutils/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/development/pyqt-distutils/README b/development/pyqt-distutils/README
new file mode 100644
index 0000000000..69eeceb658
--- /dev/null
+++ b/development/pyqt-distutils/README
@@ -0,0 +1,3 @@
+The goal of this tiny library is to help developers write PyQt
+applications in a pythonic way, using setup.py to build the Qt
+designer Ui files.
diff --git a/development/pyqt-distutils/pyqt-distutils.SlackBuild b/development/pyqt-distutils/pyqt-distutils.SlackBuild
new file mode 100644
index 0000000000..1220507721
--- /dev/null
+++ b/development/pyqt-distutils/pyqt-distutils.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for pyqt-distutils
+
+# Copyright 2019 Leonardo Citrolo, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyqt-distutils
+VERSION=${VERSION:-0.7.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/pyqt-distutils/pyqt-distutils.info b/development/pyqt-distutils/pyqt-distutils.info
new file mode 100644
index 0000000000..1216fdb0b5
--- /dev/null
+++ b/development/pyqt-distutils/pyqt-distutils.info
@@ -0,0 +1,10 @@
+PRGNAM="pyqt-distutils"
+VERSION="0.7.3"
+HOMEPAGE="https://github.com/ColinDuquesnoy/pyqt_distutils"
+DOWNLOAD="https://files.pythonhosted.org/packages/3a/28/0c38bea00c3288493bfa69d896ee478bcbbed24e02120ba670027eb5114d/pyqt-distutils-0.7.3.tar.gz"
+MD5SUM="598b52cdfa90cdc548b80ca84772640f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-docopt python3"
+MAINTAINER="Leo C."
+EMAIL="leoc@gmx.com"
diff --git a/development/pyqt-distutils/slack-desc b/development/pyqt-distutils/slack-desc
new file mode 100644
index 0000000000..62a4e54ccd
--- /dev/null
+++ b/development/pyqt-distutils/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyqt-distutils: pyqt-distutils (distutils extension to work with PyQt applications)
+pyqt-distutils:
+pyqt-distutils: The goal of this tiny library is to help developers write PyQt
+pyqt-distutils: applications in a pythonic way, using setup.py to build the Qt
+pyqt-distutils: designer Ui files.
+pyqt-distutils:
+pyqt-distutils:
+pyqt-distutils:
+pyqt-distutils:
+pyqt-distutils: Homepage: https://github.com/ColinDuquesnoy/pyqt_distutils
+pyqt-distutils: