summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author David Woodfall2018-05-21 13:33:14 +0200
committer Willy Sudiarto Raharjo2018-05-26 01:59:22 +0200
commit3060d96712bd49723b46c7064b3cfb50ea5bb9fe (patch)
tree05ca14447f9e3944eb8ea5026f48f48bbe903ef2 /development
parenta37a693952fd1efaf9278add1957ec957010f48b (diff)
downloadslackbuilds-3060d96712bd49723b46c7064b3cfb50ea5bb9fe.tar.gz
development/pudb: Updated for version 2017.1.4 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/pudb/README53
-rw-r--r--development/pudb/pudb.SlackBuild139
-rw-r--r--development/pudb/pudb.info14
-rw-r--r--development/pudb/slack-desc6
4 files changed, 174 insertions, 38 deletions
diff --git a/development/pudb/README b/development/pudb/README
index 9cafb649d7..253788f594 100644
--- a/development/pudb/README
+++ b/development/pudb/README
@@ -1,7 +1,52 @@
PuDB is a full-screen, console-based visual debugger for Python.
-Its goal is to provide all the niceties of modern GUI-based debuggers in a
-more lightweight and keyboard-friendly package. PuDB allows you to debug
-code right where you write and test it--in a terminal. If you've worked
-with the excellent (but nowadays ancient) DOS-based Turbo Pascal or C
+Its goal is to provide all the niceties of modern GUI-based debuggers in a
+more lightweight and keyboard-friendly package. PuDB allows you to debug
+code right where you write and test it--in a terminal. If you've worked
+with the excellent (but nowadays ancient) DOS-based Turbo Pascal or C
tools, PuDB's UI might look familiar.
+
+By default this SlackBuild builds the python2 debugger, and if python3 is
+detected, the python3 version too. The Pygments SlackBuild will automatically
+install for python3 too.
+
+NOTE: The python3 application is named pudb3.
+NOTE: You need python3-urwid installed to use pudb3.
+
+OPTIONS
+
+To *ONLY* build the python2 version, use:
+
+NO_PYTHON3=1 ./pudb.SlackBuild
+
+To *ONLY* build the python3 version, use:
+
+NO_PYTHON2=1 ./pudb.SlackBuild
+
+The python2 version requires a newer version of urwid than the stock Slackware
+one, therefore this also builds a custom urwid named py2_urwid, which it can
+use. This should not conflict with the stock Slackware version.
+
+OPTIONAL DEPENDENCIES
+
+python3-urwid for the python3 version. Note that it will still build without
+this, so it can be installed later if needed.
+
+###############################################################################
+
+GETTING STARTED
+
+Please see starting.rst usage.rst misc.rst and shells.rst in
+/usr/doc/pudb-$VERSION to get started, and also -
+
+Online docs:
+
+https://documen.tician.de/pudb/
+
+A simple, but useful, illustrated example page:
+
+http://heather.cs.ucdavis.edu/~matloff/pudb.html
+
+Github page:
+
+https://github.com/inducer/pudb
diff --git a/development/pudb/pudb.SlackBuild b/development/pudb/pudb.SlackBuild
index 74958b618a..cd38d8a15a 100644
--- a/development/pudb/pudb.SlackBuild
+++ b/development/pudb/pudb.SlackBuild
@@ -1,20 +1,39 @@
#!/bin/sh
#
# Slackware build script for pudb
+
+# Copyright 2018 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
#
-# Written by Rudson R. Alves rudsonalves@yahoo.com.br
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pudb
-VERSION=${VERSION:-2015.2}
+VERSION=${VERSION:-2017.1.4}
+URWIDVER=2.0.1
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
fi
CWD=$(pwd)
@@ -22,44 +41,114 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
+if [ -n "$NO_PYTHON2" ] && [ -n "$NO_PYTHON3" ]; then
+ printf "%s\n" "You appear to not want to install anything."
+ exit 1
+fi
+
+# see if we have python3 installed
+which python3 >/dev/null 2>&1 && PY3=1
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
+
+# install custom urwid package
+if [ -z "$NO_PYTHON2" ]; then
+ rm -rf urwid-$URWIDVER
+ tar xfv $CWD/urwid-$URWIDVER.tar.gz
+ cd urwid-$URWIDVER
+
+ chown -R root:root .
+ find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+ # change the module name so our urwid doesn't call the stock version
+ sed -i "s%'name':\"urwid\"%'name':\"py2_urwid\"%" setup.py
+ sed -i "23 a import py2_urwid\n\
+import sys\n\
+sys.modules['urwid'] = py2_urwid" urwid/__init__.py
+
+ python setup.py install --root=$PKG
+
+ # rename it so it doesn't collide with the stock version
+ mv $PKG/usr/lib$LIBDIRSUFFIX/python2.7/site-packages/urwid \
+ $PKG/usr/lib$LIBDIRSUFFIX/python2.7/site-packages/py2_urwid
+ cd ..
+fi
+
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# install the python3 version before we wreck the python2 build
+if [ -n "$PY3" ] && [ -z "$NO_PYTHON3" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
+# install the edited python2 version
+if [ -z "$NO_PYTHON2" ]; then
+ # change all references to urwid to our custom py2_urwid
+ for py in \
+ settings.py \
+ source_view.py \
+ debugger.py \
+ theme.py \
+ __init__.py \
+ ui_tools.py \
+ var_view.py
+ do
+ sed -i "s%import urwid%import py2_urwid as urwid%g" pudb/$py
+ done
-python setup.py install --root=$PKG
+ sed -i "s%urwid>=1.1.1%py2_urwid>=1.1.1%" setup.py
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ # done so now install
+ python setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null \
+ || true
+
+# added more docs, some examples and a test debug script
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/examples
+cp -a README.rst LICENSE \
+ doc/starting.rst doc/usage.rst doc/misc.rst doc/shells.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+
+cp -a example-* debug_me.py $PKG/usr/doc/$PRGNAM-$VERSION/examples
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a MANIFEST.in PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# this might come in handy later for someone
+cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.slackware
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/development/pudb/pudb.info b/development/pudb/pudb.info
index 38d8730a9f..58f593815a 100644
--- a/development/pudb/pudb.info
+++ b/development/pudb/pudb.info
@@ -1,10 +1,12 @@
PRGNAM="pudb"
-VERSION="2015.2"
+VERSION="2017.1.4"
HOMEPAGE="https://pypi.python.org/pypi/pudb"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pudb/pudb-2015.2.tar.gz"
-MD5SUM="0e155dc7c07d59090269df5a02a9eaac"
+DOWNLOAD="https://github.com/inducer/pudb/archive/v2017.1.4/pudb-2017.1.4.tar.gz \
+ https://pypi.org/packages/source/u/urwid/urwid-2.0.1.tar.gz"
+MD5SUM="7d42e623ffa7b27af30330ac9e118c15 \
+ c70a7016fa1ad2c2a979dbebd4de78c2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Rudson R. Alves"
-EMAIL="rudsonalves@yahoo.com.br"
+REQUIRES="Pygments"
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
diff --git a/development/pudb/slack-desc b/development/pudb/slack-desc
index 62e3fb05ce..1755e59e9e 100644
--- a/development/pudb/slack-desc
+++ b/development/pudb/slack-desc
@@ -6,9 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-pudb: pudb (A full-screen, console-based Python debugger)
-pudb:
-pudb: PuDB is a full-screen, console-based visual debugger for Python.
+pudb: pudb (A console-based Python debugger)
pudb:
pudb: Its goal is to provide all the niceties of modern GUI-based debuggers
pudb: in a more lightweight and keyboard-friendly package. PuDB allows you
@@ -17,3 +15,5 @@ pudb:
pudb: If you've worked with the excellent (but nowadays ancient) DOS-based
pudb: Turbo Pascal or C tools, PuDB's UI might look familiar.
pudb:
+pudb: https://pypi.python.org/pypi/pudb
+pudb: https://github.com/inducer/pudb