summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author João Felipe Santos2010-05-12 23:28:56 +0200
committer Michiel van Wessem2010-05-12 23:28:56 +0200
commitfba93817d0b363b7644c982b3ee5a8d7159a74b5 (patch)
treec840efab308816abb5a1adb4a9e3eb9e6facbeeb /development
parentaeedfe447a30ab61217ff3102a9cdc28e36bbeeb (diff)
downloadslackbuilds-fba93817d0b363b7644c982b3ee5a8d7159a74b5.tar.gz
development/tailor: Added to 12.2 repository
Diffstat (limited to 'development')
-rw-r--r--development/tailor/README8
-rw-r--r--development/tailor/slack-desc18
-rw-r--r--development/tailor/tailor.SlackBuild69
-rw-r--r--development/tailor/tailor.info8
4 files changed, 103 insertions, 0 deletions
diff --git a/development/tailor/README b/development/tailor/README
new file mode 100644
index 0000000000..c9a31b1071
--- /dev/null
+++ b/development/tailor/README
@@ -0,0 +1,8 @@
+Tailor (A VCS/DVCS repository conversion tool)
+
+Tailor is a tool to migrate changesets between Aegis, ArX, Bazaar, Bazaar-NG,
+CVS, Codeville, Darcs, Git, Mercurial, Monotone, Perforce, Subversion and Tla
+repositories.
+
+You will need to install the VCS/DVCS tools separately; Tailor will use them
+to convert your repositories.
diff --git a/development/tailor/slack-desc b/development/tailor/slack-desc
new file mode 100644
index 0000000000..71658507b0
--- /dev/null
+++ b/development/tailor/slack-desc
@@ -0,0 +1,18 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+tailor: Tailor (A VCS/DVCS repository conversion tool)
+tailor:
+tailor: Tailor is a tool to migrate changesets between Aegis, ArX, Bazaar,
+tailor: Bazaar-NG, CVS, Codeville, Darcs, Git, Mercurial, Monotone, Perforce,
+tailor: Subversion and Tla repositories.
+tailor:
+tailor:
+tailor: Homepage: http://progetti.arstecnica.it/tailor
+tailor:
+tailor:
diff --git a/development/tailor/tailor.SlackBuild b/development/tailor/tailor.SlackBuild
new file mode 100644
index 0000000000..cedf316ae7
--- /dev/null
+++ b/development/tailor/tailor.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for tailor
+
+# Written by João Felipe Santos (joao.eel@gmail.com)
+
+# Copyright (c) 2009 João Felipe Santos
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+PRGNAM=tailor
+VERSION=${VERSION:-0.9.35}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --root $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/tailor/tailor.info b/development/tailor/tailor.info
new file mode 100644
index 0000000000..28f88ec128
--- /dev/null
+++ b/development/tailor/tailor.info
@@ -0,0 +1,8 @@
+PRGNAM="tailor"
+VERSION="0.9.35"
+HOMEPAGE="http://progetti.arstecnica.it/tailor/"
+DOWNLOAD="http://darcs.arstecnica.it/tailor-0.9.35.tar.gz"
+MD5SUM="58a6bc1c1d922b0b1e4579c6440448d1"
+MAINTAINER="João Felipe Santos"
+EMAIL="joao.eel[at]gmail.com"
+APPROVED="michiel"