summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Simon Coxall2010-05-11 20:00:23 +0200
committer Robby Workman2010-05-11 20:00:23 +0200
commite5e53d4c75f4df315bec8ff761a67dea1b002d98 (patch)
treeaf51f615ab2e3bd972acc9cb63992c43f86e3d5c /development
parent75bcf7a332a10c3afec2a7321492de93e6bc83a2 (diff)
downloadslackbuilds-e5e53d4c75f4df315bec8ff761a67dea1b002d98.tar.gz
development/easyedit: Added to 12.0 repository
Diffstat (limited to 'development')
-rw-r--r--development/easyedit/Makefile.diff13
-rw-r--r--development/easyedit/README8
-rw-r--r--development/easyedit/easyedit.SlackBuild84
-rw-r--r--development/easyedit/easyedit.info8
-rw-r--r--development/easyedit/slack-desc19
5 files changed, 132 insertions, 0 deletions
diff --git a/development/easyedit/Makefile.diff b/development/easyedit/Makefile.diff
new file mode 100644
index 0000000000..c8159db855
--- /dev/null
+++ b/development/easyedit/Makefile.diff
@@ -0,0 +1,13 @@
+--- Makefile.old 2007-07-10 13:39:00.000000000 +0100
++++ Makefile 2007-07-11 19:11:23.000000000 +0100
+@@ -21,8 +21,8 @@
+ @./create.make
+
+ install :
+- cp ee /usr/local/bin/ee
+- cp ee.1 /usr/local/man/man1/ee.1
++ cp ee $(DESTDIR)/usr/bin/ee
++ cp ee.1 $(DESTDIR)/usr/man/man1/ee.1
+
+ clean :
+ rm -f ee.o new_curse.o ee
diff --git a/development/easyedit/README b/development/easyedit/README
new file mode 100644
index 0000000000..45e0d7e4f7
--- /dev/null
+++ b/development/easyedit/README
@@ -0,0 +1,8 @@
+The editor 'ee' (easy editor) is intended to be a simple, easy to use
+terminal-based screen oriented editor that requires no instruction to use.
+It's primary use would be for people who are new to computers, or who use
+computers only for things like email.
+
+WARNING: Easy edit conflicts with Electric Eyes (an image viewer). If you
+have installed Electric Eyes, it must be uninstalled before installing
+easyedit. Electric Eyes is not part of a standard Slackware installation.
diff --git a/development/easyedit/easyedit.SlackBuild b/development/easyedit/easyedit.SlackBuild
new file mode 100644
index 0000000000..b56dc4007f
--- /dev/null
+++ b/development/easyedit/easyedit.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+# Easyedit.SlackBuild v2.0 2007/10/29
+# Copyright (c) 2007 Simon Coxall simoncoxall@yahoo.co.uk
+# All rights reserved.
+#
+# Permission to use, copy, modify, and distribute this software for
+# any purpose with or without fee is hereby granted, provided that
+# the above copyright notice and this permission notice appear in copies.
+#
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
+# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
+# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
+# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+# SUCH DAMAGE.
+#
+# ---------------------------------------------------------------------
+#
+# Auther: Simon Coxall simoncoxall@yahoo.co.uk
+# SlackBuild for easyedit (ee)
+# Source URL: http://mahon.cwx.net/sources/ee-1.4.6.src.tgz
+#
+# Version history:
+# v1. 2007/07/10 Initial build
+# v2. 2007/10/29 Revised to use system ncurses
+# ---------------------------------------------------------------------
+
+PRGNAM=easyedit
+VERSION=1.4.6
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="Artistic Changes README.ee ee.i18n.guide ee.msg"
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG/usr/{bin,doc,man/man1} $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+
+tar xvf $CWD/ee-$VERSION.src.tgz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R a-s,u+rw,go+r-w .
+
+# Patch the Makefile so it's installed to /usr instead of /usr/local
+# and also honours the DESTDIR=$PKG
+patch -p0 < $CWD/Makefile.diff
+
+# No ./configure required, just run make. However, we'll use the system ncurses
+# instead of the builtin version, as it doesn't seem to work properly.
+make curses -f make.default
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man/man1
+ gzip -9 ee.1
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/easyedit/easyedit.info b/development/easyedit/easyedit.info
new file mode 100644
index 0000000000..78f4719695
--- /dev/null
+++ b/development/easyedit/easyedit.info
@@ -0,0 +1,8 @@
+PRGNAM="easyedit"
+VERSION="1.4.6"
+HOMEPAGE="http://mahon.cwx.net"
+DOWNLOAD="http://mahon.cwx.net/sources/ee-1.4.6.src.tgz"
+MD5SUM="447c48341fc355dacc7e5d338dd1677a"
+MAINTAINER="Simon Coxall"
+EMAIL="simoncoxall@yahoo.co.uk"
+APPROVED="rworkman"
diff --git a/development/easyedit/slack-desc b/development/easyedit/slack-desc
new file mode 100644
index 0000000000..5d5ab6f4e3
--- /dev/null
+++ b/development/easyedit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+easyedit: easyedit (an easy to use text editor)
+easyedit:
+easyedit: The editor 'ee' (easy editor) is intended to be a simple, easy
+easyedit: to use, terminal-based screen oriented editor that requires no
+easyedit: instruction to use. It's primary use would be for people who
+easyedit: are new to computers, or who use computers only for things
+easyedit: like email.
+easyedit:
+easyedit:
+easyedit:
+easyedit: