summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Jick Nan2010-05-11 20:00:20 +0200
committer Robby Workman2010-05-11 20:00:20 +0200
commit614938484084d871e044d5e721606266654c4ebf (patch)
tree65d7dc1b92560a1a83b747b80f571237915876b8 /development
parenta98325d294f3095eeb3f929b9542ed9f2d035ad4 (diff)
downloadslackbuilds-614938484084d871e044d5e721606266654c4ebf.tar.gz
development/SilverCity: Added to 12.0 repository
Diffstat (limited to 'development')
-rw-r--r--development/SilverCity/README5
-rw-r--r--development/SilverCity/SilverCity.SlackBuild43
-rw-r--r--development/SilverCity/SilverCity.info8
-rw-r--r--development/SilverCity/slack-desc19
4 files changed, 75 insertions, 0 deletions
diff --git a/development/SilverCity/README b/development/SilverCity/README
new file mode 100644
index 0000000000..53781676bd
--- /dev/null
+++ b/development/SilverCity/README
@@ -0,0 +1,5 @@
+SilverCity (Python interface to Scintilla lexers)
+
+SilverCity is a lexing package, based on Scintilla, that can provide
+lexical analysis for over 20 programming and markup langauges. Included
+in the package are modules to convert source code to syntax-styled HTML.
diff --git a/development/SilverCity/SilverCity.SlackBuild b/development/SilverCity/SilverCity.SlackBuild
new file mode 100644
index 0000000000..81053d8fd4
--- /dev/null
+++ b/development/SilverCity/SilverCity.SlackBuild
@@ -0,0 +1,43 @@
+#!/bin/sh
+
+# Slackware build script for SilverCity.
+
+# Written by Jick Nan (jick.nan@gmail.com)
+
+PRGNAM=SilverCity
+VERSION=0.9.7
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py bdist || exit 1
+tar zxvf dist/$PRGNAM-$VERSION.linux-i686.tar.gz -C $PKG || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/SilverCity/SilverCity.info b/development/SilverCity/SilverCity.info
new file mode 100644
index 0000000000..02fb73e280
--- /dev/null
+++ b/development/SilverCity/SilverCity.info
@@ -0,0 +1,8 @@
+PRGNAM="SilverCity"
+VERSION="0.9.7"
+HOMEPAGE="http://silvercity.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/silvercity/SilverCity-0.9.7.tar.gz"
+MD5SUM="4ae4f9691798385dbde3df9cbb228e8c"
+MAINTAINER="Jick Nan"
+EMAIL="jick.nan@gmail.com"
+APPROVED="rworkman"
diff --git a/development/SilverCity/slack-desc b/development/SilverCity/slack-desc
new file mode 100644
index 0000000000..5fdc5ca02c
--- /dev/null
+++ b/development/SilverCity/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+SilverCity: SilverCity (Python interface to Scintilla lexers)
+SilverCity:
+SilverCity: SilverCity is a lexing package, based on Scintilla, that can
+SilverCity: provide lexical analysis for over 20 programming and markup
+SilverCity: languages. Included in the package are modules to convert
+SilverCity: source code to syntax-styled HTML.
+SilverCity:
+SilverCity:
+SilverCity:
+SilverCity:
+SilverCity: