summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2017-07-26 16:46:50 +0200
committer Willy Sudiarto Raharjo2017-07-27 09:44:45 +0200
commitdc9ba94bc739d38497b2dc55c49fef6d1a1df008 (patch)
tree93e79e828c5ec453c85f1d9d9d6e4a94efa60295 /development
parentb61db350a4b201979898cbdad7e47818cfb3e763 (diff)
downloadslackbuilds-dc9ba94bc739d38497b2dc55c49fef6d1a1df008.tar.gz
development/dissy: Removed (Project abandoned).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/dissy/README2
-rw-r--r--development/dissy/dissy.SlackBuild104
-rw-r--r--development/dissy/dissy.desktop9
-rw-r--r--development/dissy/dissy.info10
-rw-r--r--development/dissy/doinst.sh4
-rw-r--r--development/dissy/slack-desc19
6 files changed, 0 insertions, 148 deletions
diff --git a/development/dissy/README b/development/dissy/README
deleted file mode 100644
index fc17f51b6d..0000000000
--- a/development/dissy/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Dissy is a graphical frontend to the objdump disassembler.
-Dissy can be used for debugging and browsing compiler-generated code.
diff --git a/development/dissy/dissy.SlackBuild b/development/dissy/dissy.SlackBuild
deleted file mode 100644
index 2e82623723..0000000000
--- a/development/dissy/dissy.SlackBuild
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for dissy
-
-# Copyright 2010,2011 Vincent Batts, vbatts@hashbangbash.com, http://hashbangbash.com/
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=dissy
-VERSION=${VERSION:-10}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix manpage location.
-sed -i -e"s|share/man|man|" setup.py
-
-python setup.py install --root=$PKG
-
-# establish it in the xdg space
-mkdir -p $PKG/usr/share/applications
-cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
-
-mkdir -p $PKG/usr/share/pixmaps
-( cd $PKG/usr/share/pixmaps
- ln -s ../dissy/gfx/icon.svg dissy.svg
-)
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING ChangeLog MANIFEST README TODO UPGRADE \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
diff --git a/development/dissy/dissy.desktop b/development/dissy/dissy.desktop
deleted file mode 100644
index 9031cd9b70..0000000000
--- a/development/dissy/dissy.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=dissy
-GenericName=objdump Disassembler
-Comment=a graphical frontend to the objdump disassembler
-Exec=dissy
-Icon=dissy
-Categories=Development;
-Terminal=false
-Type=Application
diff --git a/development/dissy/dissy.info b/development/dissy/dissy.info
deleted file mode 100644
index b65cb59c73..0000000000
--- a/development/dissy/dissy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="dissy"
-VERSION="10"
-HOMEPAGE="http://code.google.com/p/dissy/"
-DOWNLOAD="http://dissy.googlecode.com/files/dissy-10.tar.gz"
-MD5SUM="04e50e2aa21e34df15617ff04acf4d1e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pywebkitgtk"
-MAINTAINER="Vincent Batts"
-EMAIL="vbatts@hashbangbash.com"
diff --git a/development/dissy/doinst.sh b/development/dissy/doinst.sh
deleted file mode 100644
index 4e8ba7071d..0000000000
--- a/development/dissy/doinst.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
diff --git a/development/dissy/slack-desc b/development/dissy/slack-desc
deleted file mode 100644
index f1ea84312c..0000000000
--- a/development/dissy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-dissy: dissy (graphical objdump disassembler)
-dissy:
-dissy: Dissy is a graphical frontend to the objdump disassembler.
-dissy: Dissy can be used for debugging and browsing compiler-generated code.
-dissy:
-dissy:
-dissy:
-dissy:
-dissy:
-dissy:
-dissy: